Willkommen

Shredder von Stefan Meyer-Kahlen

Shredder Classic, Shredder 9 UCI und Deep Shredder 9 UCI sind kommerzielle Schachprogramme der Shredder-Familie von Stefan Meyer-Kahlen.

Diese Anleitung vermittelt Ihnen alle erforderlichen Informationen, damit Sie Shredder effizient bedienen und erfolgreich für Ihr eigenes Schachtraining anwenden können.

Umgang mit dieser Hilfedatei

Neben dem Inhaltsverzeichnis können Sie über den Reiter Index auf bestimmte Themen zugreifen. Sollten Sie keinen Eintrag zum gewünschten Thema vorfinden, können Sie die Anleitung über den Reiter Suchen gezielt nach bestimmten Begriffen durchforsten. In diesem Fall werden alle Kapitel, in denen der Suchbegriff vorkommt, aufgelistet.

Sie können sämtliche Themen ausdrucken.


Hinweis

Shredder Classic, Shredder 9 UCI und Deep Shredder 9 UCI sind urheberrechtlich geschützte Programme.

Sie können Shredder Classic völlig unverbindlich für 30 Tage auf Ihrem Computer kostenlos testen. Danach müssen Sie sich entweder registrieren oder aber das Programm von Ihrer Festplatte löschen. Von Shredder 9 UCI und Deep Shredder 9 UCI existieren keine Testversionen, das Benutzerinterface ist jedoch bei allen drei Programmen gleich, sie unterscheiden sich nur durch die eingesetzte Schachengine sowie die jeweils erhältlichen Programmergänzungen.


Registrierung

Wenn Sie Shredder Classic nach 30 Tagen weiterhin benutzen möchten, müssen Sie sich einen Lizenzcode erwerben und sich registrieren. Shredder 9 UCI und Deep Shredder 9 UCI müssen direkt beim ersten Start mit einem erworbenen Lizenzcode registriert werden.

Weitere Informationen dazu finden Sie unter www.shredderchess.de .

Um einen Lizenzcode zu erwerben, klicken Sie einfach auf die Code erwerben-Schaltfläche. So kommen Sie automatisch auf die Bestellseite für Shredder im Internet.

Nach Eingang Ihrer Zahlung erhalten Sie umgehend zusammen mit Ihrem gewünschten Registrierungsnamen einen Registrierungscode, die Sie in dem folgenden Dialog eingeben müssen, um Shredder zu registrieren.

Sie können auswählen, ob Sie nur die GUI oder die Engine registrieren wollen. Da der Code in den jeweiligen Shredderversionen bei der GUI und der Engine jedoch gleich ist, ist es empfehlenswert, beides zusammen zu registrieren. Lassen Sie also einfach beide Felder aktiviert.

Sie müssen den Namen und Code exakt so eingeben, wie Sie in bei der Registrierung erhalten haben!

In der Regel erhalten Sie Ihren Code per Email. Es ist ratsam, den Code über die Zwischenablage in Shredder einzugeben. Dazu markieren Sie den Code in Ihrem Emailprogramm und kopieren ihn mit Strg-C in die Zwischenablage. Nun klicken Sie bei Shredder in das Editierfeld für den Code und drücken Strg-V.

Wenn ein gültiger Code eingegeben worden ist, dann wird die Schaltfläche "Registrieren" automatisch aktiviert. Geschieht dies nicht, dann überprüfen Sie bitte, ob Sie Ihren Registrierungsnamen und Code korrekt eingegeben haben.

Wenn Sie Shredder erfolgreich registriert haben, dann können Sie es uneingeschränkt und unbegrenzt weiter benutzen und die Dialoge, die Sie zum Registrieren auffordern erscheinen dann natürlich nicht mehr.


Kontakt

Sie erreichen die Homepage von Shredder im Internet unter www.shredderchess.de.


Der Autor

Stefan Meyer-Kahlen

Shredder ist ein Reihe von Schachprogrammen von Stefan Meyer-Kahlen. Der Autor ist Diplom Informatiker, verheiratet und lebt in Düsseldorf.

An Shredder arbeitet Stefan Meyer-Kahlen seit 1992.

Stefan Meyer-Kahlen hat mit seinem Schachprogramm Shredder seit 1996 bereits neun Titel als Computerschachweltmeister gewonnen.

· 1996 Mikrocomputerschachweltmeister in Jakarta

· 1999 Mikrocomputerschachweltmeister in Paderborn

· 1999 Computerschachweltmeister in Paderborn

· 2000 Mikrocomputerschachweltmeister in London

· 2001 Mikrocomputerschachweltermeister Single CPU in Maastricht

· 2002 Blitzcomputerschachweltmeister in Maastricht

· 2003 Computerschachweltmeister in Graz

· 2003 Blitzcomputerschachweltmeister in Graz

· 2004 Blitzcomputerschachweltmeister in Tel Aviv

Dazu kommen noch weitere Siege und Spitzenplazierungen bei bedeutenden Computerschachturnieren wie dem IPCCC in Paderborn

Das Eröffnungsbuch wurde von dem italienischen Eröffnungsexperten Sandro Necci erstellt und auf die Spielweise von Shredder abgestimmt.


Menüs

Die Menüs

Sämtliche Funktionen von Shredder können Sie über die Pull-Down-Menüs am oberen Bildschirmrand abrufen.

Folgende Pull-Down-Menüs stehen zur Verfügung:

  • Menü Datei

  • Menü Befehle

  • Menü Spielstufen

  • Menü Modus

  • Menü Extras

  • Menü Fenster

  • Menü Hilfe

Die Menüs enthalten teilweise Untermenüs mit weiteren Funktionen.

Viele Funktionen können Sie per Rechtsklick auf ein Bildschirmelement über die Kontextmenüs aufrufen.


Menü Datei

Neue Partie

Startet eine neue Partie mit den zuletzt aktiven Einstellungen, z.B. Spielstufe , Programmeinstellungen, u.s.w.

Neue Shuffle-Partie

Startet eine neue Partie ShuffleChess. Beim Shuffle-Chess variiert die Grundstellung der Figuren zu Beginn jeder Partie.

Shuffle-Chess bietet im Unterschied zum klassischen Schach mit vordefinierter Grundstellung den Vorteil, dass es weniger auf theoretisches Wissen, sondern auf flexibles Erfassen der Stellung ankommt.

Partie laden

Ruft die Partienliste der momentan aktiven Partiendatenbank auf. Zum Laden einer Partie doppelklicken Sie auf einen Eintrag in der Partienliste.

Partie speichern

Speichert die aktuelle Partie in der aktiven Datenbank.

Tragen Sie in der Eingabemaske die Namen der Spieler, Spielort, Turnier, Ergebnis u.s.w. ein.

Wenn Sie die Daten vollständig eingeben, erleichtern Sie sich spätere Suchabfragen innerhalb einer Datenbank.

Hinweis:achten Sie darauf, dass Sie unterschiedliche Partien möglichst mit einheitlicher Schreibweise erfassen. Wenn Sie z.B. Partien von Garry Kasparow einmal mit "Kasparow" und dann mit "Kasparov" erfassen, kann die Suchfunktion aufgrund der unterschiedlichen Schreibweisen nicht alle Partien dieses Spielers in der Datenbank finden.

Partie ersetzen

Ersetzt einen Eintrag innerhalb der Datenbank, bzw. Partienliste.

Partie löschen

Löscht eine Partie physisch und damit endgültig aus einer Datenbank.

Stellung laden

Lädt eine Stellung aus einer EPD-Datei. Shredder bietet einen sehr übersichtlichen Auswahldialog für EPD-Dateien, die mehrere Schachpositionen enthalten können. Die Funktionen in dem Auswahldialog sind weitgehend selbsterklärend. Sie können z.B. einen Listeneintrag im rechten Abschnitt mit der Maus anklicken, um sich die entsprechende Position im Vorschaufenster anzeigen zu lassen. Alternativ können Sie mit Hilfe der Pfeilschalter unter dem Schachbrett durch die Liste navigieren. Der Wert "5/30" bedeutet, dass von ingesamt 30 abgespeicherten Positionen der Eintrag Nr. 5 markiert wurde. Unter den Navigationsschaltern finden Sie den EPD-String mit der entsprechenden Schachposition.

Stellung speichern

Speichert eine Stellung innerhalb einer EPD-Datei.

Letzte Dateien

Shredder merkt sich die zuletzt geöffneten Datenbanken. Sie können mit Strg-X rasch die zuletzt bearbeiteten Dateien öffnen.

Stellung eingeben

Ruft die Stellungseingabe auf. Die aktuelle Stellung erscheint als Vorgabe in der Eingabemaske. Um eine Figur einzusetzen, klicken Sie die gewünschte Figurenart rechts neben dem Schachbrett an. Der Mauszeiger verwandelt sich in die gewählte Figur, wenn Sie ihn über das Brett bewegen. Klicken Sie auf das gewünschte Feld im Schachbrett, um die Figur einzusetzen.

Partie drucken

Druckt eine Partie aus. Sie können in der Eingabemaske Partiedaten nachtragen, bzw. ändern.

Stellung drucken

Druckt die aktuelle Stellung aus.

Beenden

Beendet Shredder. Die aktuellen Einstellungen werden gespeichert und beim Neustart wieder aktiviert.


Menü Befehle

Rechne / Seiten wechseln

Startet den Rechenvorgang des Programms. In einer laufenden Partie können Sie damit einen Seitenwechsel herbeiführen.

Unterbrechen

Unterbricht den Rechenvorgang des Programms. Shredder spielt den bislang besten Zug aus. Diese Funktion ist nur möglich, während das Programm rechnet.

Kopieren

Kopiert die aktuellen Partiedaten in die Windows-Zwischenablage. Sie können wählen, ob eine Partienotation (PGN), eine Position (EPD), der Inhalt des Analysefensters, nur die letzte Analyse oder die Partienotation im Textformat in die Zwischenablage kopiert werden soll. Sie können diese Daten mit anderen Windows-Anwendungen, z.B. einer Textverarbeitung, austauschen und bearbeiten.

Einfügen

Übernimmt den Inhalt der Zwischenablage, z.B. eine Notation im PGN-Format oder eine Schachposition im EPD-Format. Diese Formate finden Sie häufig im Internet, z.B. in E-Mails oder schachbezogenen Foren.

Remis anbieten

Sie können dem Programm jederzeit Remis anbieten, wenn Sie am Zug sind. Dieser Befehl ist nur während einer neuen Partie verfügbar. Anschliessend erhalten Sie vom Programm einen Hinweis, ob das Remis akzeptiert oder abgelehnt wird.

Aufgeben

Sie können dem Programm die Partieaufgabe mitteilen. Dieser Befehl ist nur während einer normalen Partie verfügbar.

Gehe zu Zug

Springt direkt zu einem bestimmten Zug. geben Sie die Zugnummer ein.

Partie vorführen

Spielt automatisch eine geladene Partie vor.

Hauptvariante vorspielen

Spielt die momentan berechnete Hauptvariante auf einem Variantenbrett vor. Sie können mit Hilfe der Pfeiltasten durch die Variante navigieren.Der Schalter "Automatisch" bewirkt, dass die aktuelle Variante automatisch vorgespielt wird. Aktualisieren bewirkt, dass die jeweils aktuell berechnete Hauptvariante angezeigt wird.

Hinweis: die Analyse wird dabei nicht unterbrochen.

Hauptvariante einfügen

Fügt die aktuell berechnete Hauptvariante incl. Stellungsbewertung und Zeit in die Partienotaton ein.

Besten Zug einfügen

Fügt den besten Zug in die Notation als Kommentar ein.

Partiedaten

Ruft die Eingabemaske zur Erfassung der Partiedaten auf.


Menü Spielstufen

Unter dem Menüpunkt Spielstufen können Sie, wieviel Zeit die Spieler verbrauchen dürfen.

Wie ein menschlicher Spieler, spielt Shredder um so stärker, je mehr Zeit er für die Berechnung zur Verfügung hat. Im Spielstufe-Menü können Sie zwischen verschiedenen festgelegten und programmierbaren Spielstufen wählen.

Blitz

In der Spielstufe Blitz kann eine Bedenkzeit für die gesamte Partie vorgegeben werden. Diese Bedenkzeit gilt in der Regel für beide Spieler.

Aufschlag: der angegebene Wert (Sekunden) wird für jeden Zug zur vorhandenen Bedenkzeit ausgeschlagen. Dies entspricht der sogenannten Fischer-Uhr.

Menschenbonus: Sie können mit einer höhreren Bedenkzeit als das Programm gegen Shredder spielen.

Zeit pro Zug

In der Spielstufe Zeit pro Zug hält sich Shredder entweder ungefähr oder genau an die eingestellte Vorgabezeit pro Zug.

Ausnahmen:

  • Shredder spielt aus dem Eröffnungsbuch

  • Shredder erkennt ein Matt

Wenn Sie die Option "Exakte Zeit" auswählen, wird Shredder versuchen, die Zeitvorgabe für den Zug genau einzuhalten. Wenn der Schalter deaktiviert ist, wird die Durchschnittszeit verwendet.

Die Stufe mit exakter Zeit pro Zug ist für normale Partien weniger geeignet als z.B. für Teststellungen. Wenn Sie EPD-Dateien mit vorgegebenen Bedenkzeiten lösen wollen, benutzen Sie diese Stufe.

Zeitkontrollen

Hier lassen sich bis zu drei verschiedene Zeitkontrollen bestimmen. Die dritte Zeitkontrolle wird nur angezeigt, wenn eine zweite Zeitkontrolle festgelegt wurde. Mit "Alle" bestimmen Sie, daß die Zeitkontrolle für den gesamten Rest der Partie gilt. Sie können auch einen Aufschlag angeben, der nach jedem Zug auf die Bedenkzeit aufaddiert wird.

Feste Suchtiefe

Mit Suchtiefe kann bestimmt werden, wie viele Halbzüge Shredder im voraus rechnen soll. Die dafür benötigte Zeit kann je nach Komplexität der Stellung unterschiedlich ausfallen. Stellungen mit vielen Figuren auf dem Brett benötgen deutlich mehr Rechenzeit als figurenarme Positionen.

Spielstärke beschränken

Hier können Sie Shredders Spielstärke beliebig beschränken und auf eine feste Elozahl einstellen. Je höher die Zahl, desto stärker spielt Shredder. Wenn Sie selber gegen das Programm spielen wollen, ist es sehr ratsam, die Spielstärke von Shredder mit dieser Funktion an die eigene Spielstärke anzupassen.

Wenn Sie im Spielstärke beschränken Dialog den Schieber ganz nach rechts stellen, dann spielt Shredder NICHT mit seiner vollen Spielstärke. Dazu müssen Sie diese Option völlig deaktivieren.


Menü Modus

Analyse

Startet die Hintergrundanalyse des Programms. In diesem Modus spielt Shredder oder die jeweils aktive Schachengine keine Züge aus. Während Sie Züge eingeben oder Partienotationen nachspielen, zeigt Shredder permanent seine Bewertung und weitere Informationen zum Suchvorgang in dem Analysefenster unter dem Schachbrett an.

Siehe Analysemodus

Siehe Züge auswählen

Spiel gegen Computer

In diesem Modus spielt Shredder basierend auf der gewählten Spielstufe seine Züge normal aus.

Züge eingeben

In diesem Modus können Sie Spielzüge auf dem grafischen Schachbrett eingeben. Shredder spielt keine Antwortzüge aus und zeigt keine Recheninformationen an.

Stellung ausspielen

Das Programm spielt gegen sich selbst. Sie können diese Funktion sinnvoll einsetzen, in dem Sie das Programm ab einer bestimmten Stellung die Züge für beide Seiten ausführen lassen.

TripleBrain

Beim Triple Brain handelt es sich um ein völlig neuartiges Konzept, um die Vorzüge zweier unterschiedlicher Engines miteinander zu kombinieren und das Optimum für die Analyse herauszuholen. Die "normalen" Schachengines analysieren eine bestimmte Position, während ein drittes Programm die Entscheidung trifft, welcher Zug die beste Alternative darstellt. Innerhalb von Shredder wird das Entscheidermodul als "Triple Brain" bezeichnet. Das Triple Brain zeigt in seinem eigenen Suchfenster eine Bewertungsskala von 0 - 100% an. Anhand des Prozentwertes kann der Anwender erkennen, wie sicher das Triple Brain bei der Beurteilung und Auswahl seines Zuges ist.

Partie analysieren

Shredder kann die aktuell geladene Partie vollautomatisch auf Fehler hin untersuchen. Wählen Sie dazu aus dem Modus-Menü den Eintrag "Partie analysieren" aus. Im folgenden Dialogfeld können Sie wählen, innerhalb welcher Züge und für welche Seite Shredder nach Fehlern suchen soll. Bereits vorhandene Kommentare oder Varianten können dabei optional gelöscht werden. Mit dem Schwellwert geben Sie an, ab wann Shredder einen alternativen Zug vorschlagen soll. Ein Schwellwert von 50 bedeutet zum Beispiel, daß nur ein anderer Zug vorgeschlagen werden soll, wenn er um eine halbe Bauerneinheit besser als der gespielte Zug ist. Bei einem Schwellwert von 0 gibt Shredder zu jedem Zug einen Alternativorschlag an. Shredders Vorschläge sowie deren Bewertung werden zusammen mit der Bewertung des gespielten Zuges als Variante bzw. Textkommentar zu der aktuellen Partie hinzugefügt. Sie können direkt die Zeit einstellen, die Shredder pro Zug rechnen soll. Siehe auch hier.

Stellungen analysieren

Shredder kann vollautomatisch alle Stellungen in einer EPD-, PGN- oder CBF Datei analysieren.Es kann für jede Stellung ein "Lösungszug" vorgegeben werden. Das Programm zeigt dann nach der Analyse eine Statistik der gelösten Stellungen an. Der Lösungszug muß in folgendem Format angegeben werden: "bm " (best move) und Zug in Kurznotation mit englischem Figurenbuchstaben (KQRBN für KDTLS), z.B. bm Nxf7 oder bm Bb5+.

Sie können den Kommentar (Lösungszug) beim Speichern einer Stellung eingeben. Falls Sie Lösungszüge in eine vorhandene EPD-Datei einfügen möchten, laden Sie diese mit einem Texteditor und fügen die Lösungszüge an das Ende der Stellungsbeschreibungen an.

Während der Analyse einer EPD-Datei können Sie mit dem Befehl "nächste Stellung" aus dem Spieler-Menü die Analyse der aktuellen Stellung abbrechen. Um die gesamte EPD-Analyse abzubrechen, wählen Sie einen beliebigen anderen Spielmodus, z.B. "Normal" oder "Analyse".

In Testsuites wie z.B. dem BT-2830-Test o.ä. wird nun nach Einstellung der Anzahl der Plies, die nach gefundener Lösung noch weiter gerechnet werden soll, korrekt abgebrochen.

Nach Abschluß einer EPD-Analyse werden im Analysefenster zwei Tabellen angezeigt. Die erste Tabelle gibt die Lösungszeit (in Sekunden) jeder Stellung an, die zweite Tabelle zeigt, wieviele Stellungen zum jeweiligen Zeitpunkt gelöst wurden. Es werden auch automatisch zwei Dateien im Shredder-Verzeichnis angelegt, die eine einfache Auswertung des Tests ermöglichen. Eine Datei ist im EPD-Format, die andere im CSV-Format, welches man direkt in viele gängige Tabellenkalkulationsprogramme importieren kann.

Autoplayer starten

Shredder verfügt über eine eingebaute Schnittstelle zum Auto232-System. Mit Auto232 können Schachprogramme auf zwei PCs vollautomatisch gegeneinander spielen.

Engine-Zweikampf

Sie können zwei Engines unter dem Interface von Shredder vollautomatisch gegeneinander spielen lassen. Die Partien eines Matches werden in einer PGN-Datei gespeichert. Beim Einsatz auf einem Single-System ist es sinnvoll, das Permanent Brain abzuschalten.

Engine-Turnier

Sie können mehrere Engines unter dem Interface von Shredder vollautomatisch ein Turnier austragen lassen.

Externes Brett

Shredder unterstützt die elektronischen PC-Schachbretter der Firma TASC und der Firma DGT. Sie können die Züge auf diesem Schachbrett eingeben, die Züge des Schachprogramms werden über die LED-Dioden des Smartboards angezeigt.

Vor dem ersten Einsatz des TASC-Bretters unter Shredder müssen Sie die Anbindung des Smartboards mit dem Tool "Smartmon.exe" initialisieren. Beachten Sie dazu auch Hinweise in der Dokumentation des Smartboards.

Hinweis: das TASC-Brett funktioniert nur unter Windows 95, 98 und ME.

Für das DGT-Brett müssen Sie zunächst den Treiber des Brettes installieren. Beachten Sie dazu auch die Hinweise in der Dokumentation des DGT-Brettes.


Menü Extras

In dem Menü Extras befinden sich die Untermenüs für den Engines, Eröffnungsbuch, das Endspielorakel und die Optionen.

Untermenü Engines

Hinweis: weitere wichtige Funktionen können Sie mit einem Rechtsklick auf das Analysefenster aus dem Kontextmenü abrufen.

Permanent Brain

Die Fähigkeit eines Schachprogramms, in der gegnerischen Bedenkzeit zu rechnen. Shredder konzentriert seine Analyse auf den erwarteten Gegenzug. Wird der erwartete Zug ausgespielt, hat Shredder wertvolle Rechenzeit eingespart.

Hinweis: Shredder zeigt übrigens den erwarteten Gegenzug im Analysefenster an. Permanent Brain-Analysen werden durch eine andere Farbe gekennzeichnet.

Engine installieren

Installiert , bzw. bindet eine Engine unter dem Interface von Shredder ein. Um eine neue Engine unter Shredder einzubinden, gehen Sie wie folgt vor:

  • Wählen Sie im Menü Engines den Eintrag "Installiere Engine".

  • Wählen Sie in der Auswahlmaske den entsprechenden Enginetyp aus. Bei UCI-Engines wählen Sie "UCI", bei Winboard-Engines den Eintrag "Winboard-Engine".

  • Nachdem Sie den Enginetyp festgelegt haben, geben Sie die Pfadangabe zum Ordner der Engine vor. Sie können dies komfortabel in der Dialogbox mit der Maus bewerkstelligen, indem Sie auf den Button mit den drei Punkten klicken.

  • Wählen Sie in der Dateiauswahlmaske den Pfad zu der Engine aus.

  • Anschliessend müssen Sie noch einen Namen für die Engine vorgeben. Diese Bezeichnung wird im späteren Ladedialog für eine Engine angezeigt. Zusätzlich können Sie in der Eingabemaske noch den Namen des Autoren der Engine eintragen.

Nach diesen Schritten ist die Engine unter Shredder angemeldet und kann über die hier beschriebenen Befehle geladen und gestartet werden.

Engine deinstallieren

Entfernt eine Engine aus dem Ladedialog. Hinweis: die Engine wird nicht physisch von dem Datenträger gelöscht !

Enginedatei editieren

Sie haben die Möglichkeit, die Asciidatei mit der Endung *.ENG, die die Anbindung an das Interface steuert, direkt aus Shredder heraus zu editieren. Shredder startet dazu automatisch den im Lieferumfang von Windows enthaltenen Texteditor "Notepad".

Falls Sie eine der Konfigurationsdateien der WB-Engines ediitieren und anpassen wollen, müssen Sie dies ebenfalls mit einem Texteditor tun. Die Konfigurationsdateien von WB-Engines haben oft unterschiedliche Dateiendungen und setzen unterschiedliche Einträge voraus. Beachten Sie die Hinweise in den beiliegenden Textdateien der jeweiligen Winboard-Engine.

Endspieldatenbanken

Ruft den Dialog mit den Einstellungen für die Endspieldatenbanken auf.

Untermenü Eröffnungsbuch

Das Eröffnungsbuch von Shredder ist in einem Positionsbaum gespeichert. Das mitgelieferte Eröffnungsbuch enthält ca. 20000 Züge und wurde von dem Eröffnungsexperten Sandro Necci aus Italien sorgfältig editiert. Die Bibliothek berücksichtigt Zugumstellungen.

Neues Eröffnungsbuch

Legt ein neues Eröffnungsbuch an. Die Dateiendung für die Eröffnungsbücher von Shredder lautet *.BKT. Sie können diese Bücher durch Import von CBF- oder PGN-Datenbanken erweitern.

Eröffnungsbuch laden

Lädt ein existierendes Eröffnungsbuch. Hinweis: es kann immer nur ein Buch aktiv sein.

Eröffnungsbuch importieren

Neben Datenbanken kann ein Positionsbaum durch den Import von Eröffnungsbüchern anderer Schachprogramme erweitert werden. Zur Auswahl stehen Bücher der Programme ChessGenius 1 - 5, Rebel und Fritz 1 - 4. Man kann auch bereits existierende Positionsbäume importieren.

Partien importieren

Es können Datenbanken im CBF- und PGN-Format in ein bestehendes Eröffnungsbuch von Shredder importiert werden. Dabei können Sie über eine Dialogmaske mit den nachstehend beschriebenen Optionen den Import kontrollieren:

  • Varianten importieren Datenbanken können neben reinen Notationen auch Varianten enthalten. Bei Aktivierung dieser Funktion werden Varianten in den Positionsbaum integriert.

  • Statistik importieren berücksichtigt die Erfolgskoeffizienten von Zügen und Partien

  • Zugbewertung importieren berücksichtigt beim Import von Büchern oder Datenbanken vorhandene Zugwertungen

  • Die Variantentiefe kann beim Import der Daten mit der Vorgabe Halbzüge ebenfalls gesteuert werden.

  • absolute Länge legt die Tiefe in Halbzügen fest, mit der eine Variante in den Positionsbaum integriert werden soll.

  • ECO-relative Länge legt die Tiefe in Halbzügen fest, mit der eine Variante nach der zuletzt vorgefundenen ECO-Stellung importiert werden soll.

Aktuelle Partie importieren

importiert die aktuell geladene Partie in den Positionsbaum

Eröffnungsbuch exportieren

Shredder-Bücher können in ein Textformat exportiert werden. Dies ist vor allem interessant, wenn Sie das Programm Pocket Fritz besitzen. Weitere Informationen finden Sie hier ......

Buchzüge zählen

gibt eine Information über die effektive Anzahl von Eröffnungszügen im Positionsbaum aus

Eröffnungsbuch jäten

Shredder überprüft den Inhalt des Positionsbaums. Z.B. werden Züge, die nur auf einer geringen Partienzahl basieren, entfernt.

Partie übertragen

Hier können Sie einstellen, dass Shredder die aktuelle Partie nach jedem ausgeführten Zug automatisch in einer Datei speichern soll. Sie können wählen, ob dies mit oder ohne Kommentaren geschehen soll. Diese Funktion kann man verwenden, um Partien mit geeigneten Zusatztools "live" zu übertragen.

Endspielorakel

Ruft den Dialog für das Endspielorakel auf.

Optionen

Unter den Optionen können Sie die Grundeinstellungen des Programms verändern.


Menü Fenster

Schachbrett

Schaltet die Darstellung des grafischen Schachbrettes ein oder aus.

Uhren

Schaltet die Schachuhr ein oder aus.

Partie

Schaltet das Fenster mit der Partienotation, Kommentaren und Varianten an oder aus.

Suchinformationen

Die Anzeige der Suchinformationen im Analysefenster kann an- oder abgeschaltet werden. Falls Sie gegen Shredder oder eine der anderen Engines eine ernste Partie spielen wollen, ohne vorab Informationen und Bewertungen des Programms zu erhalten, sollten Sie das Analysefenster abschalten.

Züge

Schaltet das Zügefenster ab. Im Zügefenster werden je nach Einstellung (rechte Maustaste!) die Eröffnungszüge des Positionsbaums, alle legalen Züge oder die statistischen Angaben der Endspieldatenbank angezeigt.

Partieprofil

Im Partieprofil wird grafisch der Partieverlauf angezeigt.

Untermenüs

Design

Im Untermenü Design können Sie benutzerdefiniert Ihre bevorzugten Einstellungen vornehmen.Sie können die Farben frei einstellen, unterschiedliche Hintergründe laden oder die Titelzeilen an - oder ausschalten. Designs haben immer die Dateiendung *.SDN.

Titelzeilen

Blendet die Titelzeilen der jeweiligen Fenster aus. Dies macht vor allem beim Einsatz von Shredder auf kleineren Bildschirmen oder Notebooks Sinn.

Layout

Unter dem Eintrag Layout können Sie zwischen mehreren vordefinierten Bildschirmeinstellungen auswählen. Sie können in diesem Menü eigene Bildschirmeinstellungen in sogenannten Benutzerlayouts speichern und diese zu einem späteren Zeitpunkt wieder laden. Layouts haben immer die dateiendung SLO.


Menü Hilfe

Hilfe

Ruft die Onlinehilfe von Shredder auf. Sie können die Hilfe jederzeit mit F1 aus dem Programm heraus aufrufen.

Zugvorschlag

Wenn Sie am Zug sind, können Sie über diese Funktion einen Zugvorschlag abrufen. Shredder führt seinen Zugvorschlag kurz auf dem Schachbrett aus. Wenn Shredder Classis am Zug ist, zeigt er den bisher berechneten besten Zug kurz an.

Trainer passt auf

Schaltet den Schachtrainer ein oder aus.

Registrieren

Hier können Sie Ihre Version von Shredder durch die Eingabe Ihres Namens und Ihres persönlichen Benutzercodes registrieren . Wenn der Menüpunkt nicht aktivierbar ist, dann ist das Programm sowie die gerade geladene Engine schon registriert.

Programm aktualisieren

Sie können Shredder veranlassen, im Internet bei www.shredderchess.com nach Programmupdates zu suchen. Findet Shredder eine neue Version, dann werden Sie gefragt, ob Sie Ihre Version automatisch aktualisieren möchten. Beim Überprüfen auf Updates sendet Shredder Ihren Lizenzcode verschlüsselt an unseren Server, damit wir anhand unserer Kundendatenbank überprüfen können, ob es sich um eine legale Updateanfrage handelt.

Upgrade Informationen

Ruft bei aktiver Onlineverbindung eine Seite im Internet auf, auf der Sie sich über kostenpflichtige Upgrades Ihrer Version informieren können (nur in der registrierten Version, nicht bei Deep Shredder).

Shredder Homepage

Ruft bei aktiver Onlineverbindung die Homepage von Shredder auf.

Nutzen Sie die Möglichkeit, sich über Neuerungen und aktuelle Entwicklungen bei Shredder zu informieren.

Über Shredder

Blendet Informationen über das Programm ein.


Rechtsklicks

Ein ganz wichtiges Bedienungselement sind neben den Pull-Down-Menüs mit den Funktionseinträgen die zahlreichen Kontextmenüs. Über die Kontextmenüs können Sie mit einem Rechtsklick der Maus auf ein Fenster situationsbezogene Funktionen aufrufen.

Viele kontextbezogene Funktionen lassen sich mit einem Rechtsklick der Maus auf ein Bildschirmelement, z.B. auf die Schachuhr, schneller abrufen. Diese Methode führt häufig schneller zum Ziel als der Aufruf über die Menüs.

Beispiel: nach einem Rechtsklick auf das Schachbrett stehen Ihnen auf Anhieb wichtige Funktionen wie Brett drehen, Stellungseingabe oder Auswahl zwischen verschiedenen Figuren- und Schachbrettern zur Verfügung.

Tipp ! Kontextmenüs stehen für jedes der Bildschirmelemente wie Schachbrett, Schachuhr, Notation, Analysefenster u.s.w. zur Verfügung. Sie sollten daher häufig von der rechten Maustaste Gebrauch machen.


Doppelklicks

Sie können im Hauptbildschirm von Shredder wichtige Funktionen mit einem simplen Doppelklick der linken Maustaste starten. Diese Möglichkeit steht in fast jedem Fenster des Bildschirms zur Verfügung.

Doppelklick Schachuhr

Ruft die Dialogmaske zum Einstellen der Bedenkzeiten auf.

Klick Partieprofil

Mit einem Klick in das Partieprofil laden Sie direkt die entsprechende Brettstellung auf das grafische Schachbrett.

Doppelklick Partieheader

Ruft die entsprechende Dialogbox zum Editieren der Partiedaten auf.

Doppelklick Notationsfenster

Sie können Partien, bzw. einzelne Züge, mit Shredder kommentieren. Ein Doppelklick auf einen Zug im Notationsfenster ruft eine Dialogbox auf, in der Sie das gewünschte Kommentierungssymbol auswählen können.

Wählen Sie das gewünschte Kommentarsymbol mit der Maus aus und bestätigen mit OK. Der Kommentar wird jetzt in die Notation übernommen.

Doppelklick Enginename

Direkt über dem Analysefenster befindet sich die Anzeige der aktiven Schachengine.

Mit einem Doppelklick auf diesen Button starten Sie den Auswahldialog zum Laden einer Schachengine.

Klick Zuganzeige

Über dem Analysefenster befindet sich die Anzeige des von der Engine erwarteten Zuges des Spielers, wenn dieser am Zug ist. Mit einem Mausklick wird der Zug ausgespielt und auf das grafische Schachbrett übertragen.


Funktionsleiste

Die Funktionsleiste

Auf dem Bildschirm finden Sie unterhalb der Menüeinträge die Schnellstartleiste. Über die Schnellstartleiste können Sie besonders häufig genutzte Funktionen per Mausklick abrufen und so das Programm flüssig bedienen.

Funktionsleiste Shredder Classic

Mit einem Rechtsklick auf die Funktionsleiste können Sie die Größe der Symbole verändern und verschiedene Symbolgruppen ein- und ausblenden.

Wenn Sie bei der Arbeit mit Shredder mit dem Mauszeiger etwas länger auf einem Symbol verharren, wird eine Erklärung zu der entsprechenden Funktion eingeblendet.


Shortcuts

Viele Funktionen von Shredder lassen sich über Tastenkombinationen auf der Tastatur direkt eingeben. Solche Tastenkombinationen bezeichnet man als "Shortcut" oder "Hotkey".

Neben den Menüeinträgen finden Sie - falls vorhanden - den entsprechenden Hotkey. Z.B. starten Sie eine neue Partie mit der Tastenkombination STRG-N. Falls Sie gerne mit der Tastatur arbeiten, sollten Sie sich die Shortcuts für die bevorzugten Funktionen einprägen.


Optionen

Dialog Optionen

Über den Dialog Optionen können Sie die wichtige Grundeinstellungen von Shredder ändern.

Am schnellsten starten Sie den Dialog mit der Taste F12. Alternativ können Sie den Dialog über das Menü Extras / Optionen aufrufen.

Koordinaten anzeigen

Schaltet die Anzeige der Koordinaten neben dem Schachbrett an oder aus.

Schnelle Mauseingabe

Wenn nur eine einzige Figur auf ein Zielfeld ziehen kann, genügt es für die Zugeingabe, wenn man das Zielfeld anklickt. Beispiel: Wenn Sie als Weißer in der Grundstellung das Feld e4 anklicken, wird der Zug umgehend ausgeführt. Analog zieht eine eine angeklickte Figur auch sofort, wenn Sie nur einen legalen Zug hat.

Wird die Option abgeschaltet, müssen Sie Ausgangs- und Zielfeld anklicken oder die Figur zum Zielfeld ziehen.

Bedenkzeit anpassen

Wird während einer Partie die Stufe gewechselt, dann wird die bisher verbrauchte bzw. verbleibende Bedenkzeit angepasst. Beispiel: Sie spielen 40/15, beide Seiten haben noch 6 Minuten auf der Uhr. Sie stehen auf Gewinn und wollen zu 40/5 wechseln. Ohne Anpassung bleiben es nach dem Levelwechsel bei 6 Minuten, mit Anpassung sind es für beide nur noch 2 Minuten.

Zeitüberschreitung reklamieren

Wenn Sie oder Shredder die Bedenkzeit überschreiten, blendet Shredder eine Dialogbox ein und weist Sie darauf hin. Wenn Sie diese Information nicht wünschen, können Sie den Dialog abschalten.

Alle Hauptvarianten anzeigen

Das Programm zeigt alle berechneten Hauptvarianten im Analysefenster an. Per Default zeigt Shredder die Hauptvatianten seiner Suche erst nach einer

Sekunde an. Mit dieser Option werden alle Hauptvarianten angezeigt, also sofort nach dem Beginn der Suche.

Aktuelle Variante anzeigen

Das Programm zeigt jede Sekunde im Analysefenster an, an welcher Variante es gerade rechnet.

Etikette

Shredder kann Partien aufgeben und Remis anbieten/ablehnen. Dies ist übrigens auch bei Enginematches und Engineturnieren möglich. Das funktioniert aber nur dann, wenn die Option Etikette aktiviert ist.

Automatisches Speichern

Hier können Sie einstellen, ob Shredder ein Protokoll über alle gespielten Partien anlegen soll. Alle gespielten Partien werden automatisch in der Datei "autosave.pgn" gespeichert.

Automatische Updates

Sie können einstellen, ob Shredder beim Programmstart automatisch nach Updates für das Programm im Internet bei www.shredderchess.com suchen soll. Ist die Option aktiviert, dann überprüft Shredder regelmäßig, ob eine neue Version verfügbar ist. Ist dies der Fall, wird auf Nachfrage Shredder automatisch aktualisiert.

Firgurentempo

Stellt die Geschwindigkeit ein, mit der sich die Figuren über das Brett bewegen. Bei 0 springen die Figuren sofort vom Start- auf das Zielfeld.

Züge ansagen

Die Notation wird über über die Lautsprecher angesagt. Dies macht vor allem dann Sinn, wenn Sie das DGT-Brett einsetzen.

Zuggeräusche

Sie können entscheiden, ob das Programm Sie mit einem Tonsignal auf einen gespielten Zug aufmerksam macht.

Trainer

Shredder macht Sie auf Fehler aufmerksam. Sie können über die Parameter Schwellwert und Rechenzeit festlegen, in welchen Situationen sich der "Coach" in die Partie einschaltet.

Schwellwert

Der Coach blendet sich nur dann ein, wenn die Bewertung des stärksten und die Bewertung des Partiezugs um den gewählten Schwellwert (in Hundertstel Bauerneinheiten) abweicht.

Rechenzeit

Legt die Mindestrechenzeit für die Funktion fest

Endspieldatenbanken -> siehe hier ....

Buchoptionen -> siehe hier ....

Engineoptionen -> siehe hier .....


Startoptionen

Sie können Shredder mit den Standard-Einstellungen starten, wenn Sie Shredder mit gedrückter Umschalt-Taste starten.

Sie können verhindern, daß die letzte Partie geladen wird, wenn Sie Shredder mit gedrückter Strg-Taste starten.


Aufbau

Der Bildschirmaufbau von Shredder

Der Shredder-Bildschirm besteht aus mehreren Elementen (sechs Fenstern, Funktionsleiste und Statuszeile).

Jedes Element kann mit den Befehlen aus dem Fenster-Menü geschlossen und wieder geöffnet werden.

Alle Fenster können verschoben und in der Größe geändert werden, dabei werden die angrenzenden Fenster automatisch in ihrer Größe angepaßt. Dies können Sie verhindern, indem Sie beim Ziehen mit der Maus die Alt-Taste gedrückt halten.

Es gibt mehrere vordefinierte Layouts (Einteilungen des Bildschirms), die mit "Layout ändern" und "Layout wählen" aus dem Menü Fenster -> Fensterlayout ausgewählt werden können.

Das Schachbrett

Notationsfenster

Schachuhren

Zügefenster

Partieprofil

Suchinformationen

Analysefenster

Symbolleiste

Statuszeile

Titelzeilen

3D-Schachbrett

Die Befehlszeile

Materialdifferenz


Schachbrett

Das Schachbrett

Das Schachbrett kann zweidimensional oder in 3D-Grafik angezeigt werden. Um zwischen den beiden Darstellungen zu wechseln, betätigen Sie STRG-3 oder klicken in der Symbolleiste auf den entsprechenden Button.

Wenn Sie die Größe des Schachbretts ändern, paßt sich die Größe der Figuren automatisch an.

Die Bildschirmfarben (2D-Schachbrett, 2D-Figuren, Text, Hintergrund) können geändert werden.

Menü Fenster -> Design -> Farben.

Die Koordinaten (Beschriftung der Linien und Reihen) können ausgeblendet werden.

Menü Extras - Optionen - Koordinaten anzeigen.

Der letzte Computerzug wird auf dem Schachbrett mit einem farbigen Rahmen markiert. Sobald Sie den Mauszeiger bewegen, wird dieser Hinweis ausgeblendet.

Tipp ! Mit den Tasten F3 (Figuren) und F4 (Schachbretter) können Sie schnell die verfügbaren Komponenten wechseln. Alternativ können Sie dies auch mit einem Rechtsklick auf das Schachbrett mit dem Kontextmenü machen.


Schachuhren

Sie können zwischen verschiedenen Darstellungen der Schachuhr wählen.

Rechtsklick auf das Uhrenfenster ruft das Kontextmenü der Schachuhr auf.

Einfach

Eine einfache Darstellung der Schachuhr mit Bedenkzeiten für Weiß und Schwarz. (Stunde/Minute/Sekunden).

Doppelt

Wie Einfach, zusätzlich wird die verbrauchte Zugzeit pro Seite angezeigt.

Digital Weiß

Digitale Darstellung mit weißem Hintergrund

Digital Schwarz

Digitale Darstellung mit schwarzem Hintergrund

Uhren einstellen

Hier können Sie die bisher verbrauchte Zeit einstellen

Spielstufe

Ändert die eingestellte Spielstufe

Logo

Schaltet das Logo ein oder aus

Schießen

Schließt das Uhrenfenster

Tipp ! Die Buttons neben der Schachuhr zeigen an, welche Seite gerade am Zug ist.


Notation

Notationsfenster

Im Notationsfenster werden die Züge der aktuellen Partie incl. Kommentaren und Varianten sowie einschliesslich der Partiedaten angezeigt.

Tipp ! Sie können die Darstellung der Schriftfonts und deren Größe benutzerdefiniert einstellen.

  • Klicken Sie mit der rechten Maustaste auf das Notationsfenster.

  • Klicken Sie auf den Eintrag Zeichensatz.

  • Stellen Sie die gewünschte Grösse und Schrifttyp ein.

Mit dem Mausrad können Sie Züge schnell vor- und zurückspielen.

Den zuletzt ausgespielten Zug können Sie mit einer benutzerdefinierten Farbauswahl hervorheben.

Menü Fenster -> Design -> Farben - Aktueller Zug.


Zügefenster

Das Züge-Fenster befindet sich am rechten Bildschirmrand.

Per Rechtsklick auf das Zügefenster können folgende Informationen angezeigt werden:

  • Züge aus dem Eröffnungsbuch inkl. zahlreicher eingebetteter Statistiken

  • alle legalen Züge sowie optional für alle Züge eine Widerlegung des Schachprogramms sowie die Reihenfolge, in der das Schachprogramm die Züge durchsucht hat. Bitte beachten Sie, dass das Schachprogramm nicht immer für alle Züge die beste Widerlegung berechnet sondern häufig nur eine, die gut genug ist. Die angegebenen Varianten sind deshalb mit etwas Vorsicht zu betrachten. Dieses Feature kostet dafür jedoch keine zusätzliche Rechenzeit der Engine.

  • Informationen aus der Endspieldatenbank . Hier erscheint ein Button mit der Beschriftung Online. Sie können damit die aktuelle Stellung in der Onlineendspieldatenbank von Shredder abfragen.

Mit automatisch können Sie einstellen, dass die Anzeige immer automatischen zwischen den drei Möglichkeiten auswählt. Sind in einer Stellung Buchzüge vorhanden, dann werden diese angezeigt. Bei Stellungen mit sechs oder weniger Figuren werden sofern vorhanden die Werte aus den Datenbanken angezeigt, ansonsten die legalen Züge.

Wenn Sie einen Zug im Züge-Fenster anklicken, wird er ausgespielt.

Mit einem Rechtsklick rufen Sie das Kontextmenü zu diesem Fenster auf.

Falls die Züge aus dem Eröffnungsbuch angezeigt werden, können Sie mit einem Rechtsklick direkt auf den Zug die gespeicherten Werte des Zuges im Eröffnungsbuch ändern.


Partieprofil

Das Partieprofil zeigt graphisch die Stellungsbewertungen des Schachprogramms im Partieverlauf sowie den Bedenkzeitverbrauch an.

Sie können so Aufhieb erkennen, wo nach Einschätzung des Programms die Partie "gekippt" ist.

Vorteil für Weiß wird oberhalb der Trennlinie, Vorteil für Schwarz unterhalb der Trennlinie angezeigt. Grün bedeutet einen Vorteil für das Schachprogramm, Rot für den menschlischen Spieler.Die schwarzen und blauen Linien kennzeichnen den Verbrauch der Bedenkzeit.

Mit einem Klick in die Markierung übertragen Sie die entsprechende Stellung auf das Schachbrett.

Auf der x-Achse werden die Züge der Partie abgetragen, auf der y-Achse die Bewertung (in Zentibauern), bzw. den Zeitverbrauch.

  • Blaue Kurve: Zeitverbrauch von Weiß.

  • Schwarze Kurve: Zeitverbrauch von Schwarz.

  • Grüne Bewertung: Programm steht besser.

  • Rote Bewertung: Gegner steht besser.

  • Bewertung nach unten gerichtet: Schwarz steht besser.

  • Bewertung nach oben gerichtet: Weiß steht besser.

  • Türkise Markierung links im Fenster: Zeigt Züge an, die aus dem Eröffnungsbuch gespielt worden sind.

  • Türkiser Balken am rechten Fensterrand: Zeigt mit einer Balkengrafik die Skalierung des Fensters an.


Suchinformatonen

Suchinformationen

Im Suchinformations-Fenster zeigt das Programm seine Analysen an. Wenn mehrere Engines parallel laufen, werden die Anzeigen sämtlicher aktiver Engines mit einheitlichen Informationen dargestellt.

Wichtige Informationen zum Suchvorgang werden übersichtlich im Suchfenster der aktiven Engine angezeigt. Sie erkennen sofort alle relevanten Informationen auf einen Blick.

Engine rechnet

  • Anzeige der jeweils aktiven Schachengine

  • Momentan berechneter Zug inkl. Wert innerhalb der Zugliste

  • Rechentiefe (brute-force/selektiv)

  • Zugzeit

  • Stellungsbewertung der Schachengine (farbig markiert)

  • Bewertete Positionen pro Sekunde

  • Auslastungsgrad der HashTabellen

Anwender am Zug

  • Anzeige des vom Anwender erwarteten Zuges -- wird neben dem Füllstand der HashTables farbig markiert angezeigt.

  • Anzeige des besten Zuges in grau unterlegter Schrift nach dem erwarteten Antwortzug des Spielers.

Eine nützliche Hilfe zum Verständnis der angezeigten Hauptvarianten ist das Variantenbrett, das Sie jederzeit mit der Taste F11 aufrufen können, wenn eine Schachengine rechnet.


Analysefenster

Im Suchfenster werden die Ergebnisse des Suchvorgangs der jeweils aktiven Engine "scrollend" nacheinander dargestellt. In jeder Zeile finden sie folgende Informationen:

  • Suchtiefe

  • Zugzeit, die Bewertung hat sich in diesem Zeitraum geändert

  • Bewertung in Bauerneinheiten

  • Aktuell berechnete Variante

  • Gesamtzahl der bewerteten Positionen

  • Durchschnitt der bewerteten Positionen pro Sekunde

Die aktuell vom Programm berechnete Hauptvariante wird zur besseren Orientierung farbig angezeigt.

Die farbliche Anzeige der Hauptvariante und der Informationen im Suchfenster hängt von den Einstellungen ab, die Sie unter Fenster -> Design -> Farben vorgenommen haben. Wenn Sie für den aktuellen Zug rote Farbe einstellen, sieht die Darstellung wie folgt aus:

Nachdem das Programm seinen Zug ausgespielt hat, wird in der Liste der beste Zug noch einmal mit wichtigen Informationen farbig angezeigt.

Tipp ! Analysen des Permanent Brains werden mit einer anderen Farbe gekennzeichnet

Wenn Sie im Kontextmenü Fortlaufende Anzeige einschalten, wird das Fenster erst beim Beenden des Programms gelöscht, ansonsten vor jeder neuen Analyse einer Stellung. Sie können dann jederzeit mit der Bildlaufleiste im Fenster zurückblättern, um Analysen früherer Züge zu sehen.

Sie können komfortabel mit der Tastatur durch das Analysefenster navigieren. Halten Sie die STRG und UMSCHALT gedrückt und verwenden Sie folgende Tasten:

  • Strg+Shift+PFEIL-NACH OBEN eine Zeile nach oben

  • Strg+Shift+PFEIL-NACH-UNTEN eine Zeile nach unten

  • Strg+Shift+BILD-NACH-OBEN eine Seite nach oben

  • Strg+Shift+BILD-NACH-UNTEN eine Seite nach unten

  • Strg+Shift+POS1 an den Anfang des Fensters

  • Strg+Shift+ENDE zum Ende des Fensters

  • Strg+Shift+DEL löscht den Inhalt des Fensters

Die Informationen im Analyse-Fenster können zusätzlich in eine Textdatei geschrieben werden. Klicken Sie mit der rechten Maustaste in das Analysefenster und wählen Sie aus dem Kontextmenü "Protokolldatei".

So können Sie Ihre Analyse in die Zwischenablage kopieren:

Rechtsklick - Kopiere (Alt+Umschalt+C) kopiert den Inhalt des Analysefensters in die Zwischenablage.

Rechtsklick - Kopiere letzte Analyse (Alt+C) kopiert nur die Analyse der letzten Stellung formatiert in die Zwischenablage.


Symbolleiste

In der Funktionsleiste befinden sich 28 Schaltflächen für die wichtigsten Befehle. Bewegen Sie den Mauszeiger auf eine Schaltfläche und warten Sie eine halbe Sekunde. Dann wird eine Beschreibung der Schaltfläche angezeigt. Mit einem Rechtsklick können Sie das Erscheinungsbild der Symbolleiste ändern.


Statuszeile

In der Statuszeile am unteren Rand des Programmfensters werden folgende Informationen angezeigt:

  • Seite am Zug (Weiß oder Schwarz)

  • Status des Programms (rechne, rechne im Hintergrund, analysiere, warte)

  • die eingestellte Spielstufe


Titelzeilen

In der Titelzeile der Fenster oder des Programms erkennen Sie häufig sehr wichtige Informationen. Z.B. werden dort in Engine-Matches oder im Autoplayermodus die Zwischenstände angezeigt.

Achten Sie daher immer auf eventuelle Hinweise in der Titelleiste und der Statuszeile des Programms.

Unter Fenster - Design können sie die Titelzeilen an- oder ausschalten. Schneller geht es mit Umschalt-F3.


3D-Brett

Für die 3D-Grafik ist eine Farbtiefe von mindestens 256 Farben notwendig. Es stehen verschiedene Figurensätze und Schachbretter für die 3D-Darstellung zur Verfügung. Klicken Sie in der Funktionsleiste auf das Symbol mit der Schachfigur.

Sie können mit F3 zwischen den Figurensätzen und mit F4 zwischen den Schachbrettern wechseln.

Sie können das 3D-Schachbrett bequem mit der Maus verschieben, vergrössern, verkleinern, drehen oder kippen:

  • Um das Schachbrett zu verschieben, klicken Sie es am oberen oder unteren Rand an und verschieben es mit niedergedrückter Maustaste.

  • Um die Größe des Schachbrett zu verändern, klicken Sie es am linken oder rechten Rand an.

  • Um das Schachbrett zu drehen oder zu kippen, klicken Sie eine der vier Ecken an und bewegen es mit niedergedrückter Maustaste.

Sie können auch die Tasten des Ziffernblocks der Tastatur verwenden, um das 3D-Schachbrett anzupassen.

Die Pfeiltasten auf dem numerischen Ziffernblock verschieben das 3D-Brett in die entsprechende Richtung.

POS 1 auf dem numerischen Block vergrössert die Darstellung der Figuren.

ENDE auf dem numerischen Block verkleinert die Darstellung der Figuren.

Eine Zusammenstellung der Shortcuts finden Sie hier ....


Materialdifferenz

Unterhalb des Notationsfensters sehen Sie die Materialbilanz, die nur unterschiedliche Materialkonstellationen anzeigt.

Anzeige unterschiedlicher Materialverteilung ....

In der Beispielgrafik erkennen Sie die unterschiedliche Materialkonstellation für Weiß und Schwarz.

Im Kontextmenü des Notationsfenster können Sie die Anzeige der Materialbilanz abschalten.


Variantenbrett

Das Variantenbrett

Das Variantenbrett ist eine wertvolle Hilfe, um die Anzeige der aktuellen Hauptvariante visuell nachzuvollziehen.

Die grafische Darstellung der Hauptvariante steht nur zur Verfügung, wenn Shredder rechnet.

Drücken Sie die Taste F11, wenn Shredder oder eine der anderen Engines rechnet.

Folgendes Fenster wird eingeblendet:

Klicken Sie auf "Automatisch", wenn Sie immer nur die aktualisierte Hauptvariante angezeigt bekommen wollen.

Die vier Buttons haben nacheinander folgende Bedeutung:

  • springt zum Anfang der Hauptvariante

  • geht einen Zug zurück

  • geht einen Zug vorwärts

  • springt zum Ende der Hauptvariante

  • Mit "Aktualisieren" können Sie die Hauptvariante aktualisieren.

  • "OK" schliesst das Fenster.


Befehlszeile

Sie können Züge in Shredder auch direkt über die Tastatur eingeben. Dies können Sie entweder in kurzer oder in langer Notation machen. Wenn Sie anfangen zu tippen öffnet sich automatisch die Befehlszeile, in der Sie Ihre Eingabe kontrollieren können.

Beispiele:

e2e4

d4

Sf3

b1c3

0-0

Tipp: Turnierrating berechnen


Design/Layout

Designs + Fensterlayouts

Im Menü Fenster finden Sie die Einträge Design und Layout. Dort können Sie benutzerdefinierte Einstellungen vornehmen, um den Bildschirm nach Ihrem Geschmack anzupassen.

Beispiel: Die Anzeige des zuletzt gespielten Zuges in der Notation und auf dem Schachbrett wird nach der Installation in dezentem Blau angezeigt. Diese Einstellung können Sie ändern. Wählen Sie Fenster - Design - Farben - Aktueller Zug. Wenn Sie jetzt die rote Farbe auswählen, wird der aktuelle Zug in der Notation und die Hauptvariante rot angezeigt.

Sie können verschiedene Designs speichern und jederzeit wieder laden.

Beim Fensterlayout werden in erster Linie die Positionierung der Fenster gespeichert. Sie sollten sich für unterschiedliche Anwendungsgebiete entsprechende Layouts erstellen und speichern. Sie können auf eine Anzahl vordefinierter Layouts zugreifen oder eigene Layouts speichern und laden.


Züge eingeben

Am einfachsten geben Sie die Züge auf dem grafischen Schachbrett mit der Maus ein. Bewegen Sie den Mauszeiger auf die gewünschte Figur, drücken Sie die linke Maustaste und bewegen Sie die Figur mit gedrückter Maustaste auf das Zielfeld. Lassen Sie dort die Maustaste los.

Tipp Sie können alle Züge, die im Notationsfenste r angezeigt werden, ausführen, indem Sie sie anklicken.

Sie können die Züge auch über die Tastatur in der Befehlszeile eingeben.


Neue Partie

Sie können jederzeit eine neue Partie beginnen.

Wählen Sie dazu den Menüpunkt Datei -> Neue Partie, drücken Sie die Tastenkombination Strg-N oder klicken Sie auf den Neue Partie Button in der Funktionsleiste.


Besondere Züge

  • Um eine gegnerische Figur zu schlagen, geben Sie nur den Zug Ihrer Figur ein.

  • Um zu rochieren, geben Sie nur den Zug Ihres Königs ein.

  • Um einen Bauern en passant zu schlagen, geben Sie nur den Zug Ihres Bauern ein.

  • Um einen Bauern umzuwandeln, ziehen Sie den Bauern auf die letzte Reihe. Anschließend erscheint ein Dialogfeld. Wählen Sie dort die gewünschte Figur.

  • Tastatur: geben Sie den Bauernzug ein, ersetzen Sie jedoch die letzte Zahl (1 oder 8) durch den Buchstaben der gewünschten Figur, z.B. b7bD (b7-b8D) oder a2bS (a2xb1S). Beachten Sie die Groß-/Kleinschreibung!


Programm rechnet

Sie erkennen an der Statusanzeige „rechne", daß Shredder seinen Zug berechnet.

Wenn Shredder oder eine Engine gezogen hat, wird die Figur des letzten Zuges mit einem farbigen Rahmen markiert. An diesem Rahmen können Sie erkennen, daß Sie am Zug sind. Wenn Sie die Maus bewegen oder eine Taste betätigen, verschwindet der Rahmen.

Während Shredder rechnet, können viele Menübefehle nicht ausgeführt werden. Sie sind dann inaktiv, d.h. erscheinen in heller Schrift.

Sie können auch keine Züge eingeben. Warten Sie, bis Shredder gezogen hat.

Zu Beginn einer Partie kann Shredder Züge aus dem Eröffnungsbuch abrufen und muß daher nicht rechnen.

Sie können Shredder jederzeit unterbrechen. Drücken Sie ESC oder klicken Sie in der Symbolleiste auf das rote Symbol mit dem Kreuz.


Partieende

Ist eine Partie beendet, zeigt Shredder eine Meldung an.

Sie kann lauten:

  • „Weiß hat gewonnen"

  • „Schwarz hat gewonnen"

  • „Patt! Remis!"

  • „Remis! Zuwenig Material zum Gewinn vorhanden!"

  • „Remis wegen dreifacher Stellungswiederholung"

  • „Remis wegen der 50-Züge-Regel".


Mit Schwarz spielen

Rechtsklick auf das Schachbrett und Brett drehen dreht das Schachbrett. Alternativ drücken Sie den Hotkey STRG+F.

Lassen Sie dann Shredder mit „Rechne" aus dem Befehle-Menü den ersten Zug spielen. Alternativ geht es über die Tastatur mit STRG+C.


Züge nachspielen

Sie können komfortabel in einer Partienotation navigieren. Benutzen Sie dazu die Navigationsbuttons in der Schnellstartleiste oder unter dem Schachbrett.

Die Bedienung ist der Steuerung eines Videorekorders nachempfunden und selbsterklärend.

Züge zurücknehmen oder vorspielen

  • Um den letzten Zug zurückzunehmen, wählen Sie PFEIL-NACH-LINKS.

  • Um einen Zug vorzuspielen, wählen Sie PFEIL-NACH-RECHTS.

Züge vorspielen

  • Mit PFEIL-NACH-OBEN nehmen Sie fünf Züge zurück.

  • Mit PFEIL-NACH-UNTEN spielen Sie fünf Züge nach.

Zum Anfang der Partie springen

Wählen Sie POS1, um zur Grundstellung zu springen. Sie können die Partiezüge anschließend vorspielen.

Zum Ende der Partie springen

Um zur Schlußstellung zu springen, wählen Sie die Taste ENDE oder klicken Sie auf den entsprechenden Button in der Navigationsleiste.

J`adoube

Falls Sie einen Fehlzug eingegeben haben, machen Sie die Eingabe auf den Button mit dem roten Pfeil wieder rückgängig.

Varianten

Um Varianten nachzuspielen, benutzen Sie die Buttons mit den nach oben und abwärts ausgerichteten Pfeilsymbolen.

Tipp Sie können zu einer bestimmten Stellung der Partie springen, indem Sie den betreffenden Zug im Partiefenster anklicken.


Spielstufen

Mit den verschiedenen Spielstufen legen Sie den Zeitverbrauch und die Spielstärke des Schachprogramms fest.

Die Spielstufen stellen Sie über das Menü Spielstufen ein.


Analysestufe

In der Analyse-Einstellung ist keine Spielstufe aktiv, da es keine Zeitbeschränkung gibt. Wenn Sie in der Analyse-Einstellung eine Spielstufe einstellen, wird in die "Normal"-Einstellung gewechselt.

Mit Strg-A oder dem Befehl Analyse aus dem Modus-Menü wechseln Sie in den Analysemodus.

Im Analysemodus analysiert das Programm permanent die aktuelle Stellung, spielt jedoch selbst keine Züge aus. Sie können also für beide Seiten Züge eingeben und ständig die Analysen von einer oder mehreren aktiven Engines im Suchfenster beobachten.

Sie können den ersten Zug der Hauptvariante durch Anklicken der Hauptvariante ausführen. Dies funktioniert auch bei mehreren Hauptvarianten.

Der Analysemodus ist die einfachste, gebräuchlichste und komfortabelste Methode zur Analyse. Im Analysemodus können Sie bis zu 10 Engines parallel betreiben und damit analysieren. Die gleichzeitige Anzeige unterschiedlicher Schachprogramme stellt eine wertvolle Orientierungshilfe zur Beurteilung der aktuellen Brettstellung dar.

Tipp Mit STRG-EINFG übernehmen sie den besten Zug in die Notation .


Stellungseingabe

Sie können jederzeit Stellungen, also Schachpositionen , eingeben oder die aktuelle Brettstellung verändern.

Wählen Sie mit einem Rechtsklick auf das Schachbrett "Stellung eingeben" oder STRG+D, um das Dialogfeld zur Stellungseingabe zu öffnen. Die aktuelle Stellung erscheint in der Grafik als Vorgabe.

  • Um eine Figur einzusetzen, klicken Sie die gewünschte Figurenart rechts neben dem Schachbrett an. Der Mauszeiger verwandelt sich in die gewählte Figur, wenn Sie ihn über das Brett bewegen. Klicken Sie auf das gewünschte Feld im Schachbrett, um die Figur einzusetzen.

  • Wenn Sie mit der rechten Maustaste auf das Schachbrett klicken, wird eine Figur der anderen Farbe eingesetzt.

  • Wenn Sie mit der mittleren Maustaste auf eine Figur klicken, wird diese vom Schachbrett entfernt und als aktuelle Eingabefigur übernommen.

  • Um eine Figur zu entfernen, klicken Sie zweimal auf ein Feld.

  • Mit dem Mausrad können Sie die aktuelle Eingabefigur wechseln.

  • Mit der Schaltfläche Brett leeren entfernen Sie alle Figuren vom Schachbrett.

  • Klicken Sie auf akt. Stellung, um Änderungen rückgängig zu machen und zur ursprünglichen Stellung zurückzukehren.

  • Mit der Ok-Schaltfläche schließen Sie die Stellungseingabe ab. Wenn die Stellung illegal ist, fehlt die Schaltfläche.

  • Sie können auf Abbruch klicken, um die Stellungseingabe ohne Änderung zu verlassen.

  • Mit den Rochaderechte-Feldern können Sie festlegen, ob Rochaden zulässig sind. Falls König oder Türme nicht mehr auf den Ausgangsfeldern stehen, lassen sich die entsprechenden Rochaden nicht aktivieren.

  • Mit den Schaltflächen rechts, links, hoch und runter können Sie die Stellung um eine Linie bzw. Reihe verschieben.

  • Mit der Schaltfläche vert. können Sie die Stellung vertikal spiegeln, d.h. a- und h-Linie werden vertauscht.

  • Mit der Schaltfläche horiz. können Sie die Stellung horizontal spiegeln, d.h. Weiß und Schwarz werden vertauscht

  • Wie kann man eine Figur einsetzen ?

  • Wie wird eine Figur entfernt ?

  • Wie können alle Figuren entfernt werden ?

  • Wie kann die aktuelle Position wieder hergestellt werden ?

  • Warum ist der Button "OK" manchmal grau unterlegt ?

  • Was bewirken die sechs kleinen Schaltflächen neben dem Schachbrett ?

  • Welche Bedeutung haben die Felder Rochaderechte ?


Figur setzen

Klicken Sie die gewünschte Figur neben dem Schachbrett an.

Alternativ können Sie die gewünschte Figur auch mit dem Mausrad auswählen.

Der Mauszeiger verwandelt sich in die gewählte Figur wenn er über das Schachbrett bewegt wird. Klicken Sie mit der linken Maustaste auf das gewünschte Zielfeld auf dem Schachbrett, um die Figur aufzustellen.

Hinweis: mit einem Klick der rechten Maustaste setzen Sie eine Figur der entgegengesetzten Farbe auf das Brett.


Figur entfernen

Klicken Sie zweimal auf das entsprechende Feld und die Figur wird entfernt

Alternativ können Sie die Figur auch mit der mittleren Maustaste anklicken.


Alle Figuren entfernen

Klicken Sie auf den Button "Brett leeren".


Akt. Position herstellen

Aktuelle Position wieder herstellen

Klicken Sie auf den Button "Akt. Stellung". Die aktuelle Brettstellung wird übernommen.


Schalter OK inaktiv

Was tun, wenn der Schalter OK grau unterlegt und anscheinend inaktiv ist?

Der Button "OK" wird dann inversiv angezeigt, wenn die aktuell eingegebene Position nicht den Regeln entspricht.

Überprüfen Sie die Position auf dem Brett.

Klicken Sie auf Abbruch, um die Stellungseingabe ohne Modifikationen zu beenden.


Sechs Schaltflächen

  • Mit den Schaltflächen "rechts", "links", "oben" und "unten" können Sie die Brettstellung um eine Linie bzw. Reihe verschieben.

  • Mit der Schaltfläche "vert." können Sie die Stellung vertikal (senkrecht) spiegeln.

  • Mit der Schaltfläche ""horiz." können Sie Stellung horizontal spiegeln und so Weiß und Schwarz vertauschen.


Rochaderechte

Hier legen Sie fest, ob Weiß oder Schwarz lang, bzw. kurz rochieren kann. Falls Könige oder Türme nicht mehr auf den Ausgangsfeldern stehen, sind diese Optionen deaktiviert.


Speichern/Laden

Stellungen speichern und laden

Shredder kann Stellungen sowohl im EPD-Format als auch im CBF-und PGN-Format speichern.

EPD-Dateien können beliebig viele Stellungen enthalten. Sie können beim Speichern einer Stellung im EPD-Format einen Kommentar eingeben, der bei der Analyse von EPD-Dateien als "Lösungszug" herangezogen wird. Shredder speichert in EPD-Dateien keine weiteren Informationen.

Um Stellungen zu speichern und zu laden, verwenden Sie die entsprechenden Befehle aus dem Datei-Menü. Um eine gespeicherte Stellung aus einer EPD-Datei laden, müssen Sie wissen, an welcher Stelle der Datei sie gespeichert ist.

Sie können sich die Inhalte von EPD-Dateien komfortabel mit dem EPD-Ladedialog ansehen.

Es ist sinnvoller, Stellungen in CBF- oder PGN-Datenbanken zu speichern, da Sie in diesen Formaten auch Partiedaten speichern können.


Datenbanken

Shredder verwendet zum Speichern und Laden von Partien Datenbanken im PGN- und CBF-Format.

Eine Datenbank kann nahezu beliebig viele Partien enthalten. Außer den Zügen werden Partiedaten (Spielernamen, Ergebnis, Ort, usw.), Kommentare und Varianten gespeichert. Das PGN-Format wird von vielen anderen Schachprogrammen unterstützt. PGN-Dateien sind Textdateien, die auch mit einer Textverarbeitung oder einem Editor bearbeitet werden können. Es ist für große Partiemengen nicht besonders gut geeignet, da der Zugriff auf große PGN-Dateien relativ langsam ist.

Das CBF-Format wird auch von einigen anderen Schachprogrammen unterstützt. Es stammt ursprünglich vom Datenbankprogramm ChessBase. CBF-Datenbanken bestehen aus zwei Dateien, einer CBF- und einer CBI-Datei. Das CBF-Format benötigt relativ wenig Speicherplatz und ist deshalb für große Partiemengen besser als das PGN-Format geeignet. Es weist jedoch auch einige Einschränkungen auf:

  • Es können nur Jahreszahlen und kein vollständiges Datum gespeichert werden.

  • Es gibt nur eine Feld für die Turnierbezeichnung, während es im PGN-format ein "Quelle"- und ein "Ort"-Feld gibt.

  • Elozahlen können nur in Fünferschritten (von 1605 bis 2875) gespeichert werden.


Partien speichern

Wählen Sie aus dem Datei-Menü "Partie speichern" oder den Shortcut STRG+S.

Es erscheint der Partiedaten-Dialog, in dem Sie die Daten zu der Partie eingeben können und sollten.

Wenn Sie die Partie später laden, wird eine Liste mit den Partiedaten angezeigt. Sie sollten zumindest die Felder "Weiß", "Schwarz" und "Quelle" ausfüllen, um die Partie später mit der Suchfunktion wiederfinden zu können. Klicken Sie auf "Speichern", nachdem Sie die Partiedaten eingegeben haben.

Wenn noch keine Datenbank zur Speicherung aktiv sein sollte, erscheint der normale Windows-Dateidialog. Geben Sie unter Dateityp unbedingt das gewünschte Dateiformat, z.B. "meinepartien.pgn" an.

Ansonsten können Sie im Eingabedialog der Partiedaten unter Wechsle Datenbank eine Datenbank zur Speicherung auswählen. Wählen Sie eine Partiedatenbank aus und klicken Sie auf "Speichern".

Tipp ! Um die Partie in einer neuen Datenbank zu speichern, geben Sie unter "Dateiname" den gewünschten Namen ein.

Informationen zum Laden und Speichern von Positionen finden Sie hier ....


Partien laden

Wählen Sie aus dem Datei-Menü "Partie laden" oder den Hotekey STRG+L.

Wählen Sie die gewünschte Datenbank aus. Zur Auswahl stehen die beiden Dateiformate CBF und PGN .

Es erscheint die Partieliste der Datenbank. Folgende Partiedaten werden angezeigt:

  • Weiß

  • Schwarz

  • Quelle

  • Runde

  • ECO -Code

  • Ergebnis

Verwenden Sie die Bildlaufleiste, um weitere Partien zu sehen. Markieren Sie die gewünschte Partie mit einem Mausklick und klicken Sie auf "Laden" oder doppelklicken Sie die Partie in der Liste. Die Partie wird mit der Ausgangsstellung geladen.

Nachdem Sie eine Partie geladen haben, können Sie die nächste Partie mit F8 und die vorherige Partie mit F7 laden.Falls Sie lieber mit der Maus arbeiten, helfen die Buttons Vorherige Partie Laden und Nächste Partie laden aus der Funktionsleiste


Partien ersetzen

Sie können die zuletzt geladene Partie mit dem entsprechenden Befehl aus dem Datei-Menü ersetzen. Alternativ geht auch Strg-R.

Nach einer vorherigen Abfrage erscheint der Partiedaten-Dialog . Dort können Sie z.B. fehlerhafte Einträge korrigieren. Wenn Sie den Partiedaten-Dialog mit einem Klick auf "OK" schließen, wird die zuletzt geladene Partie durch die aktuelle Partie ersetzt.

Tipp ! Sie können keine Partien ersetzen, nachdem eine neue Partie begonnen wurde, eine Stellungseingabe vorgenommen wurde oder eine Stellung aus einer EPD-Datei geladen wurde.


Partien löschen

Sie können Partien aus Datenbanken löschen. Die Vorgehensweise entspricht dem Laden von Partien.

Der Befehl "Partie löschen" aus dem Datei-Menü öffnet eine Partieliste.

Markieren Sie dort die zu löschende Partie und klicken Sie auf die Schaltfläche "Löschen".

Tipp ! Partien in CBF-Datenbanken werden nicht physikalisch gelöscht, sondern nur als "gelöscht" markiert. Sie werden dann in der Partieliste in grauer Schrift angezeigt.


Partien suchen

Sie können in Datenbanken nach Partien suchen. Klicken Sie in der Partieliste auf die "Suchen"-Schaltfläche, um die Suchmaske zu öffnen.

Sie können nach folgenden Partiedaten suchen:

  • Spielernamen

  • Quelle

  • Ort

  • Runde

  • Ergebnis

  • Jahr

  • Elozahlen

  • Eröffnung

Bei den Spielernamen können Sie die Suche auf eine bestimmte Farbe zu beschränken.

Es wird nicht zwischen Gross- und Kleinschreibung unterschieden. Suchtexte müssen nur teilweise eingegeben werden. Wenn Sie z.B. nach dem Spieler "stein" suchen, werden sowohl die Partien des ersten Weltmeisters Steinitz als auch Partien Bronsteins gefunden.

Mit dem Kontrollkästchen links unten in der Partieliste können Sie die Suchmaske ein- und ausschalten, d.h. nur die gesuchten Partien oder alle Partien anzeigen lassen.

Info ! Eine Suche nach Stellungen oder Zügen ist nicht möglich.


Partien kommentieren

Sie können mit Shredder Partien kommentieren und Varianten, d.h. abweichende Zugfolgen, in die Partienotation einfügen.

Um Kommentare einzugeben oder zu bearbeiten, wählen Sie aus dem Kontext-Menü des Notationsfensters "Kommentar eingeben..." (STRG+M).

Neben Textkommentaren "versteht" das Programm auch verschiedene Arten von Kurzkommentaren, die im Dialogfeld per Klick eingegeben werden können. Diese Kurzkommentare werden oft durch besondere Symbole angezeigt.


Varianten eingeben

Wenn Sie während des Nachspielens einer Partie einen Zug mit der Maus oder der Tastatur eingeben, dann erscheint eine Abfrage, ob die neuen Züge als Variante in die Notation eingefügt werden sollen. Sie haben folgende Möglichkeiten:

Klicken Sie auf "Ja", um eine neue Variante einzufügen.

Um die Partiefortsetzung zu überschreiben, klicken Sie auf "Nein".

Sie können Varianten erzwingen, wenn Sie einen Zug mit gedrückter Alt-Taste eingeben. Wenn Sie einen Zug mit gedrückten Strg+Alt-Taste (oder der AltGr-Taste auf deutschen Tastaturen) eingeben, dann wird die Partiefortsetzung ohne Nachfrage überschrieben.

Sie können mit Hauptvariante einfügen STRG-EINFG aus dem Befehle-Menü die aktuelle Hauptvariante aus dem Suchinfo-Fenster in die Partie einfügen. Wird dieser Befehl in der Schlussstellung der Partie gewählt, dann wird die Partie um die Hauptvariante verlängert. Wird er mitten in der Partie gewählt, dann wird eine neue Variante eingefügt. Zusätzlich zu den Zügen werden Stellungsbewertung, Suchtiefe und Rechenzeit in Sekunden als Textkommentar eingefügt.


Varianten bearbeiten

Sie können Varianten löschen, die Reihenfolge von Varianten ändern oder Varianten abschneiden.

  • Um eine Variante zu löschen, gehen Sie zu einem beliebigen Zug der Variante und wählen ENTF.

  • Um eine Variante aufzuwerten (um eine Position nach oben zu schieben), wählen Sie STRG+PFEIL-NACH-OBEN.

  • Um die letzten Züge einer Variante zu löschen, gehen Sie zu dem letzten Zug, den Sie behalten wollen und wählen STRG+ENTF. Dieser Befehl funktioniert nicht nur in Varianten, sondern auch in der Partiefortsetzung

Alle diese Befehle können Sie auch aus dem Kontextmenü des Notationsfensters aufrufen.


EPD-Ladedialog

Shredder bietet eine übersichtliche Auswahlbox zum übersichtlichen Laden von Schachpositionen, die in EPD-Dateien gespeichert sind.

Sie können über die Funktionsleiste den Ladedialog von EPD-Dateien durch einen Klick auf den Button "Lade Position", durch Auswahl des Menüpunktes "Stellung laden" aus dem Dateimenü oder mit dem Hotkey Strg-I starten.

Nachdem Sie eine EPD-Datei geöffnet haben, sehen Sie in dem Ladedialog folgende Elemente:

Das Vorschaubrett

Auf dem Vorschaubrett wird die entsprechende Position angezeigt, wenn im Listenfenster ein Eintrag merkiert wurde.

Das Listenfenster

Im Listenfenster stehen die einzelnen EPD-Strings. Per Mausklick auf einen String wird die entsprechende Position auf dem Vorschaubrett angezeigt. Sie können auf Anhieb die dem EPD-String zugeordnete Stellung erkennen.

EPD-String - Zeile

In der Eingabezeile steht der EPD-String der angezeigten Position. Sie können den String mit der Tastenkombination STRG-C markieren und über die Zwischenablage mit anderen Anwendungen 8Schachprogrammen) austauschen.

Navigatonsbuttons

Mit Hilfe der Navigationsbuttons können Sie schnell durch die Listeneinträge navigieren. Entweder in Einer- oder Zehnerschritten. Die Buttons aussen springen zum Anfang, bzw. Ende der Liste.


Was ist EPD ?

Im Gegensatz zu PGN ist vielen Anwendern das EPD-Format, das ebenfalls auf Ascii (reinem Text) basiert und ausschließlich zur Speicherung von Schachpositionen sehr gut geeignet ist, weniger geläufig.

In einer EPD-Datei können Sie mehrere Positionen in einer einzigen Ascii-Datei speichern.

Über das Menü Datei -> Stellung laden / Stellung speichern können Sie Stellungen aus EPD-Dateien laden oder eigene Positionen in neuen EPD-Dateien speichern.


Was ist PGN ?

Das PGN-Format ist ein Standardformat zum Speichern von Schachpartien . Es wird von Shredder wie von vielen anderen Schachprogrammen unterstützt und ist deshalb für den Datenaustausch extrem wichtig. Es besteht z.B. die Möglichkeit, Partien im PGN-Format über die Zwischenablage einzufügen. Im Internet finden Sie z.B. eine Fülle von Partien im PGN-Format, die über die Zwischenablage direkt in Shredder eingefügt werden können.


Eingeben/Bearbeiten

Kommentare eingeben und bearbeiten

Sie können mit Shredder Partien kommentieren und Varianten, d.h. abweichende Zugfolgen, in die Partienotation einfügen.

Um Kommentare einzugeben oder zu bearbeiten, wählen Sie aus dem Kontextmenü des Notationsfensters "Kommentar eingeben.." (STRG+M).

Siehe auch Buchzüge kommentieren ....


Eingabe Varianten

Wenn Sie während des Nachspielens einer Partie einen Zug mit der Maus oder der Tastatur eingeben, dann erscheint eine Abfrage, ob die neuen Züge als Variante in die Notation eingefügt werden sollen.

Sie haben folgende Möglichkeiten:

  • Klicken Sie auf "Ja", um eine neue Variante einzufügen.

  • Um die Partiefortsetzung zu überschreiben, klicken Sie auf "Nein".

Sie können Varianten erzwingen, wenn Sie einen Zug mit gedrückter Alt-Taste eingeben. Wenn Sie einen Zug mit gedrückten Strg+Alt-Tasten (oder der AltGr-Taste auf deutschen Tastaturen) eingeben, dann wird die Partiefortsetzung ohne Nachfrage überschrieben.

Sie können die aktuelle Hauptvariante aus dem Suchinfo-Fenster mit STRG-EINFG einfügen. Wird dieser Befehl in der Schlussstellung der Partie gewählt, dann wird die Partie um die Hauptvariante verlängert. Wird er mitten in der Partie gewählt, dann wird eine neue Variante eingefügt. Zusätzlich zu den Zügen werden Stellungsbewertung, Suchtiefe und Rechenzeit in Sekunden als Textkommentar eingefügt.


Bearbeiten Varianten

Varianten bearbeiten

Sie können Varianten löschen, die Reihenfolge von Varianten verändern oder Varianten abschneiden.

  • Um eine Variante zu löschen, gehen Sie zu einem beliebigen Zug der Variante und wählen aus dem Kontext-Menü Variante löschen (ENTF).

  • Um eine Variante aufzuwerten (um eine Position nach oben zu schieben), wählen Sie aus dem Kontext-Menü Variante aufwerten (STRG+PFEIL-NACH-OBEN).

  • Um die letzten Züge einer Variante zu löschen, gehen Sie zu dem letzten Zug, den Sie behalten wollen und wählen aus dem Kontext-Menü Restliche Züge löschen (SHIFT+ENTF).Dieser Befehl funktioniert nicht nur in Varianten, sondern auch in der Partiefortsetzung.

Alle diese Befehle können Sie auch aus dem Kontextmenü des Notationsfensters aufrufen.


Joker-Analyse

Die Jokerfigur-Analyse

In Drei-/Vier-/Fünf- und einigen Sechssteinerendspielen steht mit der Funktion "Jokeranalyse" eine einzigartige Analysefunktion zur Verfügung. Bei der Jokerfigur-Analyse greift Shredder auf die Informationen der TableBases von Eugene Nalimov zu.

Die Jokeranalyse aktivieren Sie mit einem Rechtsklick auf das grafische Schachbrett oder Alt-E. Die Funktion steht nur dann zur Verfügung, wenn ein entsprechendes Endspiel aufgebaut ist und die entspechenden Endspieldatenbanken installiert sind. Falls Sie die entsprechende Endspieldatenbank nicht installiert haben, fragt Shredder nach, ob er die Stellung in der Onlineendspieldatenbank von Shredder suchen soll.

Zur Jokerfigur-Analyse wird eine beliebige Figur vom Brett genommen und auf allen Feldern des Schachbretts eingesetzt. Die Bewertung der Stellung wird direkt auf dem entsprechenden Feld des Schachbretts notiert.

Hinweis ! Während der Jokerfigur-Analyse wird die aktuelle Partie gelöscht. Sie sollten sie deshalb vorher speichern, falls notwendig.

Shredder leistet vortreffliche Dienste bei der Analyse von Endspielen.

Beispiel: Stellen wir uns einfach einmal die folgende Endspielfrage: Wo muss der weiße König stehen, damit das Endspiel K + D gegen K + sBf2 noch zu gewinnen ist. Dafür bauen wir einfach eine Stellung dieses Typs in Shredder auf, wählen Jokeranalyse, und klicken auf den weißen König.

Innerhalb von weniger als einer Sekunde zeigt Shredder nun jedes Feld des Schachbrettes, auf dem der König legal stehen darf. Zusätzlich gibt es eine Information, ob die Stellung mit dem König auf diesem Feld remis oder gewonnen ist. Ist sie gewonnen, so steht auf jedem Feld sogar die Zugzahl bis zum Matt. Diese Funktion kann man für jedes beliebige Endspiel mit höchstens sechs Figuren anwenden, dabei kann man jede Figur auf dem Brett, also nicht nur den König, als Joker verwenden. Mit wenigen Mausklicks kann man Fragen beantworten, für die die Endspieltheoretiker oft Jahre brauchten, wie z.B. wo der Bauer im Endspiel KDB-KD am besten steht, damit die Siegchancen am größten sind und wo es nur Remis wird. Diese Bewertungen repräsentieren wohlgemerkt nicht die Meinung von Shredder, sondern den "realen Wert" der Stellung aus den Endspieldatenbanken. Shredder bestimmt also den Wert jeder Stellung und gibt ihn direkt auf dem Schachbrett aus.

Endspielorakel


Triple Brain

Beim Triple Brain handelt es sich um ein völlig neuartiges Konzept, um die Vorzüge zweier unterschiedlicher Engines miteinander zu kombinieren und das Optimum für die Analyse herauszuholen. Die "normalen" Schachengines analysieren eine bestimmte Position, während ein drittes Programm die Entscheidung trifft, welcher Zug die beste Alternative darstellt. Innerhalb von Shredder wird das Entscheidermodul als "Triple Brain" bezeichnet. Das Triple Brain zeigt in seinem eigenen Suchfenster eine Bewertungsskala von 0 - 100% an. Anhand des Prozentwertes kann der Anwender erkennen, wie sicher das Triple Brain bei der Beurteilung und Auswahl seines Zuges ist.

Beispiel: der Wert "0%" sagt aus, das das Triple Brain bei der Beurteilung eines Zuges keine bessere Alternative erkennt. "100%" gibt die Information, dass es nach Ansicht des Triple Brains einen deutlich günstigeren Zug gibt. Damit das Triple Brain seine Stärken ausspielen kann, sollten sich die beiden Engines, aus deren Bewertungen das Triple Brain den besten Zug heraussucht, im Spielstil deutlich voneinander unterscheiden.

Hinweis: Sie können die Shredder-Engine modifizieren und eigene Engines kreieren, die sich im Spielstil voneinander unterscheiden.

Die Kontrolle über die Bedenkzeiten wird in diesem Modus ebenfalls von dem Triple Brain übernommen.

Informationen im Fenster des "Dreihirns" (= Triple Brain)

Zusätzlich zu den oben beschriebenen Informationen zeigt die Triple-Brain-Engine im Suchfenster in der rot markierten Zeile folgende Informationen an:

Info Triple Brain

  • die Suchtiefe der beiden aktiven Engines

  • Analysezeit

  • Prozentwert mit Angabe, wie sicher das Triple Brain bei der Beurteilung eines bestimmten Zuges ist.

  • den nach Ansicht des Entscheidermoduls besten Zug

  • als letzter Eintrag steht der Namen der Engine, auf deren Bewertung der momentan favorisierte Zug basiert.

Die Hashfüllrate und die nps werden ebenfalls angezeigt, allerdings nur die Durchschnittswerte der rechnenden Engines.Die Darstellung dieser Detailinformationen können Sie übersichtlich in den kleinen Informationsbuttons über dem eigentlichen Analysefenster erkennen.

Beim 3-Hirn funktioniert auch das Bewertungsprofil und Etiquette und die Bewertung wird in % zwischen 0 und 100 angezeigt. 0% heißt, dass das 3-Hirn

zwischen den Zügen nicht richtig unterscheiden kann, 100% heißt, dass einer der Züge wohl deutlich besser ist.


Analysemodus

Der Analysemodus

Mit Strg-A oder dem Befehl „Analyse" aus dem Menü Modus wechseln Sie in den Analysemodus.

Im Analysemodus analysiert das Programm permanent die aktuelle Stellung, spielt jedoch selbst keine Züge aus. Sie können für beide Seiten Züge eingeben und ständig die Analysen von einer oder mehreren aktiven Engines im Suchfenster beobachten.

STRG-EINFG übernimmt die Hauptvariante in die Notation.

Der Analysemodus ist die einfachste, gebräuchlichste und komfortabelste Methode zur Analyse. Im Analysemodus können Sie bis zu 10 Engines parallel betreiben und damit analysieren. Die gleichzeitige Anzeige unterschiedlicher Schachprogramme stellt eine wertvolle Orientierungshilfe zur Beurteilung der aktuellen Brettstellung dar.


Multi-Varianten-Analyse

Mehrere Varianten analysieren

Shredder kann bei der Analyse einer Stellung nicht nur nach dem besten Zug suchen, sondern beliebig viele Fortsetzungen analysieren.

Mit der F6-Taste können Sie die Zahl der untersuchten Züge erhöhen. Das Programm erstellt eine Liste der besten Fortsetzungen mit Stellungsbewertung und Hauptvariante und zeigt sie im Suchinfo-Fenster an.

Sie können die Zahl der untersuchten Züge mit der F6-Taste beliebig erhöhen. Mit der F5-Taste können Sie die Anzahl der Varianten verringern. Sie können diese Funktion auch aus dem Kontextmenü des Suchfensters abrufen.

Je größer die Zahl der zu analysierenden Fortsetzungen ist, desto mehr Zeit wird benötigt, um eine größere Suchtiefe zu erreichen. Andererseits analysiert das Programm die zweit- und nächstbesten Fortsetzungen wesentlich gründlicher als bei einer normalen Analyse.

Tipp ! Sie können die Einstellungen für den Multi-Varianten-Modus auch mit einem Rechtsklick in das Suchfenster aktivieren.


Partien analysieren

Sie können Shredder vollautomatisch eine Partie analysieren lassen. Wählen Sie aus dem Menü Modus „Partie analysieren", um die aktuelle Partie zu analysieren. Alternativ rufen Sie den Einstelldialog über Strg-F10 auf.

Folgende Optionen stehen zur Verfügung:

  • Seite, deren Züge analysiert werden (Weiß, Schwarz oder beide).

  • Züge, die analysiert werden (Vorgabe: Zug 1 bis Ende der Partie).

  • Schwellwert-Option: Es werden nur Analysen ausgegeben, wenn die Bewertung des stärksten Zugs und die Bewertung des Partiezugs um mindestens den gewählten Schwellwert (in Hundertstel Bauern) abweichen. Wird ein Schwellwert von 0 gewählt, dann werden alle Analysen ausgegeben.

  • Kommentare/Varianten löschen: Vorhandene Kommentare und/oder Varianten werden vor der Analyse aus der Partie entfernt.

  • Die benötigte Bedenkzeit richtet sich immer nach der aktuellen Spielstufe.Sie können direkt in diesem Dialog die durchschnittliche oder die exakte Zeit pro Zug einstellen, die für die Analyse der Partie verwendet werden soll.

Shredders Analysen werden als Varianten in die Partie eingefügt. Die Bewertung, Rechentiefe und die Bedenkzeit in Sekunden werden als Textkommentar gespeichert. Die Partie wird von hinten nach vorne analysiert. Dies verbessert die Qualität der Analysen, da nach dem Analysieren und Zurücknehmen eines Zuges die Hash- und Bewertungstabellen Informationen für die Analyse des nächsten Zuges enthalten.

Züge, die im Eröffnungsbuch vorhanden sind, werden nicht analysiert, wenn es aktiviert ist.


Züge auswählen

Züge zur Analyse auswählen

Sie können vorgeben, welche Züge analysiert werden sollen und welche nicht. Wechseln Sie dazu zunächst in den Analyse-Modus .

Halten Sie die Strg-Taste gedrückt, während Sie einen Zug auf dem Brett ausführen. Damit beschränken Sie die Analyse von Shredder auf diesen Zug. Sie können dies beliebig oft wiederholen, um mehrere Züge zur Analyse auszuwählen.

Wenn Sie einen Zug ein zweites Mal mit gedrückter Strg-Taste ausführen, wird er von der Liste der zu analysierenden Züge entfernt.

Falls ein Zug im Zugfenster zu sehen ist, können sie ihn dort mit gedrückter Strg-Taste anklicken, um ihn auszuwählen.

Im Vergleich zum normalen Analysemodus kann das Programm schneller eine höhere Suchtiefe erreichen. Allerdings müssen Sie selbst dafür sorgen, daß alle Züge, die stark sein könnten, auch analysiert werden. Wenn Sie einen Zug mit gedrückter Umschalt-Taste ausführen, wird er von der Analyse ausgeschlossen. Sie können mehrere Züge mit gedrückter Umschalt-Taste eingeben, um mehrere Züge auszuschließen.

Falls ein Zug ein zweites Mal mit gedrückter Umschalt-Taste ausgeführt wird, wird die Analysebeschränkung aufgehoben. Es bietet sich zwar an, diese Funktion zu verwenden, um sinnlose Züge von der Analyse auszuschließen. Die Zeitersparnis ist jedoch nicht sehr groß, da Shredder offensichtlich sinnlose Züge ohnehin nur sehr kurz analysiert. Die Analysebeschränkung läßt sich viel effektiver einsetzen, um den (nach Shredders Meinung) besten Zug von der Analyse auszuschließen, falls Sie diese Fortsetzung aus irgendwelchen Gründen nicht interessiert.


Mehrere Positionen analysieren

Positionsdatenbanken analysieren

In einer EPD -Datei können mehrere Positionen gespeichert sein.

Shredder kann vollautomatisch alle Stellungen in einer EPD-Datei analysieren. Es kann und sollte für jede Stellung ein „Lösungszug" vorgegeben werden. Das Programm zeigt dann nach der Analyse eine Statistik der gelösten Stellungen an.

Der Lösungszug muß bei EPD-Dateien in folgendem Format angegeben werden: „bm " (best move) und Zug in Kurznotation mit englischem Buchstaben für die Figur, z.B. bm Nxf7 oder bm Bb5+. Mit "am" (avoid move) können Züge angegeben werden, die vermieden werden sollen.

Sie können den Kommentar beim Speichern einer Stellung eingeben. Falls Sie Lösungszüge in eine vorhandene EPD-Datei einfügen möchten, laden Sie diese mit einem Texteditor und fügen die Lösungszüge an das Ende der Zeile an.

Um die EPD-Analyse abzubrechen, wählen Sie einen beliebigen anderen Spielmodus, z.B. „Normal" oder „Analyse". Nach Abschluß einer EPD-Analyse werden im Analysefenster zwei Tabellen angezeigt. Die erste Tabelle gibt die Lösungszeit (in Sekunden) jeder Stellung an, die zweite Tabelle zeigt, wieviele Stellungen zum jeweiligen Zeitpunkt gelöst wurden.

Tipp ! Zur EPD-Analyse ist die Spielstufe „Exakte Zeit/Zug" besonders gut geeignet.


Einleitung

Multi-Engine-System

Shredder wurde als Multi-Engine-System konzipiert.

Dies bedeutet, dass die grafische Oberfläche und das eigentliche Schachprogramm strikt voneinander getrennt sind und über eine vordefinierte Schnittstelle miteinander kommunizieren. In Shredder ist es möglich, maximal 10 Schachengines parallel - z.B. zur Analyse - zu betreiben.

Damit bietet das System ideale Voraussetzungen, mit möglichst vielen Schachprogrammen unter einem einheitlichen Interface zu arbeiten.

Shredder unterstützt zwei unterschiedliche Standards von Schachengines:

UCI-Engines

Winboard-Engines


UCI-Engines

UCI steht für Universal Chess Interface und ist ein neues, von Stefan Meyer-Kahlen und Rudolf Huber entwickeltes Protokoll. Das Interface orientiert sich eng an dem Standard für Winboard-Engines , bietet aber gegenüber dem Winboard-Protokoll folgende Vorzüge:

  • UCI-Engines werden automatisch erkannt und in Shredder eingebunden.

  • UCI-Engines können über einheitliche Dialogboxen konfiguriert werden. Wichtige Grundoptionen und enginespezifische Funktionen müssen nicht wie bei Winboard-Engines über externe Konfigurationsdateien eingestellt werden.

  • UCI-Engines unterstützen sämtliche Ausstattungsmerkmale der Benutzeroberfläche von Shredder.

Hinweis: das UCI-Interface orientiert sich eng an dem Winboard-Protokoll. Dies bedeutet, dass bereits existente WB-Engines von den Autoren ohne grossen Aufwand an den Betrieb unter Shredder angepasst werden können. Für interessierte Programmierer hat diese Lösung folgende Vorzüge:

  • Die eigene Engine kann komfortabler unter der GUI von Shredder getestet werden.

  • Die Engine läuft ohne weitere Zusatzadapter mit voller Performance.

  • Die Akzeptanz der Engine nimmt beim Anwender zu, da eine aufwendige Konfiguration und Einbindung unter der Shredder-GUI im Unterschied zu Winboard-Engines entfällt.

  • Das UCI-Protokoll darf ohne Lizenzgebühr für das eigene Programm - auch für kommerzielle Zwecke - genutzt werden.

Die Dokumentation des UCI-Protokolls finden Sie unter www.shredderchess.de.

Wenn Sie eine eigene UCI-Engine erstellen wollen, bietet Shredder zwei Funktionen an, die dies wesentlich vereinfachen.

In der Befehlszeilezeile können Sie mit "ucidebug" einen Debugmodus ein- bzw. ausschalten. Im Debugmodus wird die gesamte Kommunikation mit der Engine im Analysefenster ausgegeben.

Mit "ucilog" können Sie ein- bzw. ausschalten, dass Shredder die gesamte Kommunikation mit der Engine in die Datei "ucilog.txt" schreibt.

Beide Funktionen sind beim Start von Shredder zunächst deaktiviert.


Winboard-Engines

Neben dem UCI-Protokoll ermöglicht Shredder die Einbindung von Winboard-Engines. Die Kommunikation zwischen dem Interface von Shredder und der WB-Engine erfolgt über einen Konverter.

Installation von Winboard-Engines

Die Installation von Winboard-Engines unter Shredder wurde anwenderfreundlich gelöst. Im Unterschied zu anderen Systemen ist es nicht notwendig, spezielle Anbindungsdateien mit Pfadangaben zu der eigentlichen Engine anzulegen. Dies bedeutet, dass Sie die WB-Engines in einem beliebigen Verzeichnis auf einer beliebigen Partition speichern und verwalten können.

Zur Einbindung unter Shredder gehen Sie wie folgt vor:

  • Wählen Sie unter EXTRAS / ENGINES den Eintrag "Installiere Engine".

  • Wählen Sie unter Enginetyp die entsprechende Engine aus. Zur Einbindung einer WB-Engine wählen Sie anstatt UCI-Engine "Winboard-Engine".

  • Im Fenster erscheint eine Dialogbox mit der Beschriftung "Installiere Winboard-Engine".

  • Neben der Eingabezeile befindet sich ein Button mit 3 Punkten. Klicken Sie diesen Button an, um den Pfad zu einer Engine mit der Maus einzustellen.

  • Auf dem Bildschirm erscheint jetzt eine dem Windows-Standard entsprechende Dateiauswahlbox. Hier können Sie den Pfad zu einer WB-Engine mit der Maus einstellen.

Nachdem Sie die die Engine, bzw. den Pfad ausgewählt haben, bestätigen Sie die Eingabe mit OK.

Nachdem Sie die Pfadangabe zu einer Engine ausgewähl haben, können und sollten Sie in der eingeblendeten Dialogbox noch den Enginenamen und den Namen des Autoren eintragen. Wenn Sie später die Engine unter Shredder laden, werden diese Angaben im Ladedialog für die WB-Engines und im Analysefenster zusätzlich angezeigt.

Hinweis Hinweise: Shredder legt automatisch eine Konfigurationsdatei mit der Endung *. ENG an. Die Textdatei hat folgenden Aufbau:

[ENGINE]

Name=Comet

Author=Dr. Ulrich Türke

Filename=D:\buffer\wb2uci.exe

[OPTIONS]

LoadEngine=D:\buffer\wbengines\Comet_A98.exe

[ENGINE] in diesem Abschnitt werden Angaben zur Schachengine gespeichert. Hier finden sich die Angaben über Schachengine, Autoren und den Konverter, der zu Laden der WB-Engine benötigt wird.

[OPTIONEN] in diesem Abschnitt stehen nach einer Erstinstallation die Pfadangaben zur Winboard-Engine.

Beachten Sie, dass fortgeschrittene Optionen der Winboard-Engines über Konfigurationsdateien gesteuert werden. Im Lieferumfang der WB-Engines finden Sie Dokumentationen der Autoren über die spezifischen Parameter der Engines. Aufgrund der präziseren Definition des UCI-Protokolls ist eine einheitliche Übergabe der Programmparameter nur mit UCI-Engines möglich.

Fortgeschrittene Optionen

Experten können über einige Parameter die Ausgabe von WB-Engines steuern.

Der Eintrag "ShowStats" unter [OPTIONS] im eng file kann auf "1" oder "true" gesetzt werden Dies bewirkt, das der aktuelle Zug der Engine angezeigt wird, falls die WB-Engine dies unterstützt.

Mit "SendToEngine" unter [OPTIONS] kann man einen String definieren, der zur Initialisierung an die Winboard-Engine geschickt wird

Beispiel:

[ENGINE]

Name=Crafty 17.13

Author=Robert Hyatt

Filename= wb2uci.exe

[OPTIONS]

LoadEngine=c:\chess\ Crafty\wcrafty.exe

ShowStats=1

SendToEngine=noise 1000


Engineoptionen

UCI-Engines verfügen über spezifische Optionen , die Sie über die integrierte Dialogbox komfortabel ändern und einstellen können.

Möglich Optionen sind zum Beispiel:

Bewertung jeder einzelnen Figur

Bewertung für Zentrumskontrolle u.s.w.

Selektivität, Remiswert u.s.w.

Zugriff auf die TableBases

Positionslernen

Der Optionendialog kann je nach Ausstattung einer Engine unterschiedlich ausfallen. Sie können die selbst erstellten Spielstile speichern.

Details für die Shredder-Engine...

Die Engines werden unter Shredder durch eine Datei mit der Endung *.ENG repräsentiert. Sie können übrigens Engines, bzw. deren Parameter modifizieren und als eigene Engine mit Bezeichnung abspeichern. Diese "eigenen" Engines werden im Auswahldialog wie eine vollwertige Engine behandelt. Sie können die selbst vorgenommenen Enginemodifikationen z.B. in Enginematches gegen andere Programme austesten.


Engine installieren

Menü Extras / Engines

Diese Funktion installiert, bzw. bindet eine Engine unter dem Interface von Shredder ein.

Um eine neue Engine unter Shredder einzubinden, gehen Sie wie folgt vor:

  • Wählen Sie im Menü Engines den Eintrag "Installiere Engine".

  • Wählen Sie in der Auswahlmaske den entsprechenden Enginetyp aus, Bei UCI-Engines wählen Sie "UCI", bei Winboard-Engines den Eintrag "Winboard-Engine".

  • Nachdem Sie den Enginetyp festgelegt haben, geben Sie die Pfadangabe zum Ordner der Engine vor. Sie können dies komfortabel in der Dialogbox mit der Maus bewerkstelligen, indem Sie auf den Button mit den drei Punkten klicken. Wählen Sie in der Dateiauswahlmaske den Pfad zu der Engine aus.

  • Anschliessend müssen Sie noch einen Namen für die Engine vorgeben. Diese Bezeichnung wird im späteren Ladedialog für eine Engine angezeigt. Zusätzlich können Sie in der Eingabemaske noch den Namen des Autoren der Engine eintragen.

Nach diesen Schritten ist die Engine unter Shredder angemeldet und kann geladen und gestartet werden.

Hinweis Engine deinstallieren --> Entfernt eine Engine aus dem Ladedialog.

Achtung Hinweis: die Engine wird beim Deinstallieren nicht physisch von dem Datenträger gelöscht !


Engine wechseln

Ersetzt eine aktive Engine mit einer neuen Engine.

Sie rufen diese Funktion durch einen Rechtsklick in das Analysefenster oder durch STRG-Q auf. Wählen Sie daraufhin im Ladedialog die gewünschte Engine aus.

Die Engine wird gewechselt und Sie können mit einer anderen Engine die Partie oder Analyse fortsetzen..


Engine hinzufügen

Fügt eine Engine zur Analyse hinzu. Sie können maximal 10 Engines parallel unter Shredder betreiben.

Achtung Hinweis: Alle geladenen Engines müssen sich die Systemresourcen teilen.


Engine schließen

Schließt eine aktive Engine und das entsprechende Such- bzw. Analysefenster.


Shredder-Engine einstellen

Sie können den Schachalgorithmus von Shredder modifizieren und in eigenen Spielstilen speichern. Die modifizierten Engines können im Ladedialog wie eine normale Engine installiert und genutzt werden.

Anmerkung: diese Optionen sind auch in der deutschen Version in Englisch. Grund: die Befehle werden direkt von der Engine geschickt.

Den Engineoptionendialog rufen Sie mit einem Rechtsklick in das Enginefenster auf.

Hinweis: Je nach Engine stehen unterschiedliche Optionen zur Verfügung.

Keep Hash Tables:

Shredder löscht nach jedem Zug nicht die Hashtabellen -> gut für Partien, vor allem Blitz, und Analyse

Position Learning:

Shredder berücksichtigt Ergebnisse der bisher gespielten Partien, auch wenn das Programm neu gestartet worden ist -> gut für Partien und Analyse. Shredder versucht bei Aktivierung dieser Option, aus seinen Fehlern zu lernen.

Prefer Open Positions:

Das Programm bevorzugt offene Stellungen, in denen seine stärken besonders gut zur Geltung kommen. So wird zwar nicht immer der beste, aber oft der unangenehmste Zug gespielt.

Use Tablebases:

Stellt ein, wie früh Shredder in der Suche auf die Nalimovendspieldatenbanken zugreifen soll.

Never: Shredder greift niemals auf die Endspieldatenbanken zu.

Late: Shredder greift erst spät zu und wird kaum abgebremst.

Normal: Shredder greift ausgewogen zu.

Early: Shredder greift sehr früh zu, die Suche wird dabei aber u.U. stark abgebremst.

Draw Score

Wie soll Shredder ein Remis bewerten? Bei einer Zahl kleiner als 0 spielt Shredder auf Gewinn, bei einer Zahl größer als 0 reicht ihm ein Remis

Clear Hash:

Löscht nach OK die Einträge in den Hashtabellen. Diese Option macht z.B. beim Lösen von Teststellungen Sinn.

Clear PosLearing:

Löscht die Lerndatei von der Festplatte. Shredder verliert sein bisher erworbenes Wissen.

Werte für Figuren:

Gibt den Wert für die einzelnen Figurentypen in % an. Der Grundwert für jede Figur beträgt 100%. Wenn Shredder z.B. zu oft Bauern opfert, kann man den Wert der Bauern auf 110% stellen. Damit wird die Figur Bauer "materialistischer" bewertet und Shredder wird eher an den Bauern "klammern". Im umgekehrten Fall kann man den Wert für einen Bauern heruntersetzen. Damit werden Bauern nicht mehr so hoch gewichtet und das Programm ist eher bereit, z.B. Bauern für Initiative herzugeben.

Tipp In der Dialogbox finden Sie für jeden Figurentyp den Eintrag "Endgame". Was bedeutet das? Gehen wir einmal von dem zuvor beschriebenen Beispiel aus. Es kann durchaus sinnvoll sein, im Mittelspiel mit vielen Figuren auf dem Brett den Faktor Material (Bauer) nicht zu hoch zu bewerten. In dieser Phase ist Raumvorteil, Aktivität u.s.w. viel wichtiger als in der Endspielphase einer Partie. Im Endspiel mit nur wenig Material sieht das oft ganz anders aus. Sie können also für unterschiedliche Partiephasen eine separate Wichtung vornehmen.

Beispiel:

Pawn = Wichtung für die Figur Bauer für das Mittelspiel und Eröffnung

Pawn (Endgame) = Wichtung des Bauern für das Endspiel.

Einstellungen für die Suche (nicht bei Shredder Classic):

Style

Intelligent - Aggressive - Active - Normal - Solid

Stellt ein, wie viel Shredder vom Suchbaum abschneiden soll. Bei Intelligent ist es am meisten, bei Solid am wenigsten.

Combinations

All - Most - Some - None

Stellt ein, wie viele taktische Wendungen Shredder untersuchen soll. Bei All sind es am meisten, bei None am wenigsten.

Forward Pruning

0...5

Gibt an, wie viele Halbzüge Shredder sinnlose Varianten weniger untersuchen soll.

Selectivity

Stellt ein, wie viele Halbzüge Shredder erfolgversprechende Varianten weiter untersuchen soll.

Bei -3, -2 und -1 wird dieser Wert automatisch bestimmt. Bei -1 am wenigsten, bei -2 am tiefsten, -3 ist ein Mittelwert.

Bei 0 - 99 kann man die Zahl der Halbzüge direkt eingeben.

Gewichte der Bewertungsparameter:

Im rechten Abschnitt kann man in %-Werten die wichtigsten Bewertungskriterien von Shredder beeinflussen. Einige Werte kann man analog wie oben auch getrennt für Eröffnung/Mittelspiel und Endspiel angeben.

King Safety

Der Faktor Königssicherheit kann hier beeinflusst werden.

Center Control

Bewertung des Faktors Zentrumskontrolle

Pawn Structure

Wie soll Shredder sein Wissen um typische Bauernstrukturen einsetzen ? Bei einem geringen Wert greift Shredder z.B. nicht auf dieses spezifische Wissen zu.

Passed Pawns

Wenn man z.B. glaubt, dass Shredder Freibauern überschätzt, dann kann man Passed Pawns auf 90% setzen.

Bishop Pair

Bewertung des Faktors Läuferpaar

Time Usage

Bei größeren Werten nimmt sich Shredder mehr Zeit, zieht also langsamer, hält aber natürlich die eingestellte Zeitkontrolle ein.

Knowledge or Speed

Wie intensiv soll konkretes, implementiertes Schachwissen berücksichtigt werden? Ein geringer Wert reduziert den Zugriff, Shredder bewertet dann also nicht mehr so genau, die Engine rechnet dafür schneller.

Threads (nur bei Deep Shredder)

Stellt auf einem Mehrprozessorsystem ein, wie viele Prozessoren Shredder gleichzeitig nutzen soll. Je größer die Zahl, desto schneller und effizienter kann Shredder rechnen.


Engine-Zweikampf

Sie können unter Shredder unterschiedliche Engines gegeneinander testen.

Folgende Anwendungsgebiete sind beispielsweise mit dieser Funktion möglich:

  • Testen modifizierter Schachengines

  • Testen externer UCI- oder Winboard-Engines

  • Testen eigener oder neuer Eröffnungsbücher in Kombination mit einer Engine

Der Dialog Engine-Zweikampf wird über das Menü Modus oder mit Strg-8 aufgerufen.

Weiß

Klicken Sie auf den Button mit den drei Punkten. Wählen Sie in dem Dialog die gewünschte Engine aus.

Schwarz

Klicken Sie auf den Button mit den drei Punkten. Wählen Sie in dem Dialog die gewünschte Engine aus.

Für Weiß und Schwarz können Sie ein eigenes Eröffnungsbuch laden. Klicken Sie auf den Button mit den drei Pfeilen und wählen Sie das gewünschte Eröffnungsbuch aus.

Enginebuch verwenden

Manche Engine greifen selber auf Ihr Eröffnungsbuch zu und über lassen dies nicht der GUI, wie es z.B. Shredder macht. Für diese Engines kann man hier einstellen, dass sie ihr internes Buch benutzen sollen. Den Namen des Buches kann man allerdings nicht ändern.

Spielstufe

Sie können über Zeitkontrollen oder Blitz die Bedenkzeiten für die Partie einstellen.

Permanent Brain

Das Permanent Brain sollten Sie ggf. auf einem System mit nur einem Prozessor abschalten. Sinnvoll ist diese Option auf Dualrechnern mit zwei Prozessoren.

Farben wechseln

Nach jeder Partie werden die Farben gewechselt. Sie können dies unterdrücken, in dem Sie das Häkchen deaktivieren.

Buchlernen

Die Engines sollen die Ausspielwahrscheinlichkeiten ihrer Bücher anhand der Ergebnisse der gespielten Partien modifizieren.

Partienzahl

Hier können Sie ein Limit für die Anzahl der zu spielenden Partien setzen.

Speichern

Sie können zur Speicherung der gespielten Partien eine Datenbank auswählen. Klicken Sie auf den Button mit den drei Punkten.

Eröffnungen

Sie können vorgeben, dass die Engines mit vorgegebenen Stellungen Enginematches spielen sollen. Damit schließen Sie den Einfluß des Eröffnungsbuches aus und können gleichzeitig testen, wie sich die Engines in bestimmten Stellungstypen verhalten. Die Stellungen müssen in einer PGN- oder CBF-Datenbank gespeichert sein. Geben Sie zuerst die gewünschten Ausgangsstellungen ein und speichern diese in einer Datenbank. Anschliessend laden Sie die Datenbank mit einm Klick auf den Button mit den drei Punkten.

Ohne Bücher

Hier können Sie mit einem Mausklick alle Bücher für den Zweikampf ausschalten.


Engine-Turnier

Sie können unter Shredder unterschiedliche Engines gegeneinander in einem Turnier automatisch testen.

Sie haben die Wahl, ob Sie ein neues Turnier beginnen oder ein altes fortsetzen wollen.

Der Dialog Engine-Turnier wird über das Menü Modus oder mit Strg-7 aufgerufen.

Titel

Geben Sie einen Namen für das Turnier ein.

Installierte Engines

Zeigt eine Liste der auf Ihrem Rechner installierten Engines an. Durch einen Doppelklick oder aber einen Klick auf den Pfeil nach rechts können Sie eine Engines zu einem Turnier einladen.

Teilnehmer

Zeigt eine Liste der Teilnehmer an Ihrem Turnier an. Durch einen Doppelklick auf eine Engine oder durch einen Klick auf den Pfeil nach links können Sie eine Engine wieder ausladen.

Alle ein Buch

Alle Engines spielen mit dem gleichen Eröffnungsbuch

Alle eine Hashgröße

Alle Engines spielen mit der gleichen Hashgröße

Eröffnungsbuch

Je nach Einstellung wählen Sie hier das Buch für eine Engine oder aber für alle Engines aus.

Enginebuch verwenden

Manche Engine greifen selber auf Ihr Eröffnungsbuch zu und über lassen dies nicht der GUI, wie es z.B. Shredder macht. Für diese Engines kann man hier einstellen, dass sie ihr internes Buch benutzen sollen. Den Namen des Buches kann man allerdings nicht ändern. Diese Einstellung gilt entweder für alle Engines oder aber nur für die aktuell ausgewählte.

Spielstufe

Sie können über Zeitkontrollen oder Blitz die Bedenkzeiten für die Partie einstellen.

Permanent Brain

Das Permanent Brain sollten Sie ggf. auf einem System mit nur einem Prozessor abschalten. Sinnvoll ist diese Option auf Dualrechnern mit zwei Prozessoren.

Buchlernen

Die Engines sollen die Ausspielwahrscheinlichkeiten ihrer Bücher anhand der Ergebnisse der gespielten Partien modifizieren.

Turniertyp

Beim Turniertyp haben Sie die Auswahl zwischen einem Rundenturnier, bei dem jeder gegen jeden spielt und einem Spießrutenlauf, bei dem die erste Engine gegen alle anderen spielt.

Durchgänge

Hier stellen sie die Anzahl der Durchgänge und somit auch die Anzahl der Partien in Ihrem Turnier ein.

Eröffnungen

Sie können vorgeben, dass die Engines mit vorgegebenen Stellungen Engineturniere spielen sollen. Damit schließen Sie den Einfluß des Eröffnungsbuches aus und können gleichzeitig testen, wie sich die Engines in bestimmten Stellungstypen verhalten. Die Stellungen müssen in einer PGN- oder CBF-Datenbank gespeichert sein. Geben Sie zuerst die gewünschten Ausgangsstellungen ein und speichern diese in einer Datenbank. Anschliessend laden Sie die Datenbank mit einm Klick auf den Button mit den drei Punkten.

Ohne Bücher

Hier können Sie mit einem Mausklick alle Bücher für den Zweikampf ausschalten.


Das Eröffnungsbuch

Alle Funktionen zum Bearbeiten von Eröffnungsbüchern finden Sie unter Extras -> Eröffnungsbuch.

Das Eröffnungsbuch von Shredder ist in einem Positionsbaum gespeichert. Das mitgelieferte Eröffnungsbuch enthält ca. 20.000 Züge und wurde von dem Eröffnungsexperten Sandro Necci aus Italien sorgfältig editiert. Die Bibliothek berücksichtigt Zugumstellungen.

Zu jeder Stellung des Positionsbaums ist eine Vielzahl von Informationen eingebettet. Diese Informationen werden im Zügefenster angezeigt. Sollten Sie den Inhalt der Bibliothek nicht angezeigt bekommen, klicken Sie mit der rechten Maustaste in das Buchfenster und aktivieren den Eintrag Buchzüge. Folgende Informationen werden in den Spalten des Buchfensters dargestellt:

  • Zug in dieser Spalte es werden die im Buch enthaltenen Züge des Programms zur aktuellen Brettposition angezeigt.

  • Prob dieser Wert zeigt die Ausspielwahrscheinlichkeit des jeweiligen Zuges in Prozent an.

  • N zeigt die Gesamtzahl der Partien an, die mit diesem Zug gespielt wurden und die im Positionsbaum enthalten sind.

  • % zeigt die Erfolgsquote des Zuges in Prozent an.

  • Elo der durchschnittliche Elowert der Spieler, auf deren Partien die Bewertung des jeweilgen Eröffnungszuges basiert. Je höher der Elowert in dieser Spalte ist, um so hochwertiger und damit aussagekräftiger sind die Bewertungen des Positiosbaums zur Erfolgsstatistik eines bestimmten Zuges.

  • Perf zeigt auf der Basis der importierten Partien die Performance eines Zuges in Elo an, die mit dieser Eröffnung erzielt wurden. Ein hoher Wert signalisiert, dass die Erfolgsquote dieses Zuges statistisch sehr hoch ist.

  • Jahr zeigt das Jahr an, in dem die meisten Partien gespielt wurden, die als Datengrundlage in den Baum eingeflossen sind.

  • + = - Anzahl der Siege, Remisen und Verlustpartien eines Eröffnungszuges. Diese Werte beziehen sich auf die importierten Partien des Positionsbaums.

Hinweis: Sie können die Einträge sortieren, indem Sie mit der linken Maustaste in den Header der jeweiligen Spalte klicken.

Sie können sowohl das mitgelieferte Eröffnungsbuch von Shredder editieren, erweitern und beliebig viele neue Eröffnungsbücher anlegen. Die Eröffnungsbücher von Shredder unterliegen keiner Einschränkung hinsichtlich der Größe und haben die Dateiendung *.BKT. Um die Bücher zu editieren oder erweitern zu können, müssen sie auf der Festplatte installiert sein.

Die Eröffnungsbücher bieten reichhaltige Möglichkeiten für das häusliche Schachtraining. Sie können jetzt besonders einfach das Repertoire des Programms erweitern oder bestimmte Linien mit Präferenzen versehen. Als aktiver Turnierspieler sollten Sie unbedingt die Möglichkeit nutzen, ein an das eigene Repertoire angepaßtes Buch zu generieren. Mit Hilfe der Importfunktion können Sie aus Datenbanken jederzeit eigene Bücher für Trainingszwecke erstellen.


Positionsbaum

Ein Positionsbaum ist eine große Datenbank von Schachstellungen und Zügen, mit deren Hilfe man für eine bestimmte Schachstellung herausfinden kann, welche Züge in dieser Stellung schon gespielt worden sind. Ein Computer benötigt dieses Wissen, damit er in der Eröffnungsphase schnell einen Zug ausspielen kann, ohne seine internen Schachalgorithmen zu verwenden. Dadurch kann er Bedenkzeit einsparen und strategische Fehler in der Eröffnung vermeiden. Bisher ist das noch nichts Neues, doch werden in dieser Datenbank zusammen mit den einzelnen Zügen noch weitere Informationen gespeichert.

Man kann zum Beispiel für jeden Zug herausfinden, wie oft er schon gespielt worden ist und wie seine Erfolgsquote lautet, d.h. wie oft Weiß oder Schwarz mit diesem Zug gewonnen oder verloren hat und wie oft die Partie unentschieden ausging. Weiter kann man auch ablesen, welchen Elodurchschnitt beide Seiten hatten sowie neuerdings auch, in welchem Jahr der Zug besonders häufig gespielt worden ist.

Damit kann man sehr gut zwischen klassischen und modernen Varianten unterscheiden. Mit diesen Informationen kann man leicht die Eloleistung für jeden Zug ausrechnen. Es macht z.B. einen Unterscheid, ob man 60% gegen gleichwertige Gegner oder aber 80% gegen schwächere Gegner erreicht.

Vorzüge des Positionsbaums

Wie sie sehen, bietet dieses Konzept eine Fülle von sehr nützlichen Informationen, und damit sind wir bei der entscheidenden Neuerung. Bisher war es nämlich immer nur der Computer oder aber das Programm, welches von dem Wissen in seinem Eröffnungsbuch profitieren konnte, doch nun hat auch der menschliche Benutzer ein sehr mächtiges und nützliches Informationssystem zur Hand.

Er kann sich nun sehr gezielt in einer bestimmen Eröffnungsvariante vorbereiten und die bisher in dieser Variante gespielten Züge sehr schnell auf ihre Tauglichkeit untersuchen. Weiterhin sieht er auch sofort, wo die bekannte Theorie zu Ende ist und muss dazu nicht erst diverse Schachbücher oder elektronische Partiedatenbanken durchstöbern.

Auch die Schachprogramme haben allerdings einen deutlichen Mehrwert. Sie nutzen natürlich die gespeicherten Informationen für Ihre Zugauswahl in der Eröffnung aus. Wenn es zum Beispiel in einer gegebenen Stellung zwei Züge zur Auswahl gibt, von denen der eine dreimal gespielt worden ist und mit dem die Partie auch dreimal den Bach runter ging, der andere jedoch nach 100 Partien eine Quote von 60% hat, sollte die Zugwahl des Programms klar sein. Dies ist aber noch lange nicht alles. Es ist nun auch viel besser möglich, das Ausspielverhalten in der Eröffnung zu beeinflussen. Durch eine Vielzahl von Einstellmöglichkeiten kann man fast stufenlos bestimmen, ob das Programm nur die besten Züge spielen soll oder aber abwechslungsreicher auch einmal potenziell schlechtere Züge wählen soll. Weiterhin kann man auch nur die Hauptvarianten spielen lassen oder aber sich auf die Nebenvarianten beschränken.


Neues Buch

Neues Eröffnungsbuch

Legt ein neues Eröffnungsbuch an.

Die Dateiendung für die Eröffnungsbücher von Shredder lautet *.BKT.

Sie können diese Bücher durch den Import von CBF- oder PGN-Datenbanken erweitern.


Buch laden

Eröffnungsbuch laden

Lädt ein existierendes Eröffnungsbuch .

Hinweis: es kann immer nur ein Buch aktiv sein.


Import

Eröffnungsbuch importieren

Neben Datenbanken kann ein Positionsbaum durch den Import von Eröffnungsbüchern anderer Schachprogramme erweitert werden.

Zur Auswahl stehen Bücher der Programme ChessGenius 1 - 5, Rebel und Fritz 1 - 4.

Hinweis Man kann auch bereits existierende Positionsbäume importieren.

Partien importieren

Es können Datenbanken im CBF- und PGN- Format in ein bestehendes Eröffnungsbuch von Shredder importiert werden. Dabei können Sie über eine Dialogmaske mit den nachstehend beschriebenen Optionen den Import kontrollieren:

  • Varianten importieren CBF-Datenbanken können neben reinen Notationen auch Varianten enthalten. Bei Aktivierung dieser Funktion werden Varianten in den Positionsbaum integriert.

  • Statistik importieren berücksichtigt die Erfolgskoeffizienten von Zügen und Partien

  • Zugbewertung importieren berücksichtigt beim Import von Büchern oder Datenbanken vorhandene Zugwertungen

  • Die Variantentiefe kann beim Import der Daten mit der Vorgabe Halbzüge ebenfalls gesteuert werden.

  • absolute Länge legt die Tiefe in Halbzügen fest, mit der eine Variante in den Positionsbaum integriert werden soll.

  • ECO-relative Länge legt die Tiefe in Halbzügen fest, mit der eine Variante nach der zuletzt vorgefundenen ECO-Stellung importiert werden soll.

Aktuelle Partie importieren

importiert die aktuell geladene Partie in den Positionsbaum.


Buchzüge zählen

Gibt in einem Informationsfenster eine Information über die effektive Anzahl von Eröffnungszügen im Positionsbaum aus


Buch jäten

Eröffnungsbuch jäten

Shredder überprüft den Inhalt des Positionsbaums und löscht nichtrelevante Züge.

Z.B. werden Züge, die nur auf einer geringen Partienzahl basieren, entfernt.


Buchoptionen

Über diese Funktion kann das Eröffnungsverhalten von Shredder nachhaltig gesteuert werden. Sie können den Eingabedialog einfach mit einem Rechtsklick der rechten Maustaste in das Zügefenster aufrufen, wenn die Buchzüge angezeigt werden. In der Eingabemaske kann man für fast jeden Parameter der Zugauswahl innerhalb des Buches Einstellungen vornehmen.

Eröffnungsbuch verwenden

legt fest, ob Shredder mit oder ohne Bibliothek spielt.

Enginebuch verwenden

Aktiviert das spezifische Enginebuch, welches von manchen Engines verwendet wird. Bei Shredder wird das Eröffnungsbuch von der GUI gesteuert, diese Funktion ist also nicht aktivierbar.

Buchmodus

Shredder spielt bei der Einstellung Turnier nur Eröffnungszüge, die der Spielweise des Programms besonders gut liegen. Man kann Buchzügen Werte von a -g zuordnen. Im rechten Abschnitt Wert können Sie einem Zug einen Wert zuweisen.

A Züge werden häufiger, e Züge seltener und f und g Züge nie gespielt. Im Buchmode "Turnier" spielt Shredder nur a - c -Züge, wenn vorhanden. Bei Standard spielt er a-d und bei Weit spielt er auch die e Züge.

Buchlernen

Schaltet die Lernfunktion für das Eröffnungsbuch ein.Löschen entfernt die Ergebnisse.Beim Buchlernen merkt sich das Programm, ob seine Stellung nach dem Buch gut oder schlecht war. So kann man unter anderem Gewinne unterschieden, bei denen es zwischendurch schlecht stand oder ob sie souverän gewonnen wurde.

Ergebnislernen

Das Programm berücksichtigt beim Ausspielen eines Zuges die bisher damit erzielten Ergebnisse aus eigenen Partien. Bei dieser Option merkt sich Shredder, wie erfolgreich er mit einer Variante gespielt hat, d.h. wie oft er gewonnen und verloren hat.

Zugwerte

Berücksichtigt die Zugwerte a-g für jeden Zug.

Statistik verwenden

Berücksichtigt beim Ausspielen eines Zuges die Ergebnisse aus der im Baum gespeicherten Statistik.

Widerlegungen beachten

Beachtet mögliche Widerlegungen der im Buch enthaltenen Züge. Beispiel: ein Zug wurde 1000mal mit einer Erfolgsquote von 60% gespielt. Die letzten Partien gingen jedoch fast alle verloren. Dies deutet darauf hin, dass eine Widerlegung gefunden wurde. Shredder versucht dies zu erkennen und den entsprechenden Zug zu korrigieren.

Klassisch/Modern

legt über den Schiebeschalter fest, ob Shredder eher klassische Eröffnungen oder ein modernes Repertoire aus dem Positonsbaum ausspielt.

Ausspielbedingungen

über diese Schalter können Sie festlegen, aufgrund welcher Kriterien Shredder seine Züge ausspielt. Shredder spielt einen Zug nur dann aktiv aus dem Buch, wenn damit mindestens "Partieminimum" Partien gespielt worden sind, von denen mindestens "Gewinnpartien" Partien gewonnen worden sind. Als Weisser muss die Erfolgsquote dann mind. "Weißquote" Prozent sein, als Schwarzer "Schwarzquote" Prozent.

Zugnummer

Spielt nur maximal so viele Züge aus dem Buch

Einfluss der Faktoren

Hier können Sie die Werte beeinflussen, auf deren Basis Shredder Züge aus dem Positionsbaum selektiert. Über den Schiebeschalter Zugwert kann man die Gewichtung der einzelnen Zugbewertungen verändern. Im Eröffnungsbuch sind die Zugwerte mit den Buchstaben a-g gekennzeichnet. Wenn der Schieber nach rechts geschoben wird, spielt Shredder Züge mit der Wertung a noch häufiger.Schiebt man den Scoreschieber nach rechts, berücksichtigt Shredder nochmehr, wie erfolgreich die Züge in der Datenbank waren, ist der Schieber links, ist es dann fast egal, ob ein Zug nun eine Erfolgquote von 10 oder 90% hat.

Gleiches gilt für die Parameter Partienanzahl, Erfolgsquote und Lernwerte.

Tipp: Vergrössern Sie das Buchfenster, während Sie die einzelnen Parameter bearbeiten. Sie können sofort die Auswirkungen der Änderungen im Buchfenster erkennen und ablesen.


Buch editieren

Sie können die Eröffnungsbibliotheken von Shredder editieren. Siehe auch Zugbewertung ....

Klicken Sie dazu mit der rechten Maustaste auf einen Zug im Buchfenster. Sie können jetzt manuell für einen Zug Attribute vergeben, die beim Ausspielen berücksichtigt werden.

Shredder spielt bei der Einstellung Turnier nur Eröffnungszüge, die der Spielweise des Programms besonders gut liegen. Man kann Buchzügen Werte von a-g zuordnen. Im rechten Abschnitt Wert können Sie einem Zug einen Wert zuweisen.

a Züge werden häufiger, e Züge seltener und f und g Züge nie gespielt. Im Buchmode "Turnier" spielt Shredder nur a - c -Züge, wenn vorhanden. Bei Standard spielt er a-d und bei Weit spielt er auch die e Züge.

Siehe auch hier...

Zug löschen entfernt einen Zug aus dem Buch.

Tipp Sie können die Buchzüge durch Anklicken im Zügefenster ausspielen.

Tipp Textkommentar -> In dem Eingabefenster können Sie Textkommentare zu einzelnen Eröffnungszügen erfassen.

Mit den Kommentarsymbolen können Sie den Zug bewerten. Shredder berücksichtig dies jedoch nicht bei seiner Zugauswahl aus dem Buch.

Siehe auch hier...


Buchzüge kommentieren

Shredder bietet die Möglichkeit, einzelne Buchzüge neben den üblichen Kommentarkürzeln zusätzlich mit Text zu kommentieren.

Um einen bestimmten Buchzug zu kommentieren, gehen Sie wie folgt vor:

Klicken Sie den zu kommentierenden Zug im Buchfenster mit der rechten Maustaste an. Es wird folgende Dialogmaske eingeblendet:

Im Textfeld Kommentar können Sie ihre Kommentare zu den Inhalten des Eröffnungsbuches eintragen.

Sie sollten diese innovative Option z.B. dazu benutzen, Anmerkungen und Ergänzungen zu Ihrem persönlichen Eröffnungsrepertoire vorzunehmen.

Anzeige der Kommentare

Im Buchfenster existiert der Abschnitt Kommentar. Dort können Sie vorhandene Kommentare auf Anhieb erkennen.

Klicken Sie mit der rechten Maustaste auf den dazugehörigen Kommentar.

Das zuvor abgebildete Kommentarfenster wird eingeblendet. Sie können hier die Kommentare einsehen oder editieren.

Die Kommentare aus der Eröffnungsbibliothek werden im Analysefenster angezeigt, wenn Sie während einer Partie ausgespielt werden.

Kommentare werden in der Datei "shredder.bkc" gespeichert. Die Kommentierung ist nicht mit einem bestimmten Buch verknüpft, sondern gilt global für mehrere Biobliotheken, falls vorhanden. Sie sollten daher von der Datei "shredder.bkc" eine Sicherungskopie anfertigen.


Zugbewertung im Buch

Zugbewertung Eröffnungsbuch

Man kann Buchzügen Werte von a -g zuordnen. Ein Rechtsklick ruft den nachstehenden Dialog auf. Im rechten Abschnitt Wert können Sie einem Zug einen Wert zuweisen.

A Züge werden häufiger, e Züge seltener und f und g Züge nie gespielt.

Im Buchmode "Turnier" spielt Shredder nur a - c -Züge, wenn vorhanden. Bei Standard spielt er a-d und bei Weit spielt er auch die e Züge.


Pocket Fritz

Eröffnungsbücher für Pocket Fritz

Falls Sie das Programm Pocket Fritz für Pocket PC`s besitzen, können Sie Eröffnungsbücher von Shredder in das Format von Pocket Fritz konvertieren.

Dazu gehen Sie wie folgt vor:

  • Laden Sie das Eröffnungsbuch in Shredder.

  • Wählen Sie Eröffnungsbuch exportieren aus dem Menü Extras / Eröffnungsbuch und beantworten Sie ggf. die Frage, ob Sie ein Textbuch exportieren wollen mit Nein. Shredder erzeugt eine Datei mit der Dateiendung *. PBK.

  • Die Datei muß umbenannt werden. Vergeben Sie die Bezeichnung "book.pbk". Pocket Fritz setzt voraus, dass eine Eröffnungsdatei mit dieser bezeichnung in seinem Verzeichnis existiert.

  • Kopieren Sie die Datei "book.pbk" in das Verzeichnis von Pocket Fritz auf dem Handheld.


TableBases

Shredder kann auf die von Eugene Nalimov entwickelten Endspieldatenbanken (=TableBases) zugreifen. Die Informationen aus den Nalimov-Endspieldatenbanken werden von Shredder während der Suche aktiv genutzt und steigern die Endspielstärke des Programms beträchtlich.

Die Nalimov Endspieldatenbanken sind im Internet frei erhältlichen.

Bevor Sie die Informationen aus den Endspieldatenbanken nutzen können, müssen Sie den Zugriff darauf aktivieren und gleichzeitig die Anzeige für die Inhalte aktivieren. Wählen Sie im Zügefenster per Rechtsklick die Einstellung "Endspieldatenbank". Alternativ und schneller geht dies mit der Tastenkombination Strg+Umschalt+E).

Shredder kann direkt auf eine riesige Onlineendspieldatenbank im Internet zugreifen, in der alle bisher erhältlichen Endspieldatenbanken mit 3 - 6 Steinen gespeichert sind. Drücken Sie dazu einfach den "Online"-Button im Zügefenster, wenn dieses auf Endspieldatenbanken eingestellt ist.

Falls Sie über ein Proxy auf das Internet zugreifen und Shredder dies beim Zugriff auf die Online-Endspieldatenbanken nicht automatisch erkennt, können Sie im Shredderverzeichnis eine Datei proxy.ini mit folgenden Inhalten anlegen.

Zugriff über den Proxy 192.168.0.1 über Port 8080:

[INTERNET]

Proxy=192.168.0.1:8080

Direkter Zugriff ohne Proxy:

[INTERNET]

Proxy=no


Pfad angeben

Pfad für die Endspieldatenbanken

Gibt den Pfad für die Endspieldatenbank vor. Shredder muß eine Information haben, wo die Datenbanken installiert sind.

Menü Extras -> Engines -> Endspieldatenbanken

Pfadangabe zu den TableBases einstellen

In der Dialogbox können Sie insgesamt fünf Pfade für die Datenbanken eintragen, bzw. mit der Maus selektieren. Jeden Pfad können Sie einzeln ein oder ausschalten. Die TableBases benötigen sehr viel Festplattenspeicher.

Sollten Sie die kompletten TableBases auf CD-Rom haben, können Sie in der Dialogmaske die entsprechende Pfadangaben eintragen. Sie können weitere Tablebases generieren.

Mit "GUI nutzt Endspieldatenbanken" können Sie die Benutzung der Endspieldatenbanken für die GUI deaktivieren. Dadurch sparen Sie den von den Endspieldatenbanken benötigten Arbeitsspeicher ein. Die Pfade werden dann nur zu der Engine geschickt, die dann weiterhin auf die Datenbanken zugreifen kann.

Was bedeutet Cachegrösse?

So könnnen Sie die Endspieldatenbanken automatisch installieren.


Cachegrösse

Gibt die Grösse des zu reservierenden Bereiches im RAM an.

Der Zugriff auf die Informationen der Nalimov- Endspieldatenbanken wird dadurch effizienter und schneller.


TableBases installieren

Installiere TableBases

Die Endspieldatenbanken benötigen je nach Endspieltyp (z.B. Vier- oder Fünfsteiner) sehr viel Festplattenspeicher.

Falls Sie CDs mit weiteren TableBases haben, können Sie die Datenbanken aus Shredder heraus auf die Festplatte installieren.

Gehen Sie dazu wie folgt vor:

  • Legen Sie die gewünschte CD in das CD-Laufwerk

  • Unter dem Menüpunkt EXTRAS/ENGINES/ENDSPIELDATENBANKEN finden Sie den Eintrag "Installiere...".

  • Geben Sie in der Auswahlbox den Pfad an, wohin die Inhalte der CD kopiert werden sollen. Sie können den Pfad zu dem gewünschten Verzeichnis mit der Maus vorgeben, indem Sie auf den Button mit den drei Punkten klicken. Wählen Sie in der Auswahlbox das Zielverzeichnis aus.

Hinweis: Sie können nur den kompletten Inhalt einer CD auf die Festplatte kopieren. Wenn Sie nur bestimmte Endspiele auf die Festplatte kopieren wollen, müssen Sie dies manuell mit dem Explorer tun.

Hinweis: der Kopiervorgang kann einige Zeit in Anspruch nehmen, da es sich um sehr große Dateien handelt.


Dateistruktur

Dateistruktur TableBases

Will man sämtliche TableBases (bis max. Sechssteinern) einsetzen, benötigt man einiges an Festplattenspeicher. Alle zur Zeit verfügbaren Sechssteiner belegen zusammen ca. 500 GB. Alle Fünfsteiner ca. 8 GB.

Falls Sie nur an bestimmten Endspielen interessiert sind (siehe auch Endspielorakel) oder wenig Festplattenspeicher verfügbar haben, müssen Sie das gewünschte Endspiel einzeln mit dem Explorer auf ihre Festplatte kopieren. Dazu müssen Sie wissen, wie ein Endspiel aufgebaut ist.

Aufbau einer Endspieldatei

Es gibt für jeden Endspieltyp zwei Dateien, in denen das Zugrecht festgelegt wird; eine für Weiß und eine für Schwarz am Zug. Anhand des Dateinamens kann man sofort erkennen, welches Endspiel in den Dateien enthalten ist. Beispiel: KQRK.NBB enthält das Endspiel König+Dame gegen König+Turm. Die Kürzel, z.B. Q(Queen) stehen für die Figurenbezeichnung aus dem Englischen. Die Erweiterung des Dateinamens NBB bedeutet konkret N=Neu, B=Base, B=Schwarz (black) am Zug; .NBW steht also für N=Neu, B=Base, W=Weiß (white) am Zug.

Der Dateiname enthält eine zweite Erweiterung mit der Bezeichnung *.EMD, die für die komprimierten TableBases steht. Im Prinzip braucht sich der Anwender darum nicht zu kümmern, da die entsprechenden Programme automatisch auf die TableBases zugreifen.

Während nun die Drei- und Viersteiner sich noch in erträglichen Größenordnungen bewegen, steigt der Speicherbedarf für Endspiele mit Fünfsteinern überproportional an. Will man z.B. alle verfügbaren Fünfsteiner im Nalimov-Format auf die Platte kopieren, fallen dafür um die 8 GB an.


Was sind TableBases ?

Nalimov-Datenbanken

Die Endspieldatenbanken von Eugene Nalimov wurden 1998 veröffentlicht.

In Fachkreisen bezeichnet man die Nalimov-Datenbanken als TableBases, die ein gigantisches Nachschlagewerk darstellen, in dem bestimmte Schachstellungen (Endspiele) gespeichert sind.

Die zur Zeit geläufigen Tablebases enthalten für fast wichtigen Vier- und Fünfsteiner sowie einige Sechssteiner alle möglichen Stellungskonstellationen, die nach einem vorgegebenen Schema systhematisiert sind. Für jede mögliche Position innerhalb einer bestimmten Figurenkonstellation ist eine Information über Gewinn, Remis oder Verlust gespeichert. Falls die Stellung konkret gewonnen oder verloren ist, wird zusätzlich noch die maximale Anzahl von Zügen bis zum Matt angegeben.

Ein Schachprogramm mit einer Schnittstelle zu den TableBases kann also eine absolute präzise Angabe über die alle Drei- Vier- und Fünfsteiner machen und wird im Unterschied zu den Thompson-Datenbanken die Werte aus der Endspieldatenbank bereits in der Suche berücksichtigen.


Endspielorakel

Eine sehr inovative Funktion von Shredder ist das Endspielorakel. Informationen über ähnliche die Jokeranalyse finden Sie hier.....

Mit Hilfe dieser Funktion ist es möglich, alle 3- bis 6-Steiner-Endspiele auf bisher noch nie mögliche Weise zu durchforsten.Insbesondere für das Endspieltraining und die Forschung können Sie es effizient einsetzen.

Wichtiger Hinweis ! Diese Funktion steht nur dann zur Verfügung, wenn die Nalimov-Tablebases installiert und aktiviert sind.

Ein Beispiel: Eine untersuchung mit der Datei Springer+Springer gegen einen Bauern zeigt, was man damit u.a. machen kann: Der Schach-Großmeister Ludek Pachmann schreibt in seiner »Endspielpraxis im Schach« (Heyne Verlag 1977; S. 10), c5 sei »die Grenze, an der ein schwarzer Bauer blockiert werden muss, damit der Gewinn [durch die 2 Springer] überhaupt möglich ist. Falls der schwarze Bauer diese Linie überschreitet, gibt es keinen Gewinn mehr.«

Stimmt das auch wirklich? Mit dem Orakel ist dies überprüfbar.

Weiter ....


Stellung definieren

Man gibt zunächst im Stellungseingabefenster (Strg+D) eine beliebige Position mit zwei Springer gegen einen Bauern, jedoch dem schwarzen Bauern auf c4 ein, denn wir wollen ja sehen, ob auch ein Bauer, der weiter als bis auf c5 vorgerückt ist, gewinnt. Unter Extras/Endspielorakel (bzw. Strg+F12) kann man nun beliebig vielen Steinen auf dem Brett, mindestens jedoch einem, einen von 3 sogenannten »Jokern« zuweisen.

Es gibt wählbare Joker für:

für alle Felder des Brettes

für die Linie, auf der der Stein am Brett steht

für die Reihe, auf der der Stein am Brett steht

für das Standfeld des Steines bis zu einem beliebigen Randfeld der gleichen Linie oder Reihe

»Joker« bedeutet, dass bei der anschließend beschriebenen vollständigen Fahndung in der gesamten S+S–B-Tablebase-Datei der oder die Stein(e) auf allen durch die Jokervergabe jeweils ausgewählten Feldern berücksichtigt werden. Weist man etwa einem auf a8 eingegebenem Stein einen Reihenjoker zu, dann wird er auf allen Feldern von a8 bis h8 berücksichtigt. Weist man einen Brettjoker zu, dann wird der Stein auf allen 64 Feldern berücksichtigt. Welcher Joker vergeben wurde, wird durch einen kleinen roten Pfeil im Eck des Standfelds der Figur angezeigt.

Die Joker können mittels mehrmaligem Anklicken eines Steines mit der Maus gesetzt werden. Zu unserem Beispiel: Der Bauer c4 bekommt keinen Joker, alle anderen Steine einen Brettjoker.

Eingabe S+S - B im Endspielorakel

Danach legt man, wie in der Abbildung ersichtlich, das Zugrecht fest: Weiß, Schwarz oder beide. Nun kann vorgegeben werden, welche der Stellungen anschließend in einem EPD-File (tboracle.epd) gespeichert werden sollen:

  • Nichts (dann wird später nur die statistische Auswertung angezeigt)

  • Längsten Gewinn für Weiß/Schwarz

  • Remis

  • Stellungen mit vorher gewählter Mattdistanz (Shredder listet dann Stellungen auf, in denen Weiß z.B. in 26 Zügen matt setzt).

  • Stellungen gegenseitigen Zugzwangs (Weiß/Schwarz gewinnt, die andere Seite am Zug remisiert; beide am Zug verlieren).

Weiter ......


Informationen vom Orakel

Informationsausgabe des Orakels

Nachdem die Suche definiert wurde, kann die Suche durch die Endspieldatei gestartet werden.

Nochmals der Hinweis: die Suche funktioniert nur dann, wenn die entsprechende Endspieldatenbank installiert wurde.

Shredder gibt dabei eine Fülle von Informationen über das jeweilige Endspiel aus:

Nach der Analyse von über 5,4 Millionen Positionen zeigt Shredder also an, dass Weiß sehr wohl gewinnen kann; wenn er selbst am Zug ist sogar in 13,96 % aller Stellungen. Wäre »Zugrecht beide« ausgewählt, so sind es immerhin noch 7,51 %. Der längste weiße Sieg dauert 73 Züge bis zum Matt. Dies zeigt, dass die Siege nicht nur deshalb zustande kommen, weil der schwarze König schon zu Beginn am Brettrand eingekesselt ist.

Man kann anschließend wählen, ob man sich die gespeicherten Stellungen sofort ansehen und evtl. mit einem Klick auf die Positionsbeschreibung aufs Spielbrett laden und dort nachspielen will. Lädt man die Stellung und klickt dann auf »Stellung ausspielen« im Modusmenü, so spielt Shredder die Stellung gegen sich selbst zu Ende.

In unserem Beispiel sieht der gespeicherte Eintrag folgendermaßen aus:

Shredder speichert in der EPD-Datei also zusätzlich noch die Zahl der Stellungen zu allen möglichen Mattdistanzen und gibt deren Häufigkeit in %-Werten an. So kann man schnell sehen, ob viele der Mattführungen eher lange oder eher kurz dauern.

EPD-Dateien kann man übrigens auch mit einem Textverarbeitungsprogramm, z.B. Word, öffnen und die gewonnenen Daten damit weiterverarbeiten.


Analyse mit dem Orakel

Eigene Partien analysieren

Gestern habe ich in einer Turnierpartie ein Endspiel mit D+B(g7)–D verloren.

Hätte ich meinen König weit weg von Bauern eher auf a4 oder auf a1 stellen sollen?

Solche Fragen treten häufig auf, wennman aktiv Turnierschach spielt. Mit Hilfe des Endspielorakel können Sie sich ein besseres Verständnis für die Behandlung dieser Endspiele erarbeiten.

Vorgehensweise:

Steine verteilen: Weißer Bauer auf g7, schwarzer König auf a4

Setzen Sie den Brettjoker für die anderen Steine

Notieren Sie die Prozentzahl der weißen Siege

Wiederholen Sie die Prozedur mit einem schwarzen König auf a1 und vergleichen Sie die Werte der Orakelausgabe


Schachtraining

Training

Beispiel: Suchen Sie im Orakel alle Stellungen im Endspiel Dame und 2 Läufer gegen alleinigen König mit Matt in 23 Zügen. Eine davon durch einen einfachen Klick aufs Spielbrett laden und dann – natürlich ohne Ansicht der Zuginformationen – versuchen gegen (absolut optimales!) Datenbankgegenspiel matt zu setzen.


Der Autoplayer

Shredder ist zum Auto232-System kompatibel. Es ermöglicht Schachprogrammen,die dieses Standardprotokoll unterstützen, vollautomatisch auf zwei verschiedenen Rechnern gegeneinander zu spielen. Voraussetzung sind zwei PCs, die mit dem mitgelieferten Kabel über die serielle Schnittstelle miteinander verbunden werden.

Alternativ ist auch ein Spiel über ein Netzwerk möglich.

Der Autoplayer kann im Spieler-Menü gestartet werden. Das Dialogfeld bietet im wesentlichen die gleichen Möglichkeiten wie die Kommandozeilen-Optionen der DOS-Treiber des Auto232-Systems, mit den folgenden Unterschieden:

  • Der Name, der in das Feld „Gegner" eingetragen wird, wird mit den Partien gespeichert.

  • Mit der Option „Aufgeben" werden entschiedene Partien frühzeitig abgebrochen.

  • Der Autoplayer wurde verbessert. Er kann gegen ChessBase-Programme aufgeben und Remis anbieten/ablehnen. Shredder macht das nur, wenn die Option Etikette angeschaltet ist. Ausserdem kann man via Autoplayer Nunn-Matches mit vordefinierten Stellungen spielen. Dafür gibt es den erweiterten Modus im Autoplayerdialog.

  • Die „Netzwerk"-Option in „Schnittstelle" ermöglicht die Verbindung über ein Windows NT/2000-Netzwerk. Unter „Host" muß bei beiden PCs der gleiche Rechnername eingetragen werden. Dies kann entweder einer der beiden Autoplayer-Rechner oder ein dritter Rechner sein. Auf dem Host-Rechner wird das Steuerprogramm ausgeführt. Die Netzwerkverbindung funktioniert nicht unter Windows 95/98!

Hinweis: die via Auto232 gespielten Partien werden automatisch in der Datenbank "auto232.pgn" gespeichert.

Bitte entnehmen Sie Details zum Auto232-System der Auto232-Dokumentation.


Artikel TableBases

Die TableBases

von Stefan Meyer-Kahlen

Die TableBases

In letzter Zeit wird sehr viel über Tablebases gesprochen: Welches Programm sie benutzen kann und welches nicht, was sie bringen, wo man sie kaufen kann. Ich kann mich allerdings an keinen Artikel erinnern, in dem beschrieben sind, was Tablebases eigentlich sind. Ich möchte dies hiermit nachholen und jedem Interessierten diese sehr nützliche Erfindung näher bringen.

Bei den Tablebases handelt es sich im Prinzip um eine sehr große Datenbank, in der alle möglichen Schachpositionen gespeichert sind. Zusammen mit der Position wird auch noch ein Wert gespeichert, der besagt, ob die Stellung gewonnen, verloren oder Remis ist. Damit ist nicht gemeint, dass dort steht, die Stellung ist "wahrscheinlich Remis" oder aber "eventuell zu gewinnen", sondern es wird sogar die exakte Zuganzahl bis zum Matt angegeben, wenn die Stellung nicht remis ist. Steht in der Datenbank: "Gewonnen in 13 Zügen", dann kann also auch der beste Schachspieler es nicht mehr schaffen, diese Stellung Remis zu halten. Ebenso kann niemand eine Stellung mehr gewinnen, wenn in der Datenbank steht, das der Stellungswert Remis ist.

Diese Aussagen gelten natürlich nicht, wenn eine Seite nicht über die Informationen aus den Datenbanken verfügt. Dann ist es durchaus möglich und passiert sogar recht häufig, dass eine theoretisch gewonnene Stellung noch zu einem Remis wird. Wenn ein Spieler oder aber auch ein Schachprogramm die Tablebases befragen kann, während er oder es am Zug ist, dann gibt es kein entrinnen mehr: Das Spiel wird perfekt bis zum Matt fortgesetzt.

Nun kommt natürlich die Frage auf, warum so viele Schachspieler so viel Zeit und Fleiß in die Analyse einer Stellung stecken und warum es Leute wie mich gibt, die versuchen, einer Maschine das Schachspielen beizubringen, wenn doch alles so einfach ist. Einfach in die Datenbank gucken und schon weiß man, welche Seite gewinnen wird oder ob es vielleicht doch ein Remis gibt. Dies ist theoretisch natürlich möglich, doch der Haken an der Sache ist, dass diese Datenbanken sehr sehr groß sind und dass man auch unglaublich viel Zeit braucht, um sie zu erstellen.

Nehmen wir zum Beispiel einmal alle Schachstellungen mit je einem König und einer weiteren Figur. Es gibt drei Figuren oder Steine auf dem Brett, man spricht auch von einem Dreisteiner. Um diese Datenbank komplett abzuspeichern braucht man ca. 62 KB. Das ist sicher nicht mehr sehr viel, wenn man weiß, dass heute selbst die billigsten Rechner mit Festplatten mit einer Kapazität von 8 GB verkauft werden (1 GB = 1024 MB = 1024*1024 KB).

Ich kann mich aber noch sehr gut an meinen ersten Computer erinnern: Der hatte 64 KB Speicher, darin war aber auch schon das gesamte Betriebssystem enthalten, so ändern sich die Zeiten. Gehen wir einen Schritt weiter und betrachten die Viersteiner, jede Seite hat also nur noch den König und eine weitere Figur. Um diese Datenbank komplett auf der Festplatte zu speichern, braucht man 30320 KB oder ca. 30 MB, immer noch nicht sehr viel aber schon deutlich mehr als bei nur drei Figuren.

Die Fünfsteiner

Für viele dieser Stellungen ist der Ausgang der Partie allerdings auch ohne Endspieldatenbanken klar, so kann jeder Spieler, der das absolute Anfängerstadium hinter sich gebracht hat, mit König und Dame Matt setzen, und auch das Endspiel Dame gegen Turm lässt sich, wenn auch schon deutlich schwieriger, fast immer ohne Hilfe von Datenbanken gewinnen. Richtig interessant wird es erst mit fünf Figuren. Hier gibt es einige Beispiele, bei denen es schon sehr schwierig sein kann, die Stellung korrekt zu bewerten. Als Beispiel nenne ich nur KTB-KT oder KDB-KD, die in der normalen Turnierpraxis recht häufig vorkommen. Hier kann die Seite mit Materialvorteil nicht unbedingt immer gewinnen, und wenn die Stellung zu gewinnen ist, dann ist es zum Teil sehr schwierig und erfordert oft sehr genaue Zügen, um den Vorteil in einen Sieg umzuwandeln.

Wie viel Platz auf der Festplatte benötigt man nun für alle Tablebases, die alle möglichen Kombinationen von fünf Figuren enthalten? Es sind ca. 6054466 KB = ca. 6000 MB = ca. 6GB, also zehn prall gefüllte CD-ROMs! Es wird deutlich, dass der benötigte Speicherplatz explosionsartig zunimmt, wenn man die Datenbanken mit auch nur einer Figur mehr betrachten will. Dies ist auch der Grund, warum heute bei Fünfsteinern Schluss ist, der benötigte Speicherplatz wird einfach zu groß, um alle Stellungen abzuspeichern. Es gibt zwar bereits einige Sechssteiner als Endspieldatenbanken, bis es jedoch so weit sein wird, dass wir alle möglichen Kombinationen mit sechs Figuren als Tablebases vorliegen haben und jeder sie auf seinem Rechner verwenden kann, wird wohl noch einige Zeit vergehen.

Ausanalysiertes Schachspiel?

Man kann nun natürlich den Gedanken weiter spinnen und sich fragen, wann es denn soweit sein wird, dass wir alle 32-Steiner komplett erfasst haben. Dies würde dann natürlich bedeuten, dass Schach gelöst sein wird, wie man es in der Informatik im Bereich der Spieltheorie so schön nennt. Man könnte dann für jede beliebige Schachstellung sagen, ob sie Remis ist oder ob eine Seite gewinnt und wenn ja, wie viele Züge es noch bis zum Matt sind. Insbesondere weiß man dann natürlich auch, ob Weiß seinen Anzugsvorteil in der Grundstellung zwingend ausnutzen kann, ob es bei perfektem Spiel von beiden Seiten immer ein Remis gibt oder ob der Anzugsvorteils vielleicht doch ein Nachteil ist und Schwarz schon in der Grundstellung einen entscheidenden Vorteil hat. Über diesen Punkt lässt sich wirklich vortrefflich streiten und diskutieren, dabei kann man auch sehr leicht in philosophische Diskussionen abdriften. Das Problem ist nämlich, dass die Anzahl der möglichen Stellungen beim Schachspiel größer ist, also die Anzahl der Atome im bekannten Universum. Mit heutigem Wissen ist es also nicht möglich, alle Stellungen zu speichern. Auf die Frage, wie man alle Stellungen überhaupt bewerten kann, muss man also bei dieser Argumentationsweise gar nicht erst eingehen.

Sinnvolle Ansatzpunkte für eine Diskussion wären nun natürlich die Fragen, ob man die Anzahl der Atome im Universum überhaupt kennt, wie man alle Schachstellungen vielleicht effizienter codieren kann und ob es vermessen ist, das Universum als ein endliches Gebilde zu betrachten. Schnell landet man dann auch bei "Paralleluniversen" sowie bei "Schwarzen Löchern". Wie sie sehen, bietet dieser Punkt reichlich Diskussionspotenzial, mit dem man leicht über den Rahmen dieses Artikels hinausgehen kann.

Es ist übrigens nichts ungewöhnliches, das ein Spiel gelöst wird, d.h. komplett berechnet worden ist. Dies ist schon vor einiger Zeit bei den im Vergleich zum Schach sehr einfachen Spielen "Vier gewinnt" und "Mühle" passiert. Bei "Vier gewinnt" kann der Anziehende immer den Gewinn erzwingen, "Mühle" ist bei fehlerfreiem Spiel beider Seiten immer Remis.

Bezugsquellen der TableBases

Widmen wir uns nun also der Frage, wie man die heute praktikablen Tablebases bekommen kann. Hier gibt es grundsätzlich zwei Möglichkeiten. Entweder man besorgt sie sich in fertiger Form oder man generiert sie auf seinem Computer. Beides hat seine Tücken. Im Internet gibt es einige Seiten, auf denen die kompletten Tablebases zum Herunterladen für jedermann angeboten werden, man wählt sich also in den entsprechenden Rechner ein und los geht es! Doch halt, machen wir einmal ein kleines Rechenbeispiel. Wie lange würde dies denn eigentlich dauern? 6 GB für alle Fünfsteiner mit einem heute handelsüblichen V.90 Modem, das macht bei guter Leitung im optimalen Fall 6 GB bei 3500 KB/s = 1840700 Sekunden = ca. 30678 Minuten = ca. 551 Stunden = ca. 21 Tage = 3 Wochen, nonstop! Über verstopfte Leitungen und abgebrochene Verbindungen will ich hier erst gar nicht reden. Jeder kann sich nun selber ausrechnen, wie sich diese Möglichkeit auf seine nächste und wahrscheinlich auch noch übernächste Telefonrechnung auswirken wird. Sie sehen, dies ist also nicht sehr empfehlenswert.

Genau diese Berechnungen habe ich im Frühjahr des Jahres 99 auch angestellt, als ich mich entschlossen habe, Shredder bei der WM in Paderborn mit Unterstützung von Endspieldatenbanken antreten zu lassen. Was also tun? Schnell fand ich ein kleines Programm im Internet, mit dessen Hilfe man alle Tablebases auf seinem eigenen Rechner generieren kann. Es fand sich zwar ein kleiner Hinweis in der beigefügten Dokumentation, dass man für die Fünfsteiner sehr viel Speicher und auch sehr viel Zeit brauchen würde, doch dachte ich mir, dass mein Rechner, ein PII-450 mit 128 MB RAM schon schnell genug sein wird.

Guter Dinge machte ich mich zunächst an die Generierung der Dreisteiner. Dies ging wirklich sehr, sehr schnell über die Bühne, so dass als nächstes schon die Viersteiner anstanden. Hier dauerte es schon zwei Stunden, bis ich alle Datenbanken komplett hatte, doch nun fingen meine Probleme erst richtig an. Ich begann mit KLL-KS und allen anderen Leichtfigurenendspielen. Für jedes dieser Endspiele dauerte es schon 1-2 Tage, bis es komplett generiert war und so langsam fing ich an, mein Vorhaben in Frage zu stellen.

Neuer Speicher musste her, also kaufte ich einen weiteren 128MB Speicherriegel, zum Glück zu damals noch sehr erschwinglichen Speicherpreisen. Doch auch mit nun 256 MB Speicher kam ich sehr schnell an die Grenzen meines Rechners. Ich konnte zwar einige weitere Endspiele berechnen, doch spätestens bei Endspielen, die mindestens einen Bauern enthielten war dann Schluss. Ich beschloss, nach einem anderen Weg zu suchen, die Tablebases zu bekommen und tröstete mich damit, dass ich mit meinem neu erworbenen Speicher in Shredder nun viel größere Hashtabellen einstellen konnte.

Es blieb nur die Möglichkeit übrig, die Tablebases irgendwo fertig generiert zu kaufen. In Deutschland wurde ich leider nicht fündig, offiziell waren sie damals nirgendwo erhältlich. Ich fand jedoch einen computerschachbegeisterten Amerikaner, der sich doch tatsächlich alle Fünfsteiner mit seinem normalen Modem aus dem Internet geladen hatte. Nach eigenen Angaben hat er dafür 1,5 Monate im Dauerbetrieb benötigt, dies ist wahrscheinlich wirklich nur in Amerika möglich. Wir wurden uns schnell einig und er versprach, mir die CDs so schnell wie möglich zu brennen und zuzuschicken. Es dauerte dann wirklich auch nur ein paar Tage, bis ich das Paket im Briefkasten hatte.

Wunderwaffe TableBases

Nach all den Mühen war ich natürlich sehr gespannt, was die neue Wunderwaffe bei Shredder bringen würde. Ich probierte ein paar Endspielstellungen mit wenig Figuren und, siehe da, die richtigen Lösungen wurden von Shredder mit Tablebases meistens deutlich früher gefunden. Schnell startete ich ein paar Testspiele, und auch hier zeigten sich zum Teil deutliche Verbesserungen. Unter anderem wurden Turmendspiele mit einem Mehrbauern meistens gewonnen und mit einem Bauern weniger meistens noch ins Remis gerettet. Ich war begeistert. Schnell wurde mir allerdings auch der Nachteil der Tablebases bewusst. Wegen ihrer Größe ist es nicht möglich, sie vollständig in den schnellen Arbeitsspeicher des Computers zu laden. Sie müssen auf der relativ langsamen Festplatte bleiben. Ein sehr wichtiger Faktor im Computerschach ist aber die Geschwindigkeit und Effizienz eines Programms. In Endspielen, vor allem mit wenig verbleibenden Figuren, kommt es aber sehr häufig vor, dass man im Suchbaum, zum Beispiel nach einer langen Abtauschfolge, auf eine Stellung mit fünf oder weniger Figuren trifft, die es zu bewerten gilt.

Wenn man dann jedes Mal auf die langsame Festplatte zugreift, wird das Programm ausgebremst und verliert sehr deutlich an Rechengeschwindigkeit, was dann fatale Folgen haben kann. Im schlimmsten Fall wird nur noch permanent auf die Festplatte zugegriffen und es bleibt keine Zeit, die wichtigen Varianten tief genug zu untersuchen. Auch dieses Problem kann man allerdings durch intelligente Algorithmen in den Griff bekommen, so dass am Ende die Vorteile der Endspieldatenbanken bei weitem überwiegen.

Heute ist es übrigens deutlich einfacher, an die begehrten Tablebases zu kommen. Alle Viersteiner werden unter anderem mit Shredder ausgeliefert und auch für die Fünfsteiner gibt es inzwischen auch in Deutschland einige Bezugsquellen. Dies ist sicher mit Abstand die beste Möglichkeit, die Tablebases zu bekommen. Sie werden sich vielleicht fragen, warum die Tablebases erst so spät aufgetaucht sind, wenn sie doch so nützlich sind. Ein Grund ist sicher, dass die Festplattengrößen erst in letzter Zeit auf ein Maß gewachsen sind, bei dem es Sinn macht, sie einzusetzen. Auf der anderen Seite muss man auch sagen, dass Endspieldatenbanken schon ein alter Hut sind und es sie schon sehr lange gibt.

Die bisherigen Formate waren allerdings entweder so, dass man schnell auf die Datenbanken zugreifen konnte, sie aber sehr viel Platz auf der Festplatte benötigen (Edwards-Datenbanken), oder aber sie waren sehr gut komprimiert und der Zugriff dauerte dann sehr lange, so dass man sie nicht effizient in der Suche einsetzten konnte (Thompson-Datenbanken). Erst mit den neuen Nalimov-Datenbanken ist ein sehr guter großer Schritt getan worden. Sie werden durch einen sehr intelligenten und effizienten Komprimierungsalgorithmus auf eine erträgliche Größe gebracht und lassen auch noch einen sehr schnellen Zugriff zu.

Abschließend möchte ich noch zwei Beispiele aus der Praxis von der WM in Paderborn aufzeigen, bei denen der Vorteil und die Stärke der Endspieldatenbanken klar zum Vorschein gekommen ist. In der ersten Partie wird deutlich, dass auch schwer zu spielende Endspiele, die noch einige Remismöglichkeiten bieten, ohne Probleme gewonnen werden, wenn man die Hilfe von Endspieldatenbanken in Anspruch nehmen kann.

Shredder - Rebel

WCCC99 Paderborn (3), 15.06.1999

1.d4 d5 2.c4 c6 3.Sf3 Sf6 4.Dc2 dxc4 5.Dxc4 Lf5 6.g3 e6 7.Lg2 Sbd7 8.Sc3 Le7 9.0-0 0-0 10.Te1 Se4 11.e3 Te8 12.Sd2 Sd6 13.De2 e5 14.d5 cxd5 15.Sxd5 Tc8 16.e4 Le6 17.Sxe7+ Dxe7 18.b3 Tc2 19.La3 Tec8 20.Tec1 Txc1+ 21.Txc1 Txc1+ 22.Lxc1 Dd8 23.La3 Db6 24.Lf1 Sc5 25.Lb2 f6 26.De3 Scxe4 27.Sxe4 Dxe3 28.Sxf6+ gxf6 29.fxe3 Se4 30.Le2 Kf7 31.Ld3 Ld5 32.g4 Kg6 33.h4 f5 34.Le2 Kf6 35.g5+ Ke6 36.Kh2 a5 37.Kg1 a4 38.bxa4 Lxa2 39.a5 Ld5 40.La3 Sc3 41.Lh5 Lc6 42.g6 hxg6 43.Lxg6 Sd5 44.h5 Kf6 45.Lc5 Sc3 46.Kf1 Lf3 47.Lb6 Lg4 48.Ld8+ Kg7 49.Lc7 Kf6 50.Kg2 Sd5 51.Ld8+ Kg7 52.Kg3 Sxe3 53.Kh4 Sd5 54.Kg5 Lh3 55.h6+ Kg8 56.Le8 Sf4 57.Ld7 Lg4 58.Lc8 Kh7 59.Lc7 Sh3+ 60.Kf6 Sf2 61.Lxb7 Se4+ 62.Kxe5 Le2 63.a6 Lxa6

8/1BB4k/b6P/4Kp2/4n3/8/8/8 w - -

Mit seinem nächsten Zug kündigt Shredder ein Matt in 31 Zügen an! Ohne Hilfe der Endspieldatenbanken wäre dies natürlich völlig unmöglich. Es entsteht ein Endspiel KLL-KS, das u.U. nur schwer innerhalb von 50 Zügen zu gewinnen ist. Mit Hilfe der Datenbanken jedoch kein Problem für Shredder, bereits hier wird der Weg bis zum Matt komplett angezeigt. 64.Lxa6 Kg6 65.h7 Kxh7 66.Kxf5 Sc5 67.Lc4 Sd7 68.Lb5 Sc5 69.Lb6 1-0

Die zweite Partie ist ein sehr schönes Beispiel dafür, dass Schachprogramme mit Hilfe von Endspieldatenbanken selbst Großmeistern in einigen Endspielstellungen deutlich überlegen sein können, obwohl das Endspiel sicher noch die Achillesferse der heutigen Schachprogramme ist.

Ferret - Shredder

WCCC99 Paderborn, 18.06.1999

1.e4 e5 2.Sf3 Sc6 3.Lc4 Lc5 4.b4 Lxb4 5.c3 La5 6.d4 exd4 7.0-0 Sge7 8.cxd4 d5 9.exd5 Sxd5 10.La3 Le6 11.Lb5 Lb4 12.Lxc6+ bxc6 13.Lxb4 Sxb4 14.Da4 Dd6 15.Sc3 Sd3 16.d5 Sc5 17.Dxc6+ Dxc6 18.dxc6 Ke7 19.Tfe1 Sd3 20.Te3 Sb4 21.Sd4 Thd8 22.Td1 Kf6 23.a3 Sd5 24.Se4+ Ke7 25.Tee1 Lg4 26.f3 Lc8 27.Sc5+ Kf6 28.Sb5 Le6 29.Sa6 Tac8 30.Sbxc7 h5 31.h3 h4 32.a4 Sxc7 33.Txd8 Txd8 34.Sxc7 Tc8 35.Sxe6 fxe6 36.Tc1 e5 37.Kf2 Ke6 38.g3 hxg3+ 39.Kxg3 Kd6 40.Td1+ Ke6 41.Td7 Txc6 42.Txg7 Tc3 43.Tg4 Kf5 44.h4 Tc1 45.h5 Tc6 46.Tg7 Ta6 47.Tg4 Tc6 48.Tg7 Ta6 49.Tg8 Tb6 50.Kh4 Tb4+ 51.Kg3 Tb6 52.Kh4 Tb4+ 53.Tg4 Tb2 54.Kg3 Tb6 55.a5Td6 56.Tg7 Ta6 57.Tg8 Td6 58.Kh4 Td4+ 59.Kg3 Td6 60.Tb8 Kg5 61.Te8 Td5 62.a6 Ta5 63.Te7 e4 64.Txa7 Ta3 65.Kf2 Txf3+ 66.Ke2 Kxh5

8/R7/P7/7k/4p3/5r2/4K3/8 w - -

In dieser Stellung gegeben die beiden anwesenden GM Boris Altermann und Thomas Luther dem Schwarzen keine Chance mehr. Für beide ist klar, dass Weiß dieses Endspiel leicht gewinnen kann. Beide Programme verfügen aber über die Tablebases und beide zeigen seelenruhig hier und im folgenden eine Remisbewertung an, völlig zu Recht, wie sich in der Analyse dann gezeigt hat. 67.Ta8 Tf7 68.Ke3 Te7 69.Tb8 Kg6 70.Tb6+ Kf5 und ½-½

Fazit

Was kann man nun als Fazit über die Tablebases sagen? Wenn man die wenigen Klippen bei der Implementierung umschifft, dann hat man ein sehr mächtiges Hilfsmittel zu Hand, um das Endspielverhalten eines Schachprogramms in einigen Stellungen deutlich zu verbessern. Dies haben die meisten Programmierer von Schachprogrammen nun auch erkannt. Viele Programme, natürlich auch Shredder, unterstützen nun das Tablebases-Format.

Stefan Meyer-Kahlen


Bauerneinheit

Bauerneinheiten

Eine Bauerneinheit dient einem Schachprogramm als Masseinheit zur Einschätzung und Bewertung einer Stellung.

Es existiert eine Faustregel, wonach man den Tauschwert von Figuren in Bauerneinheiten festlegt:

  • Dame 9 Bauerneinheiten

  • Turm 5 Bauerneinheiten

  • Läufer 3 Bauerneinheiten

  • Springer 3 Bauerneinheiten

  • Bauer 1 Bauerneinheit

Positionelle Kriterien werden in Form von Bruchteilen einer Bauerneinheit angegeben.


Datenbanken/Formate

Datenbanken

Um sinnvoll mit dem Programm arbeiten zu können, muss es die Möglichkeit geben, Partien und Schachpositionen in einer einzigen Datei kompakt abzuspeichern. Für die Verwaltung dieser Daten setzt Shredder auf die bekanntesten Dateiformate im Computerschach auf. Damit haben Sie die Möglichkeit, die Daten effizient zu verwalten und mit anderen Schachanwendungen auszutauschen.

Folgende Standards werden unterstützt:

CBF-Format

Shredder unterstützt Datenbanken im CBF-Format. Es stammt ursprünglich vom Programm ChessBase und wird mittlerweile von einer Reihe von Schachprogrammen genutzt. In CBF-Dateien können auch Varianten enthalten sein. Shredder kann in einer Notation neben Text auch Varianten speichern, die beim Nachspielen einer Partie angezeigt werden. In einer CBF-Datenbank befinden sich in der Regel eine ganze Reihe von Partien. Zu jeder Partie wird neben der Notation noch eine Vielzahl weiterer Informationen gespeichert. Neben den Partiezügen können Sie die Spielernamen, Jahr, Resultat, Eröffnungscode, Kommentare und Varianten in einer CBF-Datenbank speichern. Ein grosser Vorzug des CBF-Formates besteht darin, daß die Daten sehr komprimiert gespeichert werden und der Zugriff der Suchfunktionen sehr schnell vonstatten geht. Nach Möglichkeit sollten Sie Partien und Stellungen im CBF-Format abspeichern.

PGN-Format

Das PGN-Format hat sich als Standard zur Speicherung von Schachpartien insbesondere im Internet durchgesetzt. Im Unterschied zum CBF-Format basiert PGN auf dem Ascii-Format und belegt bei gleichem Inhalt deutlich mehr Platz auf der Festplatte. Da die Daten im reinen Textformat gespeichert werden, kann man die Notationen mit jeder beliebigen Textverarbeitung weiterverarbeiten. Genau wie das CBF-Format speichert das PGN-Format neben Notationen auch Informationen wie die Spielernamen, Jahr, Ergebnis, Eröffnungscode, Kommentare und Varianten.

EPD

Datenbanken sind wie PGN reine Ascii-Dateien und dienen ausschliesslich zur Speicherung von Positionen. Die im Rahmen des EPD-Standards zulässigen Kommentare werden von Shredder unterstützt.


EPD-Format

Das EPD-Dateiformat

Ein gravierendes Problem aus den Anfängen des Computerschachs: jedes Schachprogramm kam mit einem hauseigenen Datenformat, das zu anderen Programmen so gut wie nie kompatibel war. Es fehlte einfach ein Standard zur Speicherung von Partien und Positionen. Mittlerweile hat sich die Situation grundlegend geändert. Es gibt zwar immer noch diverse unterschiedliche Datenformate, aber deren Anzahl ist überschaubar geworden. Viele Anwender werden häufig mit dem Datenformat CBF zu tun haben, das sich mittlerweile als ein Quasistandard etabliert hat, denn es wird von einer Vielzahl von Schachprogrammen -- darunter auch Shredder -- unterstützt.

Ein grundsätzliches Problem für die Schachprogrammierer ist aber, dass die Datenformate und die Struktur der internen Datenformate von kommerzieller Schachsoftware, z.B. das CBF-Format, in der Regel nicht dokumentiert oder frei zugänglich sind. Aus diesen Überlegungen heraus haben sich im Computerschach Datenformate entwickelt, die auf einem reinem Ascii-Text basieren und mit deren Hilfe man sowohl Schachpartien als auch Schachstellungen abspeichern kann.

Standard zur Speicherung von kompletten Partien (Notationen) ist das PGN-Format. Innerhalb von PGN-Dateien, die mit jedem beliebigen Texteditor gelesen und auch bearbeitet werden können, kann man nicht nur eine singuläre Partie, sondern mehrere Partien oder Positionen übersichtlich in einer Datei abspeichern.

Im Gegensatz zu PGN ist vielen Anwendern das EPD-Format, das ebenfalls auf Ascii (reinem Text) basiert und zur Speicherung von Schachpositionen sehr gut geeignet ist. weniger geläufig. Neben einer relativ problemlosen Anbindung dieser (gut dokumentierten!) Formate an ein Schachprogramm, bieten sowohl PGN als auch EPD gerade im Zeitalter des Internets einige Vorzüge.

Aufbau eines EPD-Strings

Betrachten wir uns zunächst einmal einen Eintrag aus einer EPD-Datei, die durchaus auch mehrere dieser Einträge (Strings) enthalten kann:

rn1qr1k1/1p2bppp/p3p3/3pP3/P2P1B2/2RB1Q1P/1P3PP1/R5K1 w - - bm bxh7;

Das sieht zunächst einmal für den Anwender recht kryptisch aus, ein Schachprogramm mit Schnittstelle zum EPD-Format interpretiert diese Textzeile als die nebenstehende Schachstellung.

Markieren Sie den oben abgebildeten Textstring mit der Maus und kopieren Sie ihn mit der Tastenkombination STRG-C in die Zwischenablage von Windows. Wechseln Sie nun zu Shredder und betätigen die Tastenkombination STRG-V.

Die Brettstellung wird jetzt übernommen und Sie können mit Shredder die Position analysieren oder dauerhaft abspeichern.

Aufbau eines EPD-Strings

Zum besseren Verständnis folgende Hinweise:

1. Jede Stellungsdefinition innerhalb einer EPD-Datei steht in einer eigenen Zeile.

2. Das Schachbrett wird von links oben nach rechts unten dargestellt.

3. Die Reihen des Brettes werden immer durch einen Schrägstrich getrennt.

4. Grundsätzlich werden die englischen Figurenbezeichnungen (KQRBNP) benutzt.

5. Die weißen Figuren werden durch große Buchstaben, die schwarzen Steine durch kleine Buchstaben auf dem Brett repräsentiert.

6. Leere Felder, bzw. die Anzahl der leeren Felder wird innerhalb von EPD mit einer Zahl gekennzeichnet.

7. Nachdem die Brettposition definiert wurde, kommt ein Leerzeichen und dann noch die Kennung für das Zugrecht der jeweiligen Stellung. "W" steht für Weiß am Zug, "B" für Schwarz. Jetzt müssen noch die Rochaderechte definiert werden.

8. "K" steht für die kurze weiße Rochade, "Q" für die lange weiße Rochade während für die Festlegung der schwarzen Rochaderechte mit den gleichen Buchstaben erfolgt, nur werden diese zur Unterscheidung kleingeschrieben.

Als Anwender sollten Sie sich merken, dass EPD reine Textdateien sind, die Stellungsbeschreibungen (Positionen) enthalten. Mehr brauchen wir für einen sinnvollen Einsatz des EPD-Formates (vor)erst einmal nicht zu wissen.

Anwendung von EPD

Was kann man nun mit dem EPD-Format anfangen? Falls Sie sich häufig im Internet tummeln und dort Schachforen oder schachbezogene Webseiten besuchen, werden Sie z.B. recht häufig mit dem EPD-Format konfrontiert. Verdeutlichen wir das einfach einmal an einem praktischen Beispiel. Nehmen wir an, Sie finden in einer E-Mail oder in einem Schachforum ein Schachdiagramm und eine Eingabezeile im EPD-Format, die exakt die Stellungsbeschreibung des abgebildeten Schachdiagramms enthält:

r1br2k1/ppp2q1p/nb3p2/6p1/2PN1B2/2P2B2/P1Q2PPP/3RR1K1 w - g6 bm nc6!;

Wie können Sie diesen EPD-String jetzt zur Analyse mit anderen Programmen einsetzen? Die Lösung ist einfach: markieren Sie die Asciibeschreibung mit der Maus und übernehmen diese mit der Tastenkombination Strg-C in die Zwischenablage. Wie können wir diese Information jetzt mit anderen Schachprogrammen nutzen? Dazu gibt es je nach Programm mehrere Möglichkeiten, zuerst einmal zwei elementare Funktionen:

1.) Starten Sie einen beliebigen Texteditor, z.B. das im Lieferumfang von Windows enthaltene Notepad. Wählen Sie dort aus dem Menü BEARBEITEN den Befehl EINFÜGEN. Schwupps und schon haben Sie den EPD-String in die Textverarbeitung übernommen. Speichern Sie jetzt den EPD-String auf der Festplatte. Achten Sie darauf, dass Sie bei der Vergabe des Suffix (Dateiendung) die Bezeichnung *.EPD eingeben. Diese EPD-Datei kann jetzt von jedem Schachprogramm gelesen werden, das mit diesem Format umgehen kann!

2.) Eine weitere Möglichkeit bietet die Zwischenablage mit der Möglichkeit, Daten direkt ohne Umweg über eine Dateispeicherung auszutauschen. Etliche Schachprogramme unterstützen diesen Windows-Standard und man kann rasch die Daten übernehmen. Dieses Verfahren und andere Optionen der wichtigen Schachprogramme werden wir noch im weiteren Text präziser vorstellen.

Falls Sie nicht wissen, was die Zwischenablage ist und wie man diese effektiv einsetzt, einige Ausführungen dazu. Eine elementare Funktion unter Windows ist das wechselseitige Verfahren Kopieren <-> Einfügen. Standard sind unter Windows die Tastenkombinationen Strg-C (Kopieren) und Strg-V (Einfügen). Mit der Tastenkombination Strg-C kopieren Sie ein markiertes Objekt - dies kann Text, Grafik oder eben auch unser EPD-String sein - in einen reservierten Bereich im Arbeitsspeicher, die Zwischenablage. Mit der Tastenkombination Strg-V fügen Sie das zuvor kopierte Objekt aus der Zwischenablage in eine beliebige Anwendung ein. Diese Technik wird von allen guten Windows-Programmen, z.B. Textverarbeitungen, Grafikprogrammen und einigen Schachprogrammen, unterstützt.

Innerhalb des EPD-Formates gibt es sogar noch die Möglichkeit, Kommentare einzufügen. Betrachten wir uns den EPD-String vom letzten Beispiel, insbesondere den letzten Eintrag, etwas genauer. Dort steht am Ende der Zeile "bm nc6". Das Kürzel "bm" steht für best move und gibt damit den richtigen (oder vermeintlich richtigen) Lösungszug in der angegebenen Position an. "N" steht in englischer Kurznotation für Springer, der optimale Zug in der oben angegebenen Stellung ist also Sc6! Shredder berücksichtigt beim automatischen Analysieren eines oder mehrerer EPD-Strings diesen Kommentar und gibt im Logfile direkt an, ob die im Kommentar angegebene Lösung gefunden wurde oder nicht!


Dateistruktur TableBases

Aufbau einer Endspieldatei

Es gibt für jeden Endspieltyp zwei Dateien, in denen das Zugrecht festgelegt wird; eine für Weiß und eine für Schwarz am Zug.

Anhand des Dateinamens kann man sofort erkennen, welches Endspiel in den Dateien enthalten ist.

Beispiel: KQRK.NBB enthält das Endspiel König+Dame gegen König+Turm. Die Kürzel, z.B. Q(Queen) stehen für die Figurenbezeichnung aus dem Englischen. Die Erweiterung des Dateinamens NBB bedeutet konkret N=Neu, B=Base, B=Schwarz (black) am Zug; .NBW steht also für N=Neu, B=Base, W=Weiß (white) am Zug.

Der Dateiname enthält eine zweite Erweiterung mit der Bezeichnung *.EMD, die für die komprimierten TableBases steht. Im Prinzip braucht sich der Anwender darum nicht zu kümmern, da die entsprechenden Programme automatisch auf die TableBases zugreifen.

Während nun die Drei- und Viersteiner sich noch in erträglichen Größenordnungen bewegen, steigt der Speicherbedarf für Endspiele mit Fünfsteinern überproportional an. Will man z.B. alle verfügbaren Fünfsteiner im Nalimov-Format auf die Platte kopieren, fallen dafür um die 6 GB an.

Shredder unterstützt übrigens auch die neuen Sechssteiner !


Das Permanent Brain

Permanent Brain

Permanent Brain ist die Fähigkeit eines Schachprogramms, während der Bedenkzeit des Gegners weiterzurechnen. Alle wichtigen Schachprogramme nutzen diese Technik, natürlich auch Shredder.

Das Programm rechnet während der Bedenkzeit des gegners im Verborgenen weiter. Meist geht das Programm davon aus, daß der Gegner den erwarteten Zug ausspielen wird und kann in solchen Fällen sehr rasch antworten. Dies spart bei einer hohen Trefferquote viel Bedenkzeit.

Das Permanent Brain ist unter anderem dafür verantwortlich, daß Shredder bei längeren Bedenkzeiten oft verzögerungsfrei auf einen Zug des Gegners antwortet.

Falls Sie gerne Stellungstests oder Lösungsvergleiche mit Shredder absolvieren, sollten Sie das Permanent Brain unbedingt abschalten.

Ansonsten kann es passieren, daß Shredder auf bereits berechneten Werte in den HashTables zugreift. Dies erschwert konkrete Vergleiche von ermittelten Lösungszeiten ganz erheblich.


Der Positionsbaum

Eröffnungsbäume

von Stefan Meyer-Kahlen

Was ist ein Eröffnungsbaum ?

Jedes aktuelle Programm wirbt heutzutage damit, daß es einen sogenannten "Eröffnungsbaum" besitzt, mit dem der Benutzer Zugriff auf die gesamte Eröffnungstheorie hat. Doch was ist denn nun eigentlich ein Eröffnungsbaum?

Ein Eröffnungsbaum ist eine große Datenbank von Schachstellungen und Zügen, mit deren Hilfe man für eine bestimmte Schachstellung herausfinden kann, welche Züge in dieser Stellung schon gespielt worden sind. Ein Computer benötigt dieses Wissen, damit er in der Eröffnungsphase schnell einen Zug ausspielen kann, ohne seine internen Schachalgorithmen zu verwenden. Dadurch kann er Bedenkzeit einsparen und strategische Fehler in der Eröffnung vermeiden. Bisher ist das noch nichts Neues, doch werden in dieser Datenbank zusammen mit den einzelnen Zügen noch weitere Informationen gespeichert.

Man kann zum Beispiel für jeden Zug herausfinden, wie oft er schon gespielt worden ist und wie seine Erfolgsquote lautet, d.h. wie oft Weiß oder Schwarz mit diesem Zug gewonnen oder verloren hat und wie oft die Partie unentschieden ausging. Weiter kann man auch ablesen, welchen Elodurchschnitt beide Seiten hatten sowie neuerdings auch, in welchem Jahr der Zug besonders häufig gespielt worden ist.

Damit kann man sehr gut zwischen klassischen und modernen Varianten unterscheiden. Mit diesen Informationen kann man leicht die Eloleistung für jeden Zug ausrechnen. Es macht z.B. einen Unterscheid, ob man 60% gegen gleichwertige Gegner oder aber 80% gegen schwächere Gegner erreicht. Zur Verdeutlichung möchte ich kurz ein Beispiel für einen Ausschnitt eines Eröffnungsbaums für die Grundstellung angeben:

Partien Quote Elo Leistung

1.e4 65432 55,4% 2427 2450

1.d4 40212 53,4% 2453 2469

1.c4 8011 51,3% 2432 2463

Man sieht, dass 1.e4 am meisten gespielt worden ist (65432 mal) und auch die höchste Erfolgsquote (55.4%) hat. Mit 1.d4 wurde jedoch die höhere Eloleistung erreicht (2469 Elo) und es wurde auch von stärkeren Spielern gespielt (Elodurchschnitt 2453). 1.c4 wird seltener gespielt, die Erfolgsquote ist vergleichbar, wenn auch etwas niedriger.

Vorzüge des Positionsbaums

Wie sie sehen, bietet dieses Konzept eine Fülle von sehr nützlichen Informationen, und damit sind wir bei der entscheidenden Neuerung. Bisher war es nämlich immer nur der Computer oder aber das Programm, welches von dem Wissen in seinem Eröffnungsbuch profitieren konnte, doch nun hat auch der menschliche Benutzer ein sehr mächtiges und nützliches Informationssystem zur Hand.

Er kann sich nun sehr gezielt in einer bestimmen Eröffnungsvariante vorbereiten und die bisher in dieser Variante gespielten Züge sehr schnell auf ihre Tauglichkeit untersuchen. Weiterhin sieht er auch sofort, wo die bekannte Theorie zu Ende ist und muss dazu nicht erst diverse Schachbücher oder elektronische Partiedatenbanken durchstöbern.

Auch die Schachprogramme haben allerdings einen deutlichen Mehrwert. Sie nutzen natürlich die gespeicherten Informationen für Ihre Zugauswahl in der Eröffnung aus. Wenn es zum Beispiel in einer gegebenen Stellung zwei Züge zur Auswahl gibt, von denen der eine dreimal gespielt worden ist und mit dem die Partie auch dreimal den Bach runter ging, der andere jedoch nach 100 Partien eine Quote von 60% hat, sollte die Zugwahl des Programms klar sein. Dies ist aber noch lange nicht alles. Es ist nun auch viel besser möglich, das Ausspielverhalten in der Eröffnung zu beeinflussen. Durch eine Vielzahl von Einstellmöglichkeiten kann man fast stufenlos bestimmen, ob das Programm nur die besten Züge spielen soll oder aber abwechslungsreicher auch einmal potenziell schlechtere Züge wählen soll. Weiterhin kann man auch nur die Hauptvarianten spielen lassen oder aber sich auf die Nebenvarianten beschränken.

Nachteile des Konzepts

Nach der Beschreibung all dieser Vorteile werden sie sich sicher fragen, ob es denn nun auch Nachteile dieser Methode gibt. Wie erwartet sind natürlich auch diese vorhanden. Zunächst muss man beachten, dass die Datenbanken viel größer werden, als man es bisher gewohnt war. Dies liegt natürlich daran, dass man nicht nur die Züge, sondern auch die diversen Zusatzinformationen wie die Anzahl der gespielten Partien usw. speichern muss. Meiner Meinung nach ist dieser Punkt allerdings nicht sehr tragisch. Die Datenbanken werden bei weitem nicht so groß wie bei den im letzten Monat von mir besprochenen Endspieldatenbanken, mit 100 MB bekommt man schon ein ziemlich umfangreiches Eröffnungswissen.

Weiterhin erfolgt der Zugriff auch nicht sehr häufig: in der Regel nur einmal pro gespieltem Zug, so dass es auch keine großen Nachteile hat, dass man das Buch nicht in den schnellen Arbeitsspeicher des Rechners laden kann. Es ist durchaus möglich und bei begrenztem freien Festplattenspeicher auch sinnvoll, den Eröffnungsbaum auf CD-ROM zu belassen und von dort aus darauf zuzugreifen. Mit den weiter sehr schnell rapide fallenden Preisen für Festplatten sollte dies allerdings schon sehr bald nie mehr nötig sein.

Es gibt allerdings auch noch einen weiteren, nicht so offensichtlichen Nachteil. Dazu möchte ich noch einmal das obige Beispiel aufgreifen: Ein Zug wurde 100 mal in einer bestimmen Stellung mir einer Erfolgsquote von 60% gespielt. Ist dieser Zug nun gut, d.h. kann man ihn bedenkenlos spielen? Auf den ersten Blick sicher ja, doch wenn man sich vergegenwärtigt, dass die Schachtheorie nicht statisch ist, sondern sich immer dynamisch weiter entwickelt und verändert kommt man schnell auf den Haken: Was ist, wenn von den 100 Partien die letzten 10 Partien alle verloren worden sind? Es ist sicher möglich und in diesem Fall wohl auch wahrscheinlich, dass es in dieser Variante ein neue Widerlegung gibt, so dass der besagte Zug nicht mehr spielbar ist. Wenn man sich nur die gesamte Erfolgsquote von 60% ansieht kann man diesen Fall sicher nicht aufdecken. Doch wie fast immer gibt es auch für dieses Problem eine Lösung. Ich habe in meinem Programm Shredder einen Algorithmus implementiert, der genau dieses erkennt und Züge, für die es eine vermeintliche Widerlegung gibt, nicht mehr so hoch gewichtet. Nach meinen Tests funktioniert dieses Verfahren sehr gut.

Positionsbaum erweitern

Einen wichtigen Punkt habe ich bisher noch nicht angesprochen: Woher kommen die Daten in einem Eröffnungsbuch überhaupt? Nach dem bisher gesagten ist klar, dass es zu jedem Eröffnungsbaum immer eine Partiendatenbank geben muss, aus deren Datenbestand der Baum generiert worden ist. Weiterhin sollte auch sofort einleuchten, dass die Qualität des Eröffnungsbaums unmittelbar von der Qualität der verwendeten Partien abhängt. Für einen starken Schachspieler macht es z.B. nicht sehr viel Sinn, sich mit einem Eröffnungsbaum und den darin enthaltenen Informationen zu befassen, der aus den Partien der Bezirksliga "Grötenbach" entstanden ist. Es ist heutzutage allerdings kein Problem mehr, sich Datenbanken mit hochkarätigen und aktuellen Partien zu besorgen, so dass es leicht möglich ist, qualitativ erstklassige Eröffnungsbäume zu erstellen. Wenn man davon spricht, Zugriff auf die gesamte Eröffnungstheorie haben zu wollen, dann müssen die verwendeten Partiedatenbanken natürlich auch entsprechend umfangreich sein. Es ist aber sicher möglich, einen Baum zu generieren, der wirklich alle jemals gespielten oder zumindest veröffentlichten Partien enthält und von dem man dann wohl auch zu Recht sagen kann, dass er das gesamte Eröffnungswissen beinhaltet.

Ein Eröffnungsbaum veraltet auch nie, denn es ist möglich, den Datenbestand durch das Hinzufügen von neu gespielten Partien zu erweitern. Die jeweiligen Statistikinformationen werden dabei dann auch automatisch aktualisiert, so dass man mit den angezeigten Informationen immer auf dem neuesten Stand sein kann. Man muss dabei nur aufpassen, dass man keine Partie doppelt in den Baum einliest, denn dann stimmen die Statistiken nicht mehr.

Wenn man nämlich seine Lieblingspartie gleich 1000 mal importiert, dann hat die dort gespielte Varianten auf einmal eine traumhaft Erfolgsquote. Es wäre zwar technisch durchaus möglich, dieses mehrfache Importieren von derselben Partie zu verhindern bzw. es zu erkennen, doch dies wäre dann wirklich sehr aufwendig und man benötigte auch sehr viel mehr Speicherplatz dafür. Man kann zum Beispiel auch Bäume generieren, die alle Partien eines bestimmten Spielers, z.B. Karpov enthalten. Damit kann man dann sehr gut das Eröffnungsrepertoire dieses Spielers untersuchen und persönliche Stärken und Schwächen dieses Spielers ans Tageslicht bringen. Wenn man ein Schachprogramm mit diesem Baum als Eröffnungsbuch spielen lässt, dann simuliert es im Prinzip Karpov oder auch jeden anderen Spieler, zumindest in der Eröffnungsphase. Man hat also immer die Möglichkeit, gegen jeden Spieler der Welt anzutreten, genauer gesagt gegen dessen Eröffnungsrepertoire. Wenn man von seinem nächsten Gegner genug Partien in seinen Datenbanken findet kann man dies alles natürlich auch für eine hervorragende Vorbereitung auf diese Partie verwenden.

Fazit

Ein Vergleich zu früheren Zeiten, als das Eröffnungsbuch eines Schachprogramms händisch durch manuelles Eintippen der Züge erstellt worden ist, und zum Konzept des Positionsbaums, der blitzschnell mit neuem Datenmaterial erweitert werden kann, demonstriert nachhaltig den Vorteil dieses Konzeptes. Man darf allerdings nicht vergessen, dass sich die gesamten Statistiken in einem Eröffnungsbaum immer oder fast immer nur auf Partien zwischen zwei menschlichen Spielern beziehen. Ein Zug, der mit einer guten Quote in einem Eröffnungsbaum steht, hat sich also im Spiel Mensch gegen Computer bewährt.

Da ein Zug, der für einen Menschen gut ist, noch lange nicht auch für einen Computer gut sein muss, werden die Buchspezialisten aber wohl in absehbarer Zeit noch nicht arbeitslos werden. Es gibt sehr viele Beispiele, in denen ein Computer wohl besser nicht den Zug spielen sollte, der der beste aus Sicht eines menschlichen Spielers ist. Computer spielen einfach anders Schach als Menschen. Ich verweise hier auch auf die Ausführungen von Peter Schreiner zum Thema Eröffnungsbücher.

Wie sie sehen, hat das Konzept des Eröffnungsbaum deutlich mehr Vorteile als Nachteile, zumal die wenigen Nachteile auch nicht sehr schwer wiegen oder man sie durch geschickte Programmierung fast völlig umgehen kann. Es ist also für jedes Programm und für jeden Benutzer von Vorteil, sich mit Eröffnungsbäumen zu befassen. Die Werbung hat also diesmal Recht, ein wirklich sehr sinnvolles Feature.

Stefan Meyer-Kahlen


ECO-Klassifikation

ECO-Schlüssel sind ein System zur Klassifizierung von Eröffnungen.

Der Name leitet sich von der Enzyklopädie der Schacheröffnungen (engl. Encyclopedia of Chess Openings) ab.

Das ECO-System ist der wichtigste Standard zur Eröffnungsklassifikation.

Jeder Schlüssel besteht aus einem Buchstaben A bis E und einer zweistelligen Zahl von 00 bis 99.

Insgesamt gibt es also 500 Schlüssel von A00 bis E99.

ECO-Schlüssel sind eine wichtige Hilfe, um Partien mit bestimmten Eröffnungen aus einer Datenbank herauszufiltern. Sie haben gegenüber sprachlichen Eröffnungsbezeichnungen ausserdem den Vorteil, daß sie wesentlich präziser und international verständlich sind.

Shredder zeigt den ECO-Schlüssel einer Partie im Notationsfenster an und kann ihn mit der Partie speichern.

Sie können den ECO-Schlüssel einer Partie in der Regel genauer bestimmen, wenn Sie die Partie nachspielen und auf die Anzeige im Notationsfenster achten. Es sind zahlreiche Zugumstellungen möglich. Shredder kennt eine Vielzahl von Stellungen, um Partien zu klassifizieren. Das Programm sollte daher die meisten Partien korrekt zuordnen.


Fischer-Uhr

Eine Erfindung des Exweltmeisters Bobby Fischer.

Der Spieler erhält nach jedem Zug eine Zeitgutschrift.

Extreme Zeitnot soll so verhindert werden.

Shredder unterstützt die Fischer-Uhr .


Was sind Endspieldatenbanken?

Die Endspieldatenbanken enthalten vollständig ausanalysierte Endspiele. Beim Zugriff auf die Datenbanken muss ein Schachprogramm die besten Züge nicht berechnen, sondern kann die Informationen aus der Datenbank abrufen. Zur Zeit sind in den Endspieldatenbanken Drei-, Vier - und Fünfsteiner mit sämtlichen möglichen Stellungen erfasst, bzw. gespeichert. Ein Schachprogramm mit einer Schnittstelle zu den Endspieldatenbanken behandelt also ein Endspiel perfekt, wenn die entsprechende Stellung in der Datenbank inkl. aller Fortsetzungen gespeichert ist.

Im Computerschach gibt es zwei zur Zeit zwei Typen von Endspieldatenbanken:

  • Thompson-Datenbanken von Ken Thompson

  • Nalimov-Endspieldatenbanken von Eugene Nalimov

Thompson-Datenbanken

Die Endspieldatenbanken von Ken Thompson wurden erstmals 1991 veröffentlicht. Durch ein spezielles Komprimierungsverfahren passen die wichtigsten Endspiele auf 4 CD-Roms. Diesen Endspieldatenbanken verdankt die Endspieltheorie wichtige neue Erkenntnisse. So konnte bewiesen werden, daß das Endspiel 2 Läufer gegen Springer grundsätzlich gewonnen ist oder dass in einigen Endspielen wie 2 Läufer gegen Springer oder 2 Springer gegen Bauer mehr als 50 Züge bis zum Gewinn benötigt werden.

Der Zugriff auf die Thompson-Datenbanken verläuft statisch. Die in den Thompson-Datenbanken gespeicherten Informationen werden im Suchprozess des Schachprogramm nur dann genutzt, wenn sich die entsprechende Position auf dem Brett befindet. Shredder unterstützt die Thompson Datenbanken nicht.

Nalimov-Datenbanken

Die Endspieldatenbanken von Eugene Nalimov wurden 1998 veröffentlicht und sind den Thompson-Datenbanken konzeptionell überlegen. In Fachkreisen bezeichnet man die Nalimov-Datenbanken als TableBases, die ebenfalls ein gigantisches Nachschlagewerk darstellen, in dem bestimmte Schachstellungen (Endspiele) gespeichert sind.

Die zur Zeit geläufigen Tablebases enthalten für fast alle wichtigen Vier- und Fünfsteiner alle möglichen Stellungskonstellationen , die nach einem vorgegebenen Schema systhematisiert sind. Für jede mögliche Position innerhalb einer bestimmten Figurenkonstellation ist eine Information über Gewinn, Remis oder Verlust gespeichert. Falls die Stellung konkret gewonnen oder verloren ist, wird zusätzlich noch die maximale Anzahl von Zügen bis zum Matt angegeben. Ein Schachprogramm mit einer Schnittstelle zu den TableBases kann also eine absolute präzise Angabe über die meisten Drei-Vier- + Fünfsteiner machen und wird im Unterschied zu den Thompson-Datenbanken die Werte aus der Endspieldatenbank bereits in der Suche berücksichtigen.


HashTabellen

Was sind eigentlich HashTabellen ?

von Stefan Meyer-Kahlen

Jedes heutige Schachprogramm benutzt Hashtabellen. Jeder der sich mit Computerschach beschäftigt, hat sicher schon einmal davon gehört. Ich bin aber nicht sicher, ob jeder weiß, was es damit eigentlich genau auf sich hat.

Im Grunde sind die Hashtabellen schon wieder ein alter Hut im Computerschach. Schon die legendären Großrechnerprogramme in den Urzeiten des Computerschachs benutzten sie, und auch für die heutigen PC-Programme sind sie eine Selbstverständlichkeit. Ich kann mich allerdings noch gut daran erinnern, wie die Hashtabellen damals bei den kleinen Mikrocomputern mit großem Tamtam eingeführt worden sind. Wie bei jeder Neuerung, die etwas auf sich hält, versprach man sich und vor allem natürlich den Käufern und Anwendern, den großen Durchbruch im Computerschach. Waren sie das nun wirklich?

Die Bedeutung von HashTabellen

Hashtabellen werden nicht nur im Computerschach, sondern auch bei vielen anderen Softwareanwendungen, verwendet. Es handelt sich um ein Standardverfahren der Informatik, über das es unzählige Veröffentlichungen und bekannte Algorithmen gibt, doch wollen wir uns hier auf ihre Anwendung im Computerschach konzentrieren.

Schauen wir uns dazu zunächst einmal an, wie man die Hashtabellen des Computerschachs im deutschen Sprachgebrauch bezeichnet: man spricht von "Zugumstellungstabellen". Dieses konstruierte Wort ist sicher besser dazu geeignet, sich etwas sinnvolles darunter vorzustellen. Es beschreibt den Sinn der Hashtabellen schon recht gut, doch um wirklich verstehen zu können, was es damit auf sich hat, muss ich noch kurz genauer auf die Funktionsweise eines Schachprogramms eingehen.

Jedes heute kommerziell erhältliche Schachprogramm funktioniert nach dem gleichen Prinzip: alle Zugmöglichkeiten werden der Reihe nach ausprobiert, der beste dabei ermittelte Zug wird dann ausgespielt. Natürlich ist dies nicht ganz richtig, da die große Kunst im Computerschach darin besteht, rechtzeitig zu erkennen, welche Zugmöglichkeiten sinnlos sind und deren Untersuchung möglichst schnell abzubrechen, sowie die sinnvollen Varianten genauer und vertieft zu betrachten.

Trotzdem wird auch noch bei den heutigen Spitzenprogramm 99.99% der Zeit damit verbracht, völlig sinnlose Zugfolgen zu untersuchen, denen ein Mensch sofort ansieht, dass sie so nie und nimmer auf das Brett kommen werden. Es ist deshalb sicher nicht völlig falsch vereinfachend anzunehmen, dass wirklich alle Varianten untersucht werden. Wenn man sich kurz darüber Gedanken macht und sich fragt, wie gut die Schachprogramme denn spielen können, wenn sie nicht ein Großteil ihrer Zeit so sinnlos verschwenden würden, dann ist dies sicher eine mehr als berechtigte Schlussfolgerung.

Auf der anderen Seite ist die Stärke der Computer nun einmal deren Rechengeschwindigkeit und es hat sich im Laufe der Jahre gezeigt, dass es besser ist, einen Großteil seiner Zeit mit der Bewertung von sinnlosen Stellungen und Zugfolgen zu verbringen, als von vornherein zu versuchen, nur die sinnvollen Züge zu selektieren. Computer spielen eben anders Schach als Menschen, sie wissen erst dann, dass etwas schlecht ist, wenn sie es selbst ausprobiert haben.

Nun aber zurück zu unserem Thema. Schauen wir uns einmal in der Grundstellung die Zugfolgen

1.Sf3 Sf6 2.Sc3 Sc6

1.Sc3 Sc6 2.Sf3 Sf6

1.Sf3 Sc6 2.Sc3 Sf6 und

1.Sc3 Sf6 2.Sf3 Sc6

an.

Jeder Schachspieler wird schnell feststellen, dass die entstandene Stellung nach den vier obigen Zugfolgen völlig identisch ist. Wie wir aber bereits gelernt haben, sind Schachprogramme nicht annähernd so klug, wie man vermuten könnte, deshalb überrascht es hoffentlich niemanden mehr, wenn ich sage, dass für ein Programm die obigen Zugfolgen erst einmal völlig verschieden sind und sie bei der Abarbeitung aller Zugmöglichkeiten jede dieser Zugfolgen getrennt bewerten. Sie machen also hier das vierfache der eigentlich notwendigen Arbeit!

Diesen äußerst unbefriedigenden Zustand haben Programmieren von Schachprogrammen schon sehr früh entdeckt und sich auch natürlich daran gestört. Sie sannen nach Abhilfe und fanden eine Lösung für dieses Problem mit Hilfe der Hashtabellen. Hashtabellen im Computerschach sind also primär dazu da, solche Zugumstellungen zu erkennen, indem man die bereits untersuchten Stellungen abspeichert, und durch deren nur einfache Abarbeitung Zeit zu sparen. Daher auch der deutsche Name Zugumstellungstabellen.

Die Verwaltung der HashTabellen

Ganz so einfach ist die Sache allerdings nun auch wieder nicht. Es bleiben noch zwei Probleme zu lösen. Der Arbeitsspeicher der heutigen Computer ist schon sehr, sehr groß, allerdings bei weitem nicht groß genug, um alle auftretenden Stellungen abzuspeichern, um sie bei Bedarf wieder abrufen zu können. Außerdem gibt es Hashtabellen ja schon sehr lange, auch als Arbeitsspeicher noch sehr knapp und teuer war. Wie schafft man es also trotzdem, solche Zugumstellungen wie oben zu erkennen?

Das nächste Problem ist dann, wie man sie sehr schnell und effizient erkennen kann, denn wenn dies zu lange dauern würde, dann wäre es doch besser, alle Möglichkeiten getrennt auszuprobieren. Zum Glück gibt es für diese Probleme in der Informatik Standardverfahren, hier eben Hashtabellen. Der Trick ist der, dass man einer Stellung zunächst eine Codezahl zuordnet, mir deren Hilfe man dann sehr schnell erkennen kann, ob diese Stellung später noch einmal auftritt. In meinem Schachprogramm Shredder wird der Grundstellung zu Beispiel die 64-Bit-Zahl 0x7623EEBC5FD42FDA zugeordnet.

Ein Mensch kann damit sicher nicht sehr viel anfangen, doch für einen Computer ist dies alles kein Problem, er kann in Bruchteilen von Sekunden Tausende solcher Zahlen miteinander vergleichen. Auch für das zweite Problem der Effizienz gibt es natürlich eine Lösung, deren ausführliche Beschreibung hier allerdings deutlich zu weit führen würde. Es genügt zu wissen, dass es sehr schnell möglich ist, aus einer gegebenen Stellung eine Zahl wie die obige zu berechnen.

Die Praxis

Wie geht man als Schachprogrammieren nun vor? Nun, für jede Stellung, die man untersucht hat, speichert man den Wert dieser Stellung zusammen mit dem Code dieser Stellung in den Hashtabellen ab. Vor jeder neuen zu untersuchenden Stellung schaut man einfach in den Hashtabellen nach, ob diese Stellung schon einmal bewertet worden ist und wenn ja, dann nimmt man einfach den abgespeichert Wert und ist sofort fertig. Das ist im Prinzip alles, aber leider gibt es immer noch zwei Probleme zu beachten. Wir wissen, dass es mehr Stellungen gibt, als in den Arbeitsspeicher hineinpassen und auch weit mehr Stellungen, als man mit 64-Bit-Zahlen darstellen kann. Was passiert also wenn der zur Verfügung stehende Arbeitsspeicher voll ist oder zwei verschiedene Stellungen auf die gleiche Zahl abgebildet werden? Letzteres passiert zwangsläufig irgendwann einmal, da es ja viel mehr verschieden Stellungen als Codezahlen gibt.

Das erste Problem lässt sich ziemlich leicht lösen. Wenn der Speicher voll ist, dann muss man eben einen Eintrag löschen, um wieder Platz zu schaffen. Dabei geht man natürlich so vor, dass man einen Eintrag löscht, der höchstwahrscheinlich nicht mehr benötigt wird. Wenn man sich dabei allerdings vertut und der eben gelöschte Eintrag später noch einmal benötigt wird, dann muss man ihn erneut berechnen und kann nicht mehr einfach dessen Wert auslesen. Alles kann man eben nicht haben.

Das zweite Problem ist da zunächst schon schwieriger. Wenn man nämlich nur die beiden Codezahlen hat, und diese identisch sind, dann kann man nicht mit hundertprozentiger Sicherheit sagen, ob die beiden zugrundeliegenden Stellungen es auch sind, d.h., man ist nicht wirklich sicher, ob die gerade untersuchte Stellung wirklich vorher schon einmal untersucht worden ist, wenn man die gleiche Codezahl in den Hashtabellen findet.

Wenn zwei verschiedene Stellungen auf die gleiche Codezahl abgebildet werden, dann spricht man von einer Hashkollision. Hashkollisionen hören sich wild an, sie sind es aber eigentlich gar nicht. Wenn man nämlich die Funktion, die einer gegebenen Schachstellung eine Codezahl zuordnet, geschickt wählt, dann können Hashkollisionen schon fast ausgeschossen werden. Allerdings nur fast, denn ein gewisses Restrisiko bleibt trotzdem. Wenn eine Hashkollision dann wirklich auftritt, dann ist sie auch fast immer harmlos, denn die Wahrscheinlichkeit, dass sie in einer unwichtigen Variante auftritt ist sehr, sehr groß. Wie wir wissen, sind schließlich 99.99% aller Varianten, die ein Schachprogramm berechnet, unwichtig.

Tritt eine Kollision allerdings in einer wichtigen und sinnvollen Variante auf, dann kann es schon Probleme geben. Stellen sie sich vor, sie Wissen dass eine Stellung mit einer Dame und einem Turm mehr sehr, sehr gut ist und plötzlich übernehmen sie diesen Wert einfach für eine völlig andere Stellung, in der womöglich noch die andere Seite einen Springer mehr hat.

Falls sie jetzt denken, dass das Spiel eines Schachprogramms eine reines Zufallsprodukt ist und nur mit großem Glück und ohne dadurch Kollisionen zu vernünftigen Ergebnissen führen kann, dann kann ich sie hier beruhigen, in meiner Laufbahn als Schachprogrammierer ist mir bis jetzt noch keine Hashkollision bewusst untergekommen. Hashkollisionen dienen allerdings oft als sehr gute Entschuldigung der Programmierer für extrem dumme Züge ihres Programms, da man so schlecht ja nie programmiert haben kann. Zitat: "Da kann ich nichts dafür, dass muss wohl eine Hashkollison gewesen sein."

Die Größe der HashTabellen

Bei allen Schachprogrammen kann man die Größe der Hashtabellen einstellen, d.h. man legt fest, wie viel Arbeitsspeicher für die Hashtabellen reserviert werden soll. Dabei stellt sich nun die Frage, welcher Wert optimal ist. Allgemein kann man sagen, dass man die Hashtabellen auf gar keinen Fall größer machen soll als freier Arbeitsspeicher zur Verfügung steht. Dies ist in einem modernen Betriebssystem wie Windows ohne Probleme möglich, da Windows dann gerade nicht benötigten Speicher auf der Festplatte auslagert. Man spricht auch von "swappen".

Hashtabellen werden allerdings immer im Speicher benötigt, so dass Windows nicht weiß, was es tun soll, bis es schließlich die Hashtabellen von dem Arbeitsspeicher auf die Festplatte hin und her kopieren muss. Dies erkennt man dann an einem wilden, permanenten Gekratzte auf der Festplatte und in einem unendlich langsam ablaufenden Programm. Dies ist unter allen Umständen zu vermeiden, da dadurch das Schachprogramm wie alles andere auf dem Rechner auch völlig ausgebremst wird. Wenn man den Speicher für Hashtabellen zu klein einstellt, dann ist nicht genügend Platz für die untersuchten Stellungen und ältere Einträge, die später evtl. noch benötigt werden, müssen gelöscht werden. Man sieht auch, dass die optimale Größe der Hashtabellen auch von der Bedenkzeit und damit von der eingestellten Spielstufe abhängt, denn wenn ein Programm länger rechnet, dann hat es ja auch mehr abzuspeichern.

Dies hört sich alles sehr kompliziert an, doch wird einem die Arbeit in der Regel automatisch abgenommen, indem die Programme den zur Verfügung gestellten Speicher stets optimal ausnutzen. Man kann daher in meinem Programm Shredder die Hashtabellen stets so groß wie möglich einstellen, ohne dass man dadurch irgendwelche Nachteile für das Programm befürchten muss. Der wirklich zur Verfügung stehende Speicher darf dabei natürlich nicht überschritten werden. Wenn man auch nur Blitzschach spielen möchte, dann bringt es sicher auch nicht viel, sich noch 128 MB Speicher extra dafür zu kaufen, um Shredder statt 100 MB 200 MB für Hashtabellen zur Verfügung zu stellen. Wer dies möchte kann es aber natürlich auch tun, es schadet nichts und für die Analyse bringt es später dann wirklich etwas.

Fazit

Nachdem sie nun wissen was Hashtabellen sind und wie groß man sie einstellen soll, stellt sich die Frage, was sie denn nun eigentlich bringen. Es sollte klar sein, dass sie immer wichtiger werden, je weiter ein Programm voraus schaut, da dann die Anzahl der möglichen Zugumstellungen natürlich viel größer wird. Da es im Endspiel weniger Zugmöglichkeiten für eine Seite gibt als im Mittelspiel oder in der Eröffnung und das Programm deshalb weiter voraus schauen kann helfen Hashtabellen im Endspiel natürlich viel mehr. Das Paradebeispiel für den Nutzen von Hashtabellen ist die folgende Stellung:

8/k7/3p4/p2P1p2/P2P1P2/8/8/K7 w - -

Durch die blockierten Bauern können zunächst nur die Könige ziehen, dadurch ergeben sich eine Unmenge von möglichen Zugumstellungen. Der Lösungszug 1.Kb1 wird ohne die Hilfe von Hashtabellen nicht oder erst nach einigen Tagen des Rechnens auch auf einem sehr schnellen Computer gefunden. Mit Hashtabellen sieht die Sache dann ganz anders aus. Schon nach wenigen Sekunden zeigt der Computer an, dass Weiß mit 1.Kb1 gewinnbringenden Vorteil erreichen kann. Dies ist natürlich ein extremes Beispiel, leider kann so eine Steigerung nicht in allen Stellungen erzielt werden, doch auch im Mittelspiel mit noch sehr vielen Figuren auf dem Brett sind Hashtabellen eine sehr große Hilfe, die man nicht mehr missen will, wenn man sie einmal in seinem Programm implementiert hat.

Stefan Meyer-Kahlen


Lernfunktion

Lernfunktionen

Shredder verfügt über ausgefeilte Lernfunktionen. Die Lernfunktionen verfolgen folgende Ziele:

  • Verbesserte Leistungsfähigkeit in Partien und Analysen

  • Wiedererkennung von Kombinationen

  • Verbesserung des Eröffnungsbuchs

  • Wiederholung von Gewinnpartien bzw. Vermeidung der Wiederholung von Verlustpartien

Die Lernfunktionen verhindern u.a., dass die Tabellen nach jedem Zug gelöscht werden. Dies bewirkt, daß nach dem Spielen eines Zuges verwertbare Informationen in den Tabellen vorhanden sind. Das Programm wird dadurch schneller. Besonders deutlich wird der Effekt in der automatischen Partieanalyse und in der manuellen Analyse beim Zurücknehmen von Zügen.

In Stellungen, in denen während der Berechnung eine deutliche Veränderung der Bewertung auftrat, werden permanent gespeichert. Diese Informationen gehen auch nach dem Beenden des Programms nicht verloren. Falls eine einmal gelernte Stellung erneut berechnet werden muss, dann kann das Programm auf die gespeicherten Informationen zurückgreifen.

Die Option „Buchlernen" verändert die Wahrscheinlichkeiten von Eröffnungszügen aufgrund der Bewertungen im frühen Mittelspiel. Dadurch ist das Programm in der Lage, schlechte Eröffnungsvarianten auszusortieren bzw. vorteilhafte Varianten anzustreben, nachdem sie einmal gespielt wurden.


PGN im Detail

Das Dateiformat-PGN

Das PGN-Format ist ein Standardformat zum Speichern von Schachpartien. Es wird von Shredder wie von vielen anderen Schachprogrammen unterstützt und ist deshalb für den Datenaustausch extrem wichtig. Es besteht z.B. die Möglichkeit, Partien im PGN-Format über die Zwischenablage einzufügen. Im Internet finden Sie z.B. eine Fülle von Partien im PGN-Format, die über die Zwischenablage direkt in Shredder eingefügt werden können.

Einige grundsätzliche Informationen zum PGN-Format sind sicher nützlich.

Am Anfang einer im PGN-Format gespeicherten Partie stehen die eigentlichen Partiedaten. Folgende sieben Datenfelder sind nach dem PGN-Standard zwingend vorgeschrieben:

[Event "?"] (Turnierbezeichnung, eventuell Ereignis)

[Site "?"] (Spielort)

[Date "????.??.??"] (Datum)

[Round "?"] (Runde)

[White "?"] (Name Weiß)

[Black "?"] (Name Schwarz)

[Result "*"] (Ergebnis)

Das Format mit einer Zeile pro Datenfeld, eckigen Klammern und den Anführungszeichen muss zwingend eingehalten werden, sonst sind Probleme beim Einlesen der Daten vorprogrammiert. Bei der Eingabe des Datums sind auch einige Feinheiten zu beachten. Die Angabe des Datums muss zwingend im Format JJJJ.MM.TT erfolgen. Ein Beispiel wäre z.B. 2000.08.11. Nun wird es relativ häufig vorkommen, dass zwar das Jahr der gespielten Partie, nicht aber der Monat und der Tag bekannt ist. In solchen Fällen muss man folgende Schreibweise verwenden: 2000.??.??. Für die Angabe des Ergebnisses sind vier Werte vorgesehen, nämlich 1-0, 1/2-1/2, 0-1, *.

Im Prinzip können in PGN-Dateien auch Umlaute und sonstige sprachspezifische Sonderzeichen erfasst werden. Typische Beispiele wären z.B. ß, é, ö usw. Generell sollte man auf die Verwendung dieser Zeichen verzichten, da viele Programme (insbesondere aus dem englischsprachigen Raum) diese nicht korrekt wiedergeben.

Stellungsbeschreibungen in PGN

Innerhalb von PGN-Dateien sind durchaus noch weitere Eingaben möglich. So ist es z.B. möglich, auch Stellungsbeschreibungen für Partiefragmente, die nicht in der Grundstellung beginnen, einzugeben. Ein Beispiel für eine Stellungsbeschreibung innerhalb eines PGN-Files sieht wie folgt aus:

[Eingabe "1"]

[FEN "2B3K1/8/3N1p1p/6pk/5P1P/6P1/7r/5r2 w - -"]

Das ganze Procedere ähnelt sehr stark dem EPD-Format, nach den Partiedaten folgt eine Leerzeile und danach werden die Züge, bzw. die Notation aufgelistet. Die Notation ist leicht verständlich: es ist die übliche Kurznotation mit den englischen Figurenkürzeln (KQRBN für KDTLS). Dabei müssen folgende Konventionen beachtet werden:

1.) Vor einem weißen Zug steht immer die Zugnummer, gefolgt von Punkt und Leerzeichen.

2.) Für Schlagzüge ist stets ein "x" zu verwenden, z.B. dxe5.

3.) Für Schachgebote ist ein "+" zu verwenden, z.B. Bb5+.

4.) Ein Schachmatt muss durch "#" gekennzeichnet werden, z.B. Qh4#.

5.) Für Rochaden ist der Großbuchstabe "O" (nicht die Ziffer "0") zu verwenden, z.B. O-O-O.

6.) Remiszüge (Patt, Stellungswiederholung, 50-Züge-Regel) werden nicht gekennzeichnet.

7.) En passant-Schlagzüge werden nicht gekennzeichnet.

8.) Bei Bauernumwandlungen muss vor der Umwandlungsfigur ein "=" stehen, z.B. e8=Q.

Nach der Auflistung der Partienotation folgt wieder ein Leerzeichen, dann das Ergebnis und wiederum eine Leerzeile. Jede Zeile darf maximal 79 Zeichen enthalten und muss (falls notwendig) danach umgebrochen werden. PGN-Dateien können auch Kommentare und Varianten enthalten und zumindest theoretisch gibt es keinerlei Beschränkungen hinsichtlich der Anzahl der zu speichernden Partien in einer einzigen PGN-Datei.


Suchtiefe

Shredder rechnet eine bestimmte Anzahl an Zügen im voraus.

Wurden alle Möglichkeiten analysiert, fängt das Programm erneut mit der Berechnung an, rechnet dann jedoch einen Halbzug tiefer. Shredder unterschiedet bei der Suche zwischen sinnvollen und sinnlosen Zügen. Erstere werden tiefer analysiert (selektive Suchtiefe) als die anderen (vollständige Suchtiefe).

Was bedeutet eigentlich Halbzug ?

Jeweils ein Zug von Weiß oder Schwarz. Ein Zug besteht also aus zwei Halbzügen


Tastaturbefehle

Viele Funktionen können über vordefinierte Tastenkombination, sogenannte "Hotkeys" oder "Shortcuts", bedeutend schneller und flüssiger als mit der Maus abgerufen werden. In der folgenden Übersicht finden Sie eine Aufstellung über die wichtigsten Tastenkürzel innerhalb von Shredder.

Neue Partie | Strg+N | Partie drucken | Strg+Ums+P
Neue Shuffle-Partie | Strg+Ums+N | Stellung eingeben | Strg+D
Datenbank wählen | Strg+J | Programm beenden | Alt+F4, Alt+X
Partie laden | Strg+L | Rechne | Strg+C
Partie speichern | Strg+S | Unterbrechen | Esc
Partie ersetzen | Strg+R | Einfügen | Strg+V
Partie löschen | Strg+Entf | Remis anbieten | Alt+)
Vorherige Partie laden | F7 | Aufgeben | Alt+(
Nächste Partie laden | F8 | Zugvorschlag | Strg+H
Stellungsdatenbank wählen | Strg+Ums+J | Jokeranalyse | Alt+E
Stellung laden | Strg+I | Hauptvariante vorspielen | F11
Stellung speichern | Strg+E | Hauptvariante einfügen | Strg+Einfg
Vorherige Stellung laden | F9 | Besten Zug einfügen | Einfg
Nächste Stellung laden | F10 | Partiedaten | Strg+Z
Letzte Dateien | Strg-X | Kommentar eingeben | Strg+M
Benutzerstufe | F2 | Variante aufwerten | Strg+Pfeil-auf
Analyse | Strg+A | Variante löschen | Entf
Normal | Strg+1 | Restliche Züge löschen | Ums+Entf
Züge eingeben | Strg+2 | Autoplayer starten | Strg+0
Triple Brain | Strg+B | Engine-Zweikampf | Strg+8
Weniger Züge analysieren | F5 | Aktuelle Partie beenden | Strg+9
Mehr Züge analysieren | F6 | Schachbrett | Strg+F1
Partie analysieren | Strg+F10 | Uhren | Strg+F2
Nächste EPD-Stellung | Strg+X | Notation | Strg+F3
3D-Grafik | Strg+3 | Suchinformation | Strg+F4
Brett drehen | Strg+F | Züge | Strg+F5
2D-/3D-Brett wechseln | F4 | Bewertungsprofil | Strg+F6
3D-Figuren wechseln | F3 | Symbolleiste | Strg+F8
Optionen | F 12 | Statuszeile | Strg+F9
Permanent Brain | Strg+P | Onlinehilfe | F1
Engineoptionen | Strg+T | J´adoube | Strg+Rück
Hashtabellen | Alt+H | Partie (PGN) kopieren | Strg+Ums+C
Engine wechseln | Strg+Q | Stellung (EPD) kopieren | Strg+Alt+C
Engine hinzufügen | Strg+Ums+Q | Analysefenster kopieren | Alt+Ums+C
Engine schließen | Alt+Q | Zug zurücknehmen | Pfeil-links
Optionen anzeigen | Alt+J | Zug vorspielen | Pfeil-rechts
Layout: Alle Fenster | Strg+Ums+1 | 5 Züge zurück | Pfeil-auf
Layout: Analyse | Strg+Ums+2 | 5 Züge vorspielen | Pfeil-ab
Layout: Ernste Partie | Strg+Ums+3 | Variante zurücknehmen | Bild-auf
Layout: 3D-Brett | Strg+Ums+4 | Variante vorspielen | Bild-ab
Layout ändern | Strg+W | Alles zurück | Pos1
Benutzerlayout | Strg+Y | Alles vor | Ende
Benutzerlayout laden | Strg+Ums+Y | Uhr neu stellen (+30 sec) | Alt+“+“
Legale Züge | Strg+Ums+L | Uhr neu stellen (–30 sec) | Alt+“–“
Buchzüge | Strg+Ums+B | Gehe zu Zug | Strg+G
Endspieldatenbank | Strg+Ums+E | Partie vorführen | Strg+K
Anzeige aus | Strg+Ums+A | Neues Engine-Turnier starten | Strg+7
Buchoptionen | Strg+O | Engine-Turnier forsetzten | Strg+Ums+7
Aktuelle Partie importieren | Strg+U | Registrieren | Ums+F1
3D-Steuerung Numerischer Tastenblock |  | Fenster Suchinformationen |
Nach links drehen | Num0 | Eine Zeile nach oben | Strg+Ums+Pfeil-auf
Nach rechts drehen | Num, | Eine Zeile nach unten | Strg+Ums+Pfeil-ab
Nach hinten kippen | Num9 | Eine Seite nach oben | Strg+Ums+Bild-auf
Nach vorne kippen | Num3 | Eine Seite nach unten | Strg+Ums+Bild-ab
Nach links schieben | Num4 | Anfang | Strg+Ums+Pos1
Nach rechts schieben | Num6 | Ende | Strg+Ums+Ende
Noch oben schieben | Num8 | Löschen des Inhalts | Strg+Ums+Entf
Nach unten schieben | Num2 | Momentaner Scrollstopp | Strg+Ums
Brett vergrößern | Num+ |  |
Brett verkleinern | Num– |  |
Figuren vergrößern | Num7 |  |
Figuren verkleinern | Num1 |  |


Turnierrating berechnen

In Shredder ist eine sehr interessante Funktion implementiert, um das Elo-Ergebnis einer Begegnung ausrechnen zu lassen.

Die Eingabe der Information erfolgt über die Befehlszeile , die automatisch nach der Eingabe eingeblendet wird.

Wenn z.B. Programm X gegen Programm Y ein Ergebnis von +4 =3 -3 erzielt hat, können Sie im Shredder-Bildschirm folgende Eingabezeile eingeben:

tp 4 3 3

Im Analysefenster zeigt Shredder dann die folgende Information an:

10 +4 =3 -3 55.0% TP = +40 ELO 95% ? [-177,+257]

Diese Anzeige beinhaltet folgende Information:

es wurden insgesamt zehn Partien gespielt, davon vier gewonnen, drei unentschiedene Spiele und drei Verluste. Die Turnierleistung liegt damit 40 Elopunkte über dem gegnerischen Durchschnitt und mit einer 95%igen Wahrscheinlichkeit bewegt sich die Elozahl des betreffenden Spielers in einem Fenster zwischen -177 bis +257.

Nimmt man eine höhere Anzahl von Partien als Grundlage, fällt die Berechnung natürlich präziser aus. Bei Nutzung des Features sollten folgende Einschränkungen beachtet werden:

Das Elosystem macht nur dann Sinn, wenn beide Spieler nicht mehr als 400 Elo-Punkte Unterschied haben, deshalb beträgt die Maximaldifferenz 400 Elo.

Wenn ein Spieler 100% gewinnt, kann keine sinnvolle Bewertung vorgenommen werden, da der Spielstärkeunterschied zwischen beiden Kontrahenten beliebig groß sein kann.


Winboard

Winboard-Engines

Viele Schachprogrammierer sind Amateure und haben neben dem eigentlichen Hauptberuf sehr wenig Zeit, eine eigene Benutzeroberfläche mit grafischem Schachbrett, Dateiverwaltung usw. zu entwickeln. Die Freeware Winboard von Tim Mann stellt eine universelle Benutzerschnittstelle zum Einbinden von Schachengines dar und kann ausserdem zum Spielen auf Schachservern im Internet eingesetzt werden.

Das Winboard kann im Internet von der Webseite von Tim Mann unter der URL http://www.research.digital.com/SRC/personal/Tim_Mann/home.html geladen werden. Dort finden Sie eine Übersicht über verfügbare Winboard-Engines und Links zu diesem Thema.

Shredder unterstützt neben der eigenen UCI-Schnittstelle das Protokoll des Winboards. Dies bedeutet, dass die meisten Winboard-Engines unter der Oberfläche von Shredder eingesetzt werden können.

Vorzüge von Winboard-Engines

Es gibt eine Vielzahl von mehr oder weniger spielstarken Winboard-Engines. Die Vorzüge sind:

  • Winboard-Engines laufen mittlerweile unter fast allen kommerziellen Programmoberflächen, z.B. auch Shredder.

  • Die Engines sind -- bis auf wenige Ausnahmen -- durchweg kostenlos.

  • Die Engines spielen in der Regel deutlich schwächer als die Top-Programme. Der Anwender hat bessere Chancen, eine Partie zu gewinnen.

  • Das System hat sich mittlerweile etabliert und wird von vielen Programmautoren unterstützt. Die Auswahl an verfügbaren Engines wird immer grösser.

Nachteile von Winboard-Engines

Je nach Engine ist die Einbindung unter dem Winboard oder einer der alternativen Oberflächen mehr oder weniger kompliziert.

  • Winboard-Engines müssen in der Regel über externe Dateien konfiguriert werden.

  • Es gibt keine einheitlichen Dialoge zum Einstellen und Modifizieren einer WB-Engine

  • Das WB-Protokoll unterstützt nicht die Vereinheitlichung von Grundoptionen beim Einbinden und Konfigurieren der Engines


Zwischenablage

Zwischenablage / Clipboard

Die Zwischenablage oder das Clipboard ist ein wichtiges Hilfsmittel unter Windows, um Daten innerhalb von verschiedenen Anwendungen auszutauschen. Auch Shredder unterstützt dieses Feature. Sie können z.B. Partien und Stellungen über die Windows-Zwischenablage importieren und exportieren. Dies geschieht mit den Befehlen „Kopieren" und „Einfügen" aus dem Befehle-Menü.

Es werden universelle Speicherformate verwendet, also PGN für Partien und EPD für Stellungen.

Sie können den kompletten Inhalt des Analysefensters oder aber auch nur die Analyse der letzten Stellung in die Zwischenablage kopieren.

Die Partienotation kann im Textformat in die Zwischenablage kopiert werden.

Es gibt verschiedene Möglichkeiten, diese Funktion zu nutzen:

  • Schnelles Speichern einer Stellung oder Partie, um sie später wieder zu laden.

  • Importieren einer Stellung oder Partie, z.B. aus dieser Hilfedatei.

  • Exportieren einer Partie z.B. in eine Textverarbeitung.