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Shredder User Manual 
 
 
Shredder by Stefan Meyer-Kahlen 
Shredder Classic 3, Shredder 11  und Deep Shredder 11 are commercial chess programs by 
Stefan Meyer-Kahlen available on www.shredderchess.com and www.shredderchess.de. 
This manual gives you all the information you need to use Shredder efficiently for playing and 
analysing chess games. 
 
 
Note 
Shredder Classic 3, Shredder 11 and Deep Shredder 11 are copyright protected programs. 
 
For 30 days you can try out the test version of Shredder Classic free of charge and without obligation. 
After 30 days you either need to register or you need to delete Shredder Classic from your hard drive. 
 
There are no test versions of Shredder 11 and Deep Shredder 11 available. However the 
user interface of all three programs is the same, the difference is the integrated chess engine and the 
available extras for each program. 
 
 
Registration 
If you would like to use Shredder Classic after 30 days of testing you have to purchase a license code 
and register it. Shredder 11 and Deep Shredder 11 need to be registered at the first program 
start with a purchased license key. 
 
You will find more information at www.shredderchess.com and www.shredderchess.de 
 
If you would like to purchase a license code you can just click on the Purchase Code button which will 
automatically bring you to the registration page in the Internet. 
Directly after your payment is received you will get a license code together with your desired 
registration name. You have to enter both in the following dialog. 
 
 

 
 
 
You have to enter the name and code exactly the same as you have received it with your registration. 
 
Usually you get your code by email. It is recommended to enter the code in Shredder 
via the clipboard. To do so mark the code in your email program and copy it with command key+C to 
the clipboard. Now click in Shredder in the edit field for the code and type command key+V. 
If you have entered a valid code you should be able to click on the "Register" register button to register 
Shredder. If this doesn't work please check if you have entered name and code correctly. 
 
 



After successfully registering Shredder you can use the program unlimited and without any restriction 
and of course the dialogs asking you to register won't appear any longer. 
 
 
Contact 
You reach the homepage of Shredder in the internet at www.shredderchess.com and 
www.shredderchess.de
 
 
Stefan Meyer-Kahlen 
Shredder is a series of chess programs by Stefan Meyer-Kahlen. 
 
Stefan Meyer-Kahlen works on Shredder since 1992. Since 1996 Stefan Meyer-Kahlen with his 
computer chess program Shredder has already won twelve titles as World Computer Chess 
Champion. 
 

• 1996 World Micro Computer Chess Champion in Jakarta 
• 1999 World Micro Computer Chess Champion in Paderborn 
• 1999 World Computer Chess Champion in Paderborn 
• 2000 World Micro Computer Chess Champion in London 
• 2001 World Micro Computer Chess Champion Single CPU in Maastricht 
• 2002 World Computer Chess Blitz Champion in Maastricht 
• 2003 World Computer Chess Champion in Graz 
• 2003 World Computer Chess Blitz Champion in Graz 
• 2004 World Computer Chess Blitz Champion in Tel Aviv 
• 2005 World Computer Chess Blitz Champion in Reykjavik 
• 2006 Chess960 Computer Chess Champion in Mainz 
• 2007 Computer Chess Blitz Champion in Amsterdam 

 
 
Additionally he has gained further victories and excellent results in important computer chess 
tournaments, such as the IPCCC in Paderborn or the Open Dutch Computer Chess Championships. 
The opening book was made by the Italian expert Sandro Necchi and was especially designed to suit 
Shredder's playing style. 
 

http://www.shredderchess.de/


Using Shredder 
 

 
Menus 
 
You can activate Shredder's functions via the menu at the top of the screen. 
The following pull down menus are available: 
 

• Menu Shredder 
• Menu File 
• Menu Edit 
• Menu Mode 
• Menu Windows 
• Menu Help 

 
Some menus contain sub menus with more commands. You can also call many functions from the 
context menus which will appear when you right click in a window. 
 
 
Menu Shredder 
 
Preferences 
You can change here the settings, i.e. engine options, book options, language etc.  
Shortcut: command key+, 
 
 
Menu File  
 
New Game 
Starts a new game with the last settings, e.g. playing level 
Shortcut: command key+N 
 
Load Game  
Shows a list of the games in the active database. To load a game double click on its entry in the list. 
You can reduce the choices with the filter.  
Shortcut: command key+O 
 
Next Game 
If a game was already loaded you can load the next game in the database using this command. 
Shortcut: Shift+command key+O 
 
Save Game 
Saves the current game in the active database. 
Enter the names of the players, the tournament, the venue, the result etc. in the mask. 
If you enter the complete data it will be easier to find the game later. 
Shortcut: command key+S 
 
Print Game 
Prints the notation of the current game. 
 
Print Position 
Prints the position. 
 
Edit Position 
Opens the dialog for setting up a position. The current position on the chess board appears as the 
default position. To enter a piece, click on the desired piece on the right of the chess board.  
Below the mouse pointer you can see the piece you have selected. Now you can click on any square 
to place the piece on that square. 
Shortcut: command key+D 
 



 
Menu Edit 
 
Copy Position 
Copies position to the clipboard.  
Shortcut: command key+C 
 
Copy Game 
Copies the notation to the clipboard. 
Shortcut: Shift+command key+C 
 
Paste 
Imports the content of the clipboard into Shredder. This can be either a game in PGN format 
or a position in EPD format. 
Shortcut: command key+V 
 
Game Details 
Shows the dialog for entering the game details. 
 

                     
 
 
Flip Board  
Turns the chess board and you can play a game with the black pieces from the right side of the board. 
Shortcut: command key+F 
 
Offer Draw 
You can offer a draw to the program if it is your turn to move. This command is only possible when 
playing a game. You will receive an answer from Shredder whether the offer was accepted or 
declined. 
 
Resign 
You can resign a game when playing against the program. 
 
Stop Clock 
Stops the clock.  
 
Set Clocks 
Changes the time on the clock. 
 



Take Back All 
Jumps to the start of the game 
 
Take Back Move 
Takes back the last move 
Shortcut: left arrow 
 
J`adoube 
If you have entered a wrong move you can take it back.  
 
Redo Move 
Replays the next move form the game 
Shortcut: right arrow 
 
Redo All 
Jumps to the end of the game.  
 
Commenting 
You can promote lines, add or delete commentaries or you can evaluate positions.  
 
 
Menu Mode 
 
Analysis 
Starts the background analysis of the program. In this mode the engine is not playing any moves. 
When entering moves or replaying games the engine permanently displays its evaluation of the 
current position and more info about the search process in the analysis window. 
Shortcut: command key+A 
 
Play against Computer 
In this mode Shredder plays its moves according to the level set. 
Shortcut: command key+1 
 
Enter Moves 
In this mode you can enter moves or games in the program. Shredder is not playing any moves 
himself and no thinking information will be displayed. 
Shortcut: command key+2 
 
Compute / Switch Sides 
Starts the engine to calculate a move. During a game this can be used to switch sides. 
Shortcut: command key+G 
 
Interrupt 
Interrupts the calculating process of the engine. Shredder plays the best move found so far. This 
command is only possible if the engine is calculating. 
Shortcut: command key+I 
 
Levels 
In the levels menu you can define how much time the players are allowed to use. 
Comparable to a human chess player Shredder plays stronger when it has more time. You can choose 
between some predefined and adjustable levels. 
Shortcut: command key+L 
 
Blitz 
Here you can set the time each player is allowed to use for the whole game. Usually the time is set for 
both players. 
 
Increment: the entered value in seconds will be added to the remaining time after every move. This is 
called Fischer clock. 
 
Human Bonus: You can play with more time against Shredder. 



 
Timer Per Move 
In this mode Shredder uses the specified time per move on average. 
Exceptions: 

• Shredder is playing moves from his opening book 
• Shredder has found a mate 

 
Time Controls 
Here you can define up to three different time controls. The third time control will only be available if 
you have entered a second one. With 'all' you can specify that the time has to be used for the rest of 
the game. You can also define an increment which will be added to the remaining time after every 
move. 
 
Limit Strength 
You can reduce Shredder's playing skill to a fixed Elo number. The bigger the number the stronger 
Shredder is playing. If you want to play yourself against the program it is strongly recommended to 
adapt Shredder's playing strength to your own skills. 
 

 Please note that if you set the slider all the way to the right you have not set Shredder to play 
with his full strength. To do this you have to deactivate this option. 
 
Analyse Game 
Shredder can automatically analyse the current game and search for mistakes. 
  
Shootout 
The program is playing against itself. You can use this mode to let Shredder finish a game for both 
sides from a given position. 
 
 
Menu Windows 
 
Board, Clocks, Histogram, Game, Search Information 
A checkmark shows, that the window is open. 
 
All Windows to front 
Activates all Windows which belongs to Shredder.  
 
Layout 
You can choose different layouts.  
 
Analog Clock 
Shows the analog clock 
  
Digital Clock 
Shows the digital clock 
 
 
Menu Help 
 
Hint 
If it is your turn to move you can ask Shredder for a hint. Shredder will show his suggested move on 
the graphical chess board. The hint will be shown with a green arrow.  
Shortcut: command key+T 
 
Show Threat 
A red arrow shows a threat.  
 
Coach is watching 
Switches the chess coach on or off. The coach will warn you when you have played a weak move. 
 



Register 
Here you can register Shredder with your name and your personal license code. If this command is 
not available Shredder as well as the current engine are already registered. 
 
Shredder Homepage 
Calls the homepage of Shredder in the internet. 
Use this to keep track of new developments in Shredder. 
 
 
Context menu 
 
Each window has its own context menu. 
Ctrl+click or right click with the mouse opens a context menu in every window.  
 
Context menu in the notation window 
 
Move Variation Up 
Here you can upgrade variations. 
 
Delete Variation 
Variations can be deleted.  
 
Delete Rest of Game 
Deletes the last moves of the selected variations. 
 
Enter Comment 
You can enter a comment for the selected move.  
 
Delete All Comments 
Deletes all comments in the games.  
 
Position / Extra  
Evaluate the positions with special symbols.  
 
Remove all variants 
Deletes all variations.   
 
 
Context menu in the clock window 
 
Set Clocks 
Here you can change or adjust the clocks 
 
Stop Clock 
Stops the clock 
 
Levels 
You can set how strong Shredder should play and define different options like time per game, time per 
move etc. 
 
Analog Clock  
Selects the analog clock. 
 
Digital Clock 
Selects the digital clock 
 
 
Context menu in the window Search Information 
 
Compute / Switch Sides 
Starts the engine to calculate a move. During a game this can be used to switch sides. 



 
Interrupt 
Interrupts the calculating process of the engine. Shredder plays the best move found so far. This 
command is only possible if the engine is calculating. 
 
Analyse Less Moves 
Decrease the number of lines for analyse.  
 
Analyse More Moves 
Increase the number of lines for analyse. 
 
Engine Options 
Opens the dialog with the engine options. 
 
 
Context menu in the board window 
 
Flip Board 
Turns the chess board and you can play the game with black from the right side of the board. 
 
Edit Position 
Opens the dialog for setting up a position. The current position on the chess board appears as the 
default position. To enter a piece, click on the desired piece on the right of the chess board.  
Below the mouse pointer you can see the piece you choose. Now you can click on any square to 
place the piece on that square. 
 



General Options 
 

 
 
 
 
Animation Speed 
Adjusts the speed how fast the pieces are moving on the chess board. If set to slow the pieces will 
directly jump from the start to the target square. 
 
Language 
You can choose different languages.  
 
Move Sound 
The program will play a sound if a move is played on the chess board. 
 
Show Arrows 
Activates or deactivates the arrows which shown the last move.  
 
Show Legal Moves 
On lifting a piece, all possible target squares for that piece become highlighted. The colour of the 
bullets indicates if the piece on that square will be attacked/undefended, defended or if it is not 
attacked at all. 



 
Fast Mouse Input 
If only one piece can move to a target square it is sufficient to click on the target square to make this 
move. 
 
Example: If you click on e4 in the starting position, the move e2-e4 will get executed instantly. Similarly 
a clicked piece will move instantly if it only has one legal move. 
 
If you turn off this option, you have to click on both the start end target square or drag the piece to its 
destination. 
 
Coordinates 
Switches the display of the coordinates on the graphical chess board on or off. 
 
Boards 
You can choose different chess boards  
 
Piece type 
You can choose different styles for the pieces.  
 



Screen Layout  
 
 
The Shredder display consists of five windows and one menu bar.  
 

 
 
 
 
Each window can be closed or open in the Windows menu. You can change the size of the windows 
or move them with the mouse. 
  
There are different predefined layouts. You can select them in the Windows menu.  
 
 
Chess board 
The chess board is displayed in 2D. The size of the chess pieces will automatically adapt when you 
resize the chess board. 
 
The colours of the chess board can be changed with the menu 
Shredder > Preferences > General > Custom. 
 
The coordinates, labels of ranks and files on the chess board can be hidden with  
Menu Shredder > Preferences > General > Coordinates. 
 
The last move from Shredder will be shown with a coloured arrow. The arrow will disappear when you 
move the mouse.  
 
 
Clocks 
You can see two analog clocks or two digital clocks with green numbers.  
 
 



Histogram 
The histogram shows the evaluation of Shredder. With the histogram you can, for example, see 
precisely where mistakes has happened in the game. An advantage for white is shown at the top, an 
advantage for black at the bottom. By clicking into the window you can directly jump to that specific 
position. 
 

  
 
 
 
Game 
This window shows the moves of the game with variations, commentary and the game details. 
  

         
 
 



Search Information 
 

 
 

•  evaluation 
•  search depth 
•  time 
•  best line so far 
•  number of the evaluated positions per second 

 
The best line so far is displayed in a different color. 
 



Basic features 
 
 
 
Playing a game 
 
Enter Moves 
The easiest way to enter moves is with the mouse on the graphical chess board. Move the mouse to 
the desired piece, click on the piece with the mouse button and move the piece to the desired 
square with the mouse button still pressed. 
 
New game 
You can start a new game anytime you want. 
File > New Game in the menu or use the shortcut command key+N.  
 
Special moves 
 

• To capture a piece, enter your piece’s move only. 
• To castle, enter the king’s move only. 
• To capture a pawn en passant, enter only the move of the capturing pawn. 
• To promote a pawn, move it to the final rank. This will open up a dialog in which you can 

select the promotion piece. 
 
 
Shredder is thinking 
When Shredder is thinking you can see a blinking point in the window search information.  
When Shredder plays a move, the piece it has moved is marked with a coloured arrow. This shows 
that it is your turn. The arrow disappears when you move the mouse or touch a key. 
 
Some menu commands are not available when Shredder is thinking. They appear in light grey 
characters (= disabled). You also cannot enter moves until Shredder has moved. 
 
At the beginning of a game Shredder consults its opening book and plays its moves instantaneously. 
 
To interrupt Shredder's thinking process at any time choose Mode > Interrupt.  
Shredder will then play the best move found so far. 
  
 
End of game 
At the end of a game Shredder displays one of the following messages. 

• Checkmate 
• Stalemate! Draw! 
• Draw! Not enough material left to win! 
• Draw because of 3rd repetition! 
• Draw because of 50 moves rule! 

 
 
Playing a game with black 
You can turn the chess board with Context menu > Flip board or with the hotkey command key+F 
Let Shredder play a move with Compute from the Mode menu or command key+C 
 
Replaying moves 
You can navigate in the game notation using the navigation buttons in the board window. The buttons 
are similar to those of a VCR and its meaning should be clear. 
 
 
Taking back and redoing moves 

• to take back the last move press CURSORLEFT 
• to redo a move press CURSORRIGHT 

 



Jump to the start of a game 
Click on the left button below the chess board to jump to the start of the game 
 
Jump to the end of a game 
Click on the right button below the board to jump to the end of the game 
 
J`adoube 
If you have entered a wrong move you can take it back with the arrow button in the middle. 
 
 
Levels 
With the different playing levels you modify the strength and time usage of the chess program. 
You can set the level in the menu Mode > Levels 
 
Analysis mode 
In the analysis mode there is no playing level set as there is no time limit. If you set a level in the 
analysis mode the playing mode will switch to normal. 
 
By pressing command key +A or choosing Analyse from the Mode Menu you switch to the analysing 
mode. 
 
In the analysing mode the chess program is permanently analysing the position but does not play any 
move. You can enter moves for both sides and watch the analysis of the engine in the search 
information window. 
 
The analysing mode is the easiest and most comfortable way for analysing games. 
  
 
Position setup 
You can set up new positions (or modify the current position) on the board at any time. 
Command key+D to open the dialog for editing the current position. The current position is the default 
position in the dialog. 
 

 



 
Set piece 
To add a new piece, click on the desired piece on the right side of the board. 
The chosen piece will be shown below the mouse cursor when moving the mouse over the chess 
board. Click on a square to set the piece on that square. 
Hint: ctrl + „click“: the piece of the opposite color will be placed on that square. 
 
Remove piece 
To remove a piece from a square, double click on that square 
 
Remove all pieces 
You can clear the chess board with the button Clear Board. 
 
Restore current Position 
Click on Curr. Position to undo all changes to the current position. 
 
Button OK inactive 
If the button is inactive, the position on the board is not legal. 
Verify the position on the board and also check the side to move. 
Clicking on Cancel will discard all changes and close the dialog. 
 
Castling rights 
Here you can define which castling move is still legal in the position on the board. If the buttons are 
inactive there is no king or rook on the appropriate square. 
 
 
Game Handling 
 
Databases 
Shredder uses the PGN format to save games in databases. 
 
A database can contain any number of games. In addition to the moves, more game details (name of 
the players, site, tournament, ...), comments and lines can be saved. The PGN format is supported by 
many other chess programs. Also the data is stored in plain text format which makes it easy to 
exchange information between different programs. 
 
 
Saving games 
To save the current game, choose menu File >Save Game or use the shortcut command key+S. 
A dialog will be shown where you can enter more details of the game 
 



 
 
 
It is a good idea to enter at least the name of the players and the event data. This will make it much 
easier to find the game later if you want to load it from the database. Click on Ok to save the game 
in the current database. 
If there is no current database set a dialog will appear where you can choose to save the 
game either in an existing database or in a new database.  
If you want to change database where you want to save the game you can do so by clicking on 
„Append to different database“. 
 
Loading games 
To load a game from a database choose menu File >Load Game or use the shortcut  
command key + O. 
 
Select one game with the mouse and click on Load to load the game. You can also double click on the 
name to load it. 
 
You can limit the choice by a filter where you can search only for the name, or result, year etc. 
You can search for the initial letter or a part of a word.  
 
After loading one game from a database you can load the next and previous game in the database by 
selecting Menu File > Next Game.  
 
 
Commenting games 
With Shredder you can add comments and different lines (alternative moves) to a game. To enter or 
edit comments choose "Enter Comment" from the context menu of the Game window or use Menu 
Edit > Commenting  
You can enter text comments as well as special symbols for moves and positions. 
 
Entering Variants 
If you are entering a new move via mouse when replaying a game, a dialog will appear asking whether 
you want to add the new move as a new line. 
 



 
 
 
You have the following possibilities: 

• New Line 
• New Main Line  
• Overwrite 
• Cancel 

 
 
Editing Variations 
 
You can delete lines, change their order or cut lines. 
 

• To delete a line go to any move in the line and choose Menu Edit > Commenting > Delete 
Variation 

• To move a line up choose Menu Edit> Commenting > Move Variation Up 
• To delete the rest of the line go to the last move you would like to keep and choose Menu Edit 

> Commenting > Delete Rest of Game 
 

 



Analysis 
 
 
Analysis mode 
With command key + A or Analysis in the Mode menu you can switch on the analysis mode. 
 
In the analysis mode the chess program is permanently analysing the position but is not playing any 
move. You can enter moves for both sides and can constantly watch the analysis of one or more 
engines. 
 
The analysis mode is the easiest, most common and most comfortable method for analysing. 
 
 
Multi-Variants Mode 
When analysing a position Shredder can not only search for the best move but also analyse any 
number of moves. 
 
In the context menu you can increase the number of moves to analyse. The program will display a list 
of the best moves found together with the evaluation and main line. You can decrease the number of 
moves again in the context menu.  
 
The bigger the number of moves to analyse, the slower the analysis will be. Therefore you should 
disable the multi line analysis If you only want to know only the best move. 
 



Multi Engine System 
 
 
Shredder was designed as a multi engine system. 
 
This means that the user interface and the chess engine are strictly separated. They communicate via 
a specially designed protocol. This way you can use different chess engines in one user interface. 
Shredder supports UCI engines.  
 
 
UCI-engines 
UCI stands for Universal Chess Interface. It was developed by Stefan Meyer-Kahlen and Rudolf Huber 
and is similar to the Winboard interface but has numerous advantages. 
 

• UCI engines are automatically detected and installed by Shredder. 
• UCI engines can be configured with standardised dialog masks. Neither basic nor engine 

specific functions need external configuration dialogs.  
• UCI engines have access to all functions of the Shredder interface. 

 
 You can find the documentation of the UCI protocol at www.shredderchess.com. 

 
 
Engine options 
UCI engines can have engine options which allow changing certain parameters in the engine. They 
can be easily modified in the integrated dialog box. 
 
Some possible options are: 

• the evaluation of every piece 
• the evaluation of king safety 
• selectivity 
• draw value 
• learning 

 
The engine option dialog varies from engine to engine.  
Here are the details for the Shredder engine. 
 
Engine in Shredder are represented by a file with the extension *.eng. You can modify the options of 
any engine and save it as a new engine. Those engines will be treated like real engines in the engine 
dialog boxes.  
 
 
Install engine  
 
Menu Shredder > Preferences  > Install new engine 
This function installs an engine in the Shredder user interface. 
 
To install an engine in Shredder to the following: 

• Choose Install Engine from the Engines menu in the Extras menu. 
• Choose the path to the engine 
• Set the names of the engine and author. 

 
After these steps the engine can be loaded in Shredder. 
 
 
Change engine 
 
Replaces the active engine with a new one. 
Menu Shredder > Preferences you can choose an Engine.  



 
 
Shredder’s engine options 
 
Engine 
Here you can choose between different styles of playing, i.e. the parameters can be changed, like 
value of the pieces. 
 
Hash Tables 
The computer must be equipped with enough RAM  for the given size of the hash tables. 
 
MultiPV 
Multi variation mode. In analysis mode, not only the very best move is calculated. Caution: using 
MultiPV makes it take longer to reach the same depth of calculation. 
 
Permanent Brain 
Shredder also uses your thinking time for its calculations. 
 
Engine with low priority 
Reduces the priority for the engine process so that other tasks get the computing ressources needed. 
 
Save engine evaluations as comments 
Inserts the engine evaluations in the notation. 
 
Engine resigns or offers draw 
The engine will resign when it is hopeless to continue and will also offer draws. 
 
You can modify the chess algorithms of Shredder and save different styles as a new engine. Those 
modified engines can be used like real chess engines in the engine dialogs. 
 

You can call the engine options dialog from the menu Shredder > Preferences > Engine options 
> Extended 
 

Hint: The options depend on the active engine. 
 
 
Keep Hash Tables: 
Shredder is never clearing his internal hash tables -> this is good for games and analysis. 
 
Position Learning: 
Shredder remembers positions he has already analysed and played. With this option Shredder is 
trying to learn from his mistakes. 
 
Prefer Open Positions: 
The program prefers open positions. This may not always result in the best 'absolute' move being 
selected, but rather the move that is most difficult for the opponent to play against. 
 
Draw Score 
This specifies how Shredder is evaluating a draw. If the value is below 0 Shredder is playing to win, if 
the value is greater 0 often a draw is good enough. 
 
Clear Hash: 
After clicking on OK the internal hash tables are cleared. This option helps to get reproducible results. 
 
Clear PosLearing: 
Clears the file with all learned data from the hard disk. Shredder is loosing his learned knowledge. 
 



 
 
 
Use Tablebases: 
Set how Shredder is using the Nalimov endgame databases in its search. 
Never: Shredder never accesses the endgame databases 
Late: Shredder accesses them late and will not be slow down much. 
Normal: Shredder accesses them reasonably. 
Early: Shredder accesses them early and can sometimes be slow down a lot 
 
Use Shredderbases: 
Set how Shredder is using the Shredderbases in its search. 
Never: Shredder never accesses the Shredderbases 
LikeTB: Shredder accesses them as often as the Nalimov endgame databases. 
Normal: Shredder accesses them almost everywhere. 
Always: Shredder accesses them everywhere 
 
Values for the pieces: 
Specifies the value of the pieces in %. The default value for all pieces is 100%. For example if 
Shredder is sacrificing too many pawns you can set the value for pawns to 110%. If you set the value 
below 100% Shredder is more willing to sacrifice pawns. You can set the values for all pieces 
depending on the game stage. 
 
Weights for the evaluation parameters: 
You can set the weight in % for the most important evaluation parameters in Shredder. 



 
King Safety 
Sets the parameter for king safety 
 
Center Control 
Sets the parameter for center control 
 
Pawn Structure 
How should Shredder evaluate certain pawn patterns on the board? 
 
Passed Pawns 
If for example you think that Shredder is over evaluating passed pawns you can set this value to 90 %. 
 
Bishop Pair 
How much should Shredder evaluate the bishop pair 
 
Time Usage 
With bigger values Shredder is playing slower but will certainly obey the time controls. 
 
Knowledge or Speed 
With smaller values Shredder's evaluation is faster but not so precise. 
 



Book Options 
 
 
You can change the options for the opening book in the Book Options tab in the Preferences dialog. 
 
There are 4 settings: 

•  
• Only Best Move: only the best move will be played 
• Tournament: only good moves will be played and better moves will get a higher priority 
• Standard: only good moves will be played 
• Wide: all moves have the same weight and will be play with the same probability 
 

Here you can also change the opening book to a different book by clicking on Change Book. 
 



FAQ 
 
 
Shredder 
 
How can I load or save a game?  
In the menu File > Save Game you can save the current game in a PGN database 
With Menu File > Load Game you can load a game from a PGN database. 
 
What does the information in the Search Information window mean? 
In the window search information you can see the following information: 
 

• Evaluation in pawn units 
• Search depth 
• Current be line 

 
 
I always lost against Shredder.  
In the Menu Mode > Levels you can reduce Shredder's playing strength. It is highly recommend to use 
the limit strength feature when you play against Shredder yourself. 
 
 
General 
 
Pawn units 
A chess program evaluates positions in pawn units. 
Here are the values for each piece on the board. 
 

• Queen 9 pawn units 
• Rook 5 pawn units 
• Bishop 3 pawn units 
• Knight 3 pawn units 
• Pawn 1 pawn units 

 
Positional factors are evaluated in fractions of a pawn. 
 
Databases 
The following file standards are supported by Shredder. 
 
PGN 
The PGN format is widely used on the Internet. In addition to chess moves a lot of information 
(players, venue, year, result, opening code, comments, variations etc.) can also be stored. Games are 
stored as text, so that a PGN database can be edited with any word processing program. 
 
Here is an example of a game in PGN: 
[Event "18th WMCC"] 
[Site "Maastricht"] 
[Date "2001.08.23"] 
[Round "8"] 
[White "Shredder"] 
[Black "Chess Tiger"] 
[Result "10"] 
 
1. d4 d5 2. Nf3 Nf6 3. e3 Bf5 4. Bd3 Bxd3 5. Qxd3 Nbd7 
6. OO e6 7. Nc3 c5 8. e4 cxd4 9. Nxd4 dxe4 10. Nxe4 Be7 
11. Be3 OO 12. Rad1 Qa5 13. Nxf6+ Nxf6 14. Qb3 Nd5 
15. Qxb7 Rab8 16. Qd7 Rfd8 17. Nc6 Rxd7 18. Nxa5 Rxb2 
19. c4 Nf6 20. Nc6 Bf8 21. Rxd7 Nxd7 22. Ra1 Bc5 23. Nxa7 
Bxe3 24. fxe3 Ne5 25. a4 h5 26. a5 h4 27. h3 Nxc4 28. a6 
Nb6 29. Nc6 Kh7 30. a7 Na8 31. Nd8 Kg6 32. Ra4 e5 33. Rxh4 



Ra2 34. Nc6 Ra6 35. Nxe5+ Kg5 36. Rg4+ Kf6 37. Nd7+ Ke7 
38. Nb8 Ra1+ 39. Kh2 Kd6 40. Rd4+ Kc7 41. Rd7+ Kb6 42. Rxf7 
Rxa7 43. Nd7+ Kc6 44. Ne5+ Kb6 45. Nc4+ Ka6 46. Rxa7+ Kxa7 
47. h4 Kb8 48. Nd6 g6 49. Nf7 10 
 
You can cut and paste this game into Shredder. Shredder can load and save game collections in PGN 
format, and is also able to search for specific game information in any PGN database file. 
 
 
EPD 
An EPD file is an ASCII text file which stores chess position. 
The board is described first. The upper case letters PNBRQK represent the white pieces, and lower 
case represent black pieces. Numbers indicate a series of empty squares from 1 to 8. The board 
description starts at a8 to h8, then a7 to h7 etc. The separation of each rank is marked by a slash. 
The side to move is next. It is separated from the board description by one space character and 
consists of "w" or "b", indicating White or Black to move. 
Next are the castling rights, again separated by a space. "Q" indicates that white can castle queen 
side, "K" that he can castle king side. The lower case letters are used if black can castle. If neither side 
can castle at all only a hyphen is used. 
Finally the square on which a pawn can be captured en passant is given, in algebraic notation. If white 
is to move this string can only be a5, b5, c5, etc., or a hyphen if no pawn can be captured en passant. 
Likewise with black to move this string must be a4, b4, c4 etc., or a hyphen. 
Here's an example of an EPD position: 
8/2p5/7p/pP2k1pP/5pP1/8/1P2PPK1/8 w – id “BS-06“;c0 “f2-f3! wins“ 
 
 
Permanent Brain 
"Permanent brain" is the name given to the function that a computer thinks during the opponent's time. 
Essentially a chess engine will try to guess what the opponent is going to play and prepare a reply 
before he has finished thinking about it. If the opponent plays the move that the computer expects the 
computer may reply very quickly or even immediately. If the opponent makes another move the 
computer will have to forget its permanent brain calculations and start thinking about its next move 
again. 
This is the reason why Shredder will sometimes reply instantly, even on slow playing levels. 
You can watch the permanent brain calculations in the engine window. The information is displayed in 
light grey text. 
It is advisable to switch permanent brain off if you wish to carry out timing tests, for example, to see 
how long the Shredder engine takes to solve a particular test position. If permanent brain is on you will 
not get consistent results, since Shredder may have already been calculating the position before you 
started the test. 
So in order to get the most stable results in computer tests you should switch off permanent brain and 
clear the hash tables.  
 
 
ECO 
The ECO (Encyclopaedia of Chess Openings) code is a system to classify chess opening. Each ECO 
code has a letter from A to E and a number from 00 to 99. 
 
 
Fischer clock 
The Fischer clock was invented by former chess champion Bobby Fischer. For every move the players 
will get a time bonus to avoid time trouble. You can use the Fischer clock in Shredder. 
 
 
Endgame Databases 
Many chess programs can play all important major piece endings with three, four and five men on the 
board perfectly. This is to be taken literally. The endgame databases contain full information on every 
legal position that is possible in these endings. At any stage, the program knows whether the position 
is won, lost or drawn, and how many moves it takes to win or lose (assuming perfect play by both 
sides). 



In computer chess there are two different types of endgame databases that are being used at the 
present time: 

• The Thompson databases, generated by Ken Thompson 
• The Nalimov endgame tablebases, generated by Eugene Nalimov 

 
Shredder uses the Nalimov tablebases. It consults these during the search and it can use them in a 
special endgame oracle that allows you to study endgames in a unique manner. 
 
Nalimov tablebases 
These endgame databases were introduced in 1998 and are generally referred to as "tablebases". 
The currently available tablebases contain every possible position in every relevant four and five piece 
endgames. Together with each position there is information on whether it is a win, loss or draw. If a 
position is a win or a loss there is information on the maximum number of moves required up to mate. 
A chess playing program using the Nalimov tablebases will end many games with truly spectacular 
mate announcements. Shredder will often confront you with a "mate in 45 moves", even when there 
are many more pieces on the board. This is because the program has found a line in which it can 
trade down to five pieces and then get a position which is recorded in the tablebases as a forced win. 
 
 
Learning 
Shredder has various learning functions. The learning has the following targets: 

• Improved game play and analysis 
• Recognition of combinations 

 
 
Search depth 
Shredder can calculate a number of moves ahead. The number of moves in this calculation is called 
the search depth and is measured in plies. A ply is one move from either white or black. Thus each 
move consists of two plies. 
 
 
Hotkeys 
 
New Game Command key+N Edit Position Command key+D 
Quit  Command key+Q Load Game  Command key+O 
Save Game Command key+S Next Game Shift+Command key+O 
Preferences Command key+, Copy Position Command key+C 
Copy Game Shift+Command key+C Paste Command key+V 
Flip Board Command key+F Analysis Command key+A 
Take Back Move Left arrow Redo Move Right arrow 
Play Against Computer Command key+1 Enter Moves Command key+2 
Compute / Switch Sides Command key+G Interrupt Command key+I 
Levels Command key+L Show Threat Command key+T 
 



Tips and tricks:  
 
 
Tip 1: You play against Shredder and lose most of the games? No problem, you can set Shredder to 
any playing strength you like. Simply us the limit strength option in the different level dialogs. 
 
Tip 2: You do not like the different coloured arrows and dots on the chess board when playing against 
Shredder? Simply disable the features you do not like in the Preferences dialog. 
 
Tip 3:  It is always a good idea to use the right mouse button Shredder. Many features and functions 
are available via the context menu which will appear when you click with the right mouse button. If 
your mouse has just one button you can also keep the Ctrl key pressed and use the left mouse button. 
 
Tip 4: If you want Shredder to play a greater variety of opening lines you can change the book mode 
to “Wide” in the Book Options section in the Preferences dialog. Please note that Shredder will also 
play some inferior lines in the mode. 
 
Tip 5: The layout of the different windows in Shredder can be changed according to your preferences. 
Simply resize any window in Shredder with the mouse. You can also use one of our predefined layouts 
in the Windows menu. 
 
Tip 6: The chess pieces and the chess board as well as all colours and graphics can be changed in 
Shredder. Simply change what you do not like in the Preferences dialog. 
 
Tip 7: You can select “Hint” from the Help menu anytime to get an advice which move to play in the 
current position on the board. Use this when playing against Shredder and running out of ideas. 
 
Tip 8: When you play against Shredder you can tell him to display a warning each time you have 
entered a bad move. Shredder will warn you and will suggest a better move for you. Use “Coach is 
Watching” from the Help menu to activate this feature. 
 
Tip 9: With “Mode -> Analysis” from the main menu you can switch on the analysis mode in Shredder. 
In this mode Shredder will never execute a move himself but will always start his analysis for the 
current position on the chess board. This way you can manually replay a game or enter new lines on 
the board and Shredder will always give you his evaluation for the current position. 
 
Tip 10: You can let Shredder automatically analyse games. Enter of load a game to analyse and select 
“Analyse Game” from the Mode menu. Shredder will add his comments to the game and show you 
where better moves could have been played. 
 
Tip 11: Did you know that you can access our online endgame database with all 6 men chess 
endgames directly from Shredder? You will instantly get the exact score for every possible position. 
Just setup a position with 6 or less pieces on the board and click on Online EGTB in the Search 
Information windows and then on the Online button. Shredder will then display all legal moves 
together with their score. 
 
Tip 12: Did you know that you can access our online opening database with more than 16 million 
chess moves? Setup a position from the opening or early middle game and click on Book Moves in the 
Search Information windows and then on the Online button. You will instantly get the statistics for all 
moves that have ever been played in the current position. 
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